Großer allgemeiner "WLAN-Probleme-Thread!!

tgraupne

New member
Registriert
25 Feb. 2008
Beiträge
2.008
Da ähnliche Probleme zur Zeit sehr häufig auftreten, wollte ich die Diskussion aus dem "iwlagn power save" thread mal raus holen.

Bei mir wird es gerade so schlimm, dass ich kaum noch mit dem Gerät in der Uni arbeiten kann. Es handelt sich bei mir um ein X61s mit Intel 5100 WLAN Card. Diese beherrscht 5GHz und 150MB/s, normalerweise ;)

Ich nutze den Kernel 2.6.32-5-686, imo Standard bei Debian 6 stable.

Nun zu meinen Problemen:

  1. Beim Booten zeigt mir mein Kernel, dass die Version meiner WLAN firmware nicht aktuell ist und empfiehlt ein update. Die Daten soll es bei www.linuxwireless.org geben. Abgesehen davon, dass ich sie dort nicht finde, habe ich auch ein paar Erfahrungsberichte gefunden, die sagen, dass neuere Versionen noch weniger funktionieren sollen.
  2. Bestehende WLAN Verbindungen sind sehr sehr instabil. Alle paar Sekunden verliere ich die Verbindung. Das thinkpad versucht dann neu zu verbinden, doch dann bekomme ich hier im Uni- WLAN ein paar timeouts und so dauert es sehr lange. Dadurch werden die Abbrüche immer spürbar. Ich habe bereits gelesen, dass dies wohl sehr oft auftritt, Ubuntu nur irgendwann aufgehört hat den Abbruch direkt anzuzeigen sondern im Hintergrund einfach immer wieder neu verbindet.

    Hier ein exemplarischer dmesg output:
    Code:
    [ 3513.728084] wlan1: deauthenticating from c4:7d:4f:57:82:5d by local choice (reason=3)
    [ 3513.729464] wlan1: direct probe to AP c4:7d:4f:57:82:52 (try 1)
    [ 3513.928306] wlan1: direct probe to AP c4:7d:4f:57:82:52 (try 2)
    [ 3514.128139] wlan1: direct probe to AP c4:7d:4f:57:82:52 (try 3)
    [ 3514.328059] wlan1: direct probe to AP c4:7d:4f:57:82:52 timed out
    [ 3526.614831] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 1)
    [ 3526.812132] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 2)
    [ 3526.812933] wlan1: direct probe responded
    [ 3526.812942] wlan1: authenticate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3526.814559] wlan1: authenticated
    [ 3526.814649] wlan1: associate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3526.816900] wlan1: RX AssocResp from c4:7d:4f:57:82:5d (capab=0x111 status=0 aid=6)
    [ 3526.816907] wlan1: associated
    [ 3526.818914] wlan1: deauthenticated from c4:7d:4f:57:82:5d (Reason: 4)
    [ 3526.966682] wlan1: direct probe to AP c4:7d:4f:57:8f:1d (try 1)
    [ 3527.164291] wlan1: direct probe to AP c4:7d:4f:57:8f:1d (try 2)
    [ 3527.364294] wlan1: direct probe to AP c4:7d:4f:57:8f:1d (try 3)
    [ 3527.564084] wlan1: direct probe to AP c4:7d:4f:57:8f:1d timed out
    [ 3529.354686] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 1)
    [ 3529.356977] wlan1: direct probe responded
    [ 3529.356981] wlan1: authenticate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3529.358800] wlan1: authenticated
    [ 3529.358821] wlan1: associate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3529.360762] wlan1: RX AssocResp from c4:7d:4f:57:82:5d (capab=0x111 status=0 aid=6)
    [ 3529.360766] wlan1: associated
    [ 3542.940574] iwlagn 0000:03:00.0: iwl_tx_agg_start on ra = c4:7d:4f:57:82:5d tid = 0
    [ 3653.460073] wlan1: deauthenticating from c4:7d:4f:57:82:5d by local choice (reason=3)
    [ 3653.477379] wlan1: direct probe to AP c4:7d:4f:52:73:d2 (try 1)
    [ 3653.680056] wlan1: direct probe to AP c4:7d:4f:52:73:d2 (try 2)
    [ 3653.682057] wlan1: direct probe responded
    [ 3653.682061] wlan1: authenticate with AP c4:7d:4f:52:73:d2 (try 1)
    [ 3653.683588] wlan1: authenticated
    [ 3653.683608] wlan1: associate with AP c4:7d:4f:52:73:d2 (try 1)
    [ 3653.686888] wlan1: RX AssocResp from c4:7d:4f:52:73:d2 (capab=0x431 status=0 aid=5)
    [ 3653.686891] wlan1: associated
    [ 3713.620296] wlan1: deauthenticating from c4:7d:4f:52:73:d2 by local choice (reason=3)
    [ 3713.621633] wlan1: direct probe to AP c4:7d:4f:52:63:22 (try 1)
    [ 3713.820306] wlan1: direct probe to AP c4:7d:4f:52:63:22 (try 2)
    [ 3714.020161] wlan1: direct probe to AP c4:7d:4f:52:63:22 (try 3)
    [ 3714.220079] wlan1: direct probe to AP c4:7d:4f:52:63:22 timed out
    [ 3726.494816] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 1)
    [ 3726.692263] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 2)
    [ 3726.693138] wlan1: direct probe responded
    [ 3726.693144] wlan1: authenticate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3726.693896] wlan1: authenticated
    [ 3726.693938] wlan1: associate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3726.696257] wlan1: RX AssocResp from c4:7d:4f:57:82:5d (capab=0x111 status=0 aid=6)
    [ 3726.696262] wlan1: associated
    [ 3793.276385] wlan1: deauthenticating from c4:7d:4f:57:82:5d by local choice (reason=3)
    [ 3793.277922] wlan1: direct probe to AP c4:7d:4f:52:63:22 (try 1)
    [ 3793.476302] wlan1: direct probe to AP c4:7d:4f:52:63:22 (try 2)
    [ 3793.676143] wlan1: direct probe to AP c4:7d:4f:52:63:22 (try 3)
    [ 3793.876333] wlan1: direct probe to AP c4:7d:4f:52:63:22 timed out
    [ 3806.179293] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 1)
    [ 3806.376443] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 2)
    [ 3806.377185] wlan1: direct probe responded
    [ 3806.377193] wlan1: authenticate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3806.378262] wlan1: authenticated
    [ 3806.378353] wlan1: associate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3806.380139] wlan1: RX AssocResp from c4:7d:4f:57:82:5d (capab=0x111 status=0 aid=6)
    [ 3806.380148] wlan1: associated
    [ 3807.958233] iwlagn 0000:03:00.0: iwl_tx_agg_start on ra = c4:7d:4f:57:82:5d tid = 0
    [ 3875.149163] CE: hpet increasing min_delta_ns to 22500 nsec
    [ 3893.896302] wlan1: deauthenticating from c4:7d:4f:57:82:5d by local choice (reason=3)
    [ 3893.897925] wlan1: direct probe to AP c4:7d:4f:51:e7:32 (try 1)
    [ 3894.096318] wlan1: direct probe to AP c4:7d:4f:51:e7:32 (try 2)
    [ 3894.296109] wlan1: direct probe to AP c4:7d:4f:51:e7:32 (try 3)
    [ 3894.496095] wlan1: direct probe to AP c4:7d:4f:51:e7:32 timed out
    [ 3906.678436] wlan1: direct probe to AP c4:7d:4f:57:8c:12 (try 1)
    [ 3906.876334] wlan1: direct probe to AP c4:7d:4f:57:8c:12 (try 2)
    [ 3907.076267] wlan1: direct probe to AP c4:7d:4f:57:8c:12 (try 3)
    [ 3907.276085] wlan1: direct probe to AP c4:7d:4f:57:8c:12 timed out
    [ 3912.093325] wlan1: direct probe to AP c4:7d:4f:57:8c:12 (try 1)
    [ 3912.292331] wlan1: direct probe to AP c4:7d:4f:57:8c:12 (try 2)
    [ 3912.492112] wlan1: direct probe to AP c4:7d:4f:57:8c:12 (try 3)
    [ 3912.692273] wlan1: direct probe to AP c4:7d:4f:57:8c:12 timed out
    [ 3924.862992] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 1)
    [ 3925.060332] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 2)
    [ 3925.260299] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 3)
    [ 3925.261237] wlan1: direct probe responded
    [ 3925.261246] wlan1: authenticate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3925.262198] wlan1: authenticated
    [ 3925.262289] wlan1: associate with AP c4:7d:4f:57:82:5d (try 1)
    [ 3925.264488] wlan1: RX AssocResp from c4:7d:4f:57:82:5d (capab=0x111 status=0 aid=6)
    [ 3925.264496] wlan1: associated
    [ 3956.047469] iwlagn 0000:03:00.0: iwl_tx_agg_start on ra = c4:7d:4f:57:82:5d tid = 0
    [ 3982.009170] CE: hpet increasing min_delta_ns to 33750 nsec
    [ 4003.382449] wlan1: deauthenticated from c4:7d:4f:57:82:5d (Reason: 1)
    [ 4006.224951] wlan1: direct probe to AP c4:7d:4f:57:8f:12 (try 1)
    [ 4006.424282] wlan1: direct probe to AP c4:7d:4f:57:8f:12 (try 2)
    [ 4006.624146] wlan1: direct probe to AP c4:7d:4f:57:8f:12 (try 3)
    [ 4006.824079] wlan1: direct probe to AP c4:7d:4f:57:8f:12 timed out
    [ 4019.257842] wlan1: direct probe to AP c4:7d:4f:52:73:d2 (try 1)
    [ 4019.457074] wlan1: direct probe to AP c4:7d:4f:52:73:d2 (try 2)
    [ 4019.657318] wlan1: direct probe to AP c4:7d:4f:52:73:d2 (try 3)
    [ 4019.856116] wlan1: direct probe to AP c4:7d:4f:52:73:d2 timed out
    [ 4022.726889] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 1)
    [ 4022.925194] wlan1: direct probe to AP c4:7d:4f:57:82:5d (try 2)
    [ 4022.926600] wlan1: direct probe responded
    [ 4022.926610] wlan1: authenticate with AP c4:7d:4f:57:82:5d (try 1)
    [ 4022.927549] wlan1: authenticated
    [ 4022.927619] wlan1: associate with AP c4:7d:4f:57:82:5d (try 1)
    [ 4022.929779] wlan1: RX AssocResp from c4:7d:4f:57:82:5d (capab=0x111 status=0 aid=6)
    [ 4022.929788] wlan1: associated
    [ 4041.684051] iwlagn 0000:03:00.0: iwl_tx_agg_start on ra = c4:7d:4f:57:82:5d tid = 0
    [ 4163.380173] wlan1: deauthenticating from c4:7d:4f:57:82:5d by local choice (reason=3)
    [ 4166.210074] wlan1: direct probe to AP c4:7d:4f:57:82:5e (try 1)
    [ 4166.211205] wlan1: direct probe responded
    [ 4166.211213] wlan1: authenticate with AP c4:7d:4f:57:82:5e (try 1)
    [ 4166.213091] wlan1: authenticated
    [ 4166.213124] wlan1: associate with AP c4:7d:4f:57:82:5e (try 1)
    [ 4166.413260] wlan1: associate with AP c4:7d:4f:57:82:5e (try 2)
    [ 4166.415329] wlan1: RX AssocResp from c4:7d:4f:57:82:5e (capab=0x101 status=12 aid=0)
    [ 4166.415338] wlan1: AP denied association (code=12)

    Betreffend dazu fand ich diesen bug report im ubuntu lunchpad:
    https://bugs.launchpad.net/ubuntu/+source/linux/+bug/548992
    Nach den Erfahrungen dort, werde ich auch versuchen den gnome-nm gegen wicd zu tauschen. Doch, wird wicd denn überhaupt noch weiter entwickelt?

    Manchmal geht das ganz auch soweit, dass meine Karte gar nicht mehr verbinden möchte. Sie wird dann nur sehr heiß. Ich habe das Gefühl, dass das ganze bei Draft-N Netzwerken öfter passiert. Kann es leider nur nicht nachweisen. Gibt es dazu eine Möglichkeit den WLAN g- Standard zu erzwingen?

    Unser Uni WLAN besteht aus 2 Netzwerken, einmal eduroam, was einige kennen werden, dieses ist per WPA2 Enterprise gesichert. Und einem sogn. VPN/WEB, welches zunächst offen und dann über IPSec o.ä. gesichert ist.
    Die Abbrüche treten bei beiden auf!
 

lezard

New member
Registriert
27 Sep. 2010
Beiträge
1.571
Habe in meinem X200 mit der Intel 5100 WLAN genau das gleiche Problem unter 7 wie unter XP.

WLAN-n abgestellt, läuft danach ohne Probs mit 54 Mbit...
 

tgraupne

New member
Themenstarter
Registriert
25 Feb. 2008
Beiträge
2.008
Das diese Probleme bei Windows auch auftreten ist mir neue, aber interessante Information. Können das vielleicht noch andere Windows Nutzer bestätigen?
Auf jeden Fall klingt das langsam recht dramatisch, oder?

Wie gesagt würde ich den Versuch gern wagen und n- WLAN deaktivieren, nur weiß ich leider nicht was dafür der richtige Weg wäre.
 

lezard

New member
Registriert
27 Sep. 2010
Beiträge
1.571
Unter Windows ist es mit drei Mausklicks erledigt, aber unter Linux? Heute Abend haben sicher ein paar Admins Zeit und Muße, einem den Weg zu zeigen, ist sicher ganz einfach... ;)
 

ccyx

New member
Registriert
24 März 2011
Beiträge
168
Leg dir unter /etc/modprobe.d/ eine neue Datei mit Endung .conf an, z.B. iwlagn.conf
Dort schreib rein:

Code:
option iwlagn 11n_disable=1

Dann Laptop neustarten bzw. alternativ sollte auch:
Code:
modprobe -r iwlagn; modprobe iwlagn
reichen.
 

tgraupne

New member
Themenstarter
Registriert
25 Feb. 2008
Beiträge
2.008
im moment kann ich es leider nicht versuchen :(
Ich hatte gerade den *nw-manager "gepurged" ;) um *wicd zu installieren.
Hat zunächst auch alles funktioniert.

Was mir direkt auffiel ist, dass wicd aus irgendeinem Grund alle hier erreichbaren AP's anzeigt (ungefär 30), auch wenn es nur 2 verschiedene SSID's gibt. Irgendwie komisch, denn es ist doch ersichtlich, dass man hier "vom AP zu AP springen soll/kann", naja.

Jedenfalls, nachdem ich anfangs verbinden konnte bekam ich dann genau die selben Fehlermeldungen und Abbrüche.
Worauf hin meine Karte immer heißer wurde (über 60°C !!!) Und ich dann gar keine Verbindung mehr aufbauen konnte.
(Die war nur der zeitlich Ablauf, über eventuelle Kausalitäten kann ich keine Aussage machen)

Nun lass ich mein TP erstmal abkühlen und versuche es später zu Hause nocheinmal.
Ich denke ich werde auf jedn Fall wieder den *nw-manager installieren.
Dieser wird wenigstens noch weiter entwickelt.

Ich habe alle #iwconfig und #dmesg outputs gespeichert und werde sie später nachreichen.

*FRUST*
 

buddabrod

New member
Registriert
15 Juni 2007
Beiträge
3.740
Sehr hilfreich sind z.B. manuelles Aufbauen der Verbindung. Zeug wie Networkmanager und WICD gibt es soo lange noch nicht und vor wenigen Jahren waren die mit WPA-Enterprise Verbindungen quasi unbrauchbar. Genauso wie der iwlagn. wpa_supplicant gibt gerne hilfreiche Meldungen aus.
Irgendwo in /var/log sollte der Networkmanager das aber auch loggen.

Ich rate dir dich mit den 5GHz APs zu verbinden, das funktioniert zumindest bei mir immer einwandfrei. Mit 2,4GHz APs habe ich nach kurzer Zeit einfach einen Verbindungsverlust, der sich oftmals nur durch Neuladen des iwlagn Moduls beheben lässt.

Edit: unter 50°C kam meine Intel 4964 fast nie.. Eigentlich überhaupt nie (sofern sie aktiv war).
Die 6300 hat gerade 51°C.

Edit: Bei einem Dateitransfer habe ich nun 61°C. Wenn die Karte permanent aktiv scant, ist eine höhere Temperatur vollkommen normal.
 
Zuletzt bearbeitet:

tgraupne

New member
Themenstarter
Registriert
25 Feb. 2008
Beiträge
2.008
Komisch kommt mir die Temperatur nur vor, weil bei normaler, stabiler Verbindung die Temp der 5100 nicht über 45°C geht. Eher weit darunter bleibt. Das war ja der Hauptgrund für die Anschaffung.

Könntest du mir vllt sagen, wie ich manuell Verbindungen herstellen kann?
Wie ich 2,4GHz und 5GHz wählen kann und/oder g-WLAN erzwingen?

Die AP's hier sind sicher Kombinationen aus 5GHz und 2,4GHz...wenn der nw-manager oder wicd dann hier automatisch verbindet kann ich afaik nicht eingreifen?!

Sagen kann ich definitiv, dass die Abbrüche bei beiden WPA Enterprise Netzwerken auftret. UND zusätzlich bei dem VPN/WEB Netzwerk, was nur vpn-mäßig verschlüsselt ist (ssh). Jegliche Art von Verbindung ist unbenutzbar! :( Mit nw-manager, mit wicd, mit dem .32 oder .38 Kernel aus den backports.

Ich bin ratlos :(
 

tgraupne

New member
Themenstarter
Registriert
25 Feb. 2008
Beiträge
2.008
Ich wollte wirklich nicht pushen....aber irgendwie kann ich auch weder mit Chromium, noch mit epiphany, noch mit firefox die "Bearbeiten" Funktion nutzen.
Genau so wenig wie den "richtigen" Editor. Ich kann hier immer nur "Direkt antworten nutzen" :(

Jedenfalls konnte ich im Moment zu dem "unverschlüsseltem" VPN/WEB Netzwerk verbinden. Es ist imo ein 5GHz AP und stab......

Zu früh gefreut, nach ca 5-10min Abbruch :(
#dmesg sagt:
Code:
[  535.791699] wlan1: deauthenticated from c4:7d:4f:57:82:5e (Reason: 1

Die wicd.log sagt:
Code:
2011/06/30 16:06:43 :: attempting to set hostname with dhclient
2011/06/30 16:06:43 :: using dhcpcd or another supported client may work better
2011/06/30 16:06:43 :: attempting to set hostname with dhclient
2011/06/30 16:06:43 :: using dhcpcd or another supported client may work better
2011/06/30 16:06:48 :: Autoconnecting...
2011/06/30 16:06:48 :: No wired connection present, attempting to autoconnect to wireless network
2011/06/30 16:06:51 :: trying to automatically connect to...VPN/WEB
2011/06/30 16:06:51 :: Connecting to wireless network VPN/WEB
2011/06/30 16:06:51 :: attempting to set hostname with dhclient
2011/06/30 16:06:51 :: using dhcpcd or another supported client may work better
2011/06/30 16:06:51 :: attempting to set hostname with dhclient
2011/06/30 16:06:51 :: using dhcpcd or another supported client may work better
2011/06/30 16:06:52 :: Putting interface down
2011/06/30 16:06:52 :: Releasing DHCP leases...
2011/06/30 16:06:52 :: attempting to set hostname with dhclient
2011/06/30 16:06:52 :: using dhcpcd or another supported client may work better
2011/06/30 16:06:52 :: Setting false IP...
2011/06/30 16:06:52 :: Stopping wpa_supplicant
2011/06/30 16:06:52 :: Flushing the routing table...
2011/06/30 16:06:52 :: Putting interface up...
2011/06/30 16:06:54 :: Running DHCP with hostname x61s-tom
2011/06/30 16:06:54 :: attempting to set hostname with dhclient
2011/06/30 16:06:54 :: using dhcpcd or another supported client may work better
2011/06/30 16:06:54 :: Internet Systems Consortium DHCP Client 4.1.1-P1
2011/06/30 16:06:54 :: Copyright 2004-2010 Internet Systems Consortium.
2011/06/30 16:06:54 :: All rights reserved.
2011/06/30 16:06:54 :: For info, please visit https://www.isc.org/software/dhcp/
2011/06/30 16:06:54 :: 
2011/06/30 16:06:54 :: Listening on LPF/wlan1/00:16:ea:2c:ef:80
2011/06/30 16:06:54 :: Sending on   LPF/wlan1/00:16:ea:2c:ef:80
2011/06/30 16:06:54 :: Sending on   Socket/fallback
2011/06/30 16:06:54 :: DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 6
2011/06/30 16:07:00 :: DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 11
2011/06/30 16:07:00 :: DHCPOFFER from 141.30.1.225
2011/06/30 16:07:00 :: DHCPREQUEST on wlan1 to 255.255.255.255 port 67
2011/06/30 16:07:00 :: DHCPACK from 141.30.1.225
2011/06/30 16:07:00 :: bound to 141.76.178.150 -- renewal in 261 seconds.
2011/06/30 16:07:00 :: DHCP connection successful
2011/06/30 16:07:00 :: not verifying
2011/06/30 16:07:00 :: Connecting thread exiting.
2011/06/30 16:07:03 :: Sending connection attempt result Success


Hier noch ver output Verlauf, den ich nachreichen wollte.
Vom letzten Boot, bis zum shutdown wegen Temperatur

http://pastebin.com/eWRCjWwR
 

tgraupne

New member
Themenstarter
Registriert
25 Feb. 2008
Beiträge
2.008
Im Moment habe ich firmware-iwlwifi 0.288 installiert. Welche, wie #dmesg beim boot sagt, iwlwifi-5000-2.ucode enthält.
Könntest du mir vielleicht schnell sagen, wie ich den testing repo da hinzufüge und das installiere?

Ich habe ja bereits die squeeze backports main, da ich wie gesagt den .38 Kernel ausprobieren wollte, aber testing...?
Na jedenfalls mal wegen dem Verständnis, gehe ich recht in der Annahme, dass wenn man hier bei Debian 6 stable so zusätzlich repos hinzufügt, der "normale" update manager diese aber nicht einbindet, sondern man sozusagen #apt-get "forcen" muss, etwas aus diesen repos zu installieren?
 

ccyx

New member
Registriert
24 März 2011
Beiträge
168
Du kannst das einzelne Paket auch einfach herunterladen und manuell installieren.
Code:
wget http://ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-iwlwifi_0.30_all.deb
dpkg -i firmware-iwlwifi_0.30_all.deb

Das ist wohl die einfachste Variante.
 

tgraupne

New member
Themenstarter
Registriert
25 Feb. 2008
Beiträge
2.008
Danke, dass dachte ich dann auch und habe es fix ausprobiert.
Das Resultat war leider nicht gut:

Code:
[   14.678577] iwlagn 0000:03:00.0: firmware: requesting iwlwifi-5000-5.ucode
[   14.896144] iwlagn 0000:03:00.0: Driver unable to support your firmware API. Driver supports v5, firmware is v0.
[   14.896272] iwlagn 0000:03:00.0: Could not read microcode: -22
[   14.982598] iwlagn 0000:03:00.0: firmware: requesting iwlwifi-5000-5.ucode
[   14.986101] iwlagn 0000:03:00.0: Driver unable to support your firmware API. Driver supports v5, firmware is v0.
[   14.986218] iwlagn 0000:03:00.0: Could not read microcode: -22
[   16.933503] apm: BIOS not found.

Daraufhin wurde die Karte und dementsprechend alle Netzwerke überhaupt nicht erkannt.
Ich habe also wieder die in den stable repos befindliche 0.28 installiert.
Darauf hin das gewohnte Bild:
Code:
[  263.960615] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
[  263.960618] iwlagn: Copyright(c) 2003-2009 Intel Corporation
[  263.960694] iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[  263.960715] iwlagn 0000:03:00.0: setting latency timer to 64
[  263.960765] iwlagn 0000:03:00.0: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
[  264.006157] iwlagn 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[  264.006298] iwlagn 0000:03:00.0: irq 28 for MSI/MSI-X
[  264.006930] phy0: Selected rate control algorithm 'iwl-agn-rs'
[  264.018476] udev[2587]: renamed network interface wlan0 to wlan1
[  264.020747] iwlagn 0000:03:00.0: firmware: requesting iwlwifi-5000-5.ucode
[  264.033977] iwlagn 0000:03:00.0: iwlwifi-5000-5.ucode firmware file req failed: -2
[  264.033983] iwlagn 0000:03:00.0: firmware: requesting iwlwifi-5000-4.ucode
[  264.041152] iwlagn 0000:03:00.0: iwlwifi-5000-4.ucode firmware file req failed: -2
[  264.041158] iwlagn 0000:03:00.0: firmware: requesting iwlwifi-5000-3.ucode
[  264.045193] iwlagn 0000:03:00.0: iwlwifi-5000-3.ucode firmware file req failed: -2
[  264.045199] iwlagn 0000:03:00.0: firmware: requesting iwlwifi-5000-2.ucode
[  264.049551] iwlagn 0000:03:00.0: Loaded firmware iwlwifi-5000-2.ucode, which is deprecated. Please use API v5 instead.
[  264.049558] iwlagn 0000:03:00.0: Firmware has old API version. Expected v5, got v2. New firmware can be obtained from http://www.intellinuxwireless.org.
[  264.049563] iwlagn 0000:03:00.0: loaded firmware version 8.24.2.12

Netzwerke wurden wieder erkannt und auch prompt verbunden, doch eben mit regelmäßigen Abbrüchen, mittlerweile in regelmäßigem Takt, zwischen 2-5min.

Außerdem versuchte ich die Beschränkung auf g-WLAN

Code:
tom@x61s-tom:~$ su
Passwort: 
root@x61s-tom:/home/tom# cd /etc/modprobe.d/
root@x61s-tom:/etc/modprobe.d# ls
aliases.conf		  fbdev-blacklist.conf	       radeon-kms.conf
alsa-base-blacklist.conf  i915-kms.conf		       thinkfan.conf
alsa-base.conf		  iwlagn.conf
blacklist.conf		  linux-sound-base_noOSS.conf
root@x61s-tom:/etc/modprobe.d# nano iwlagn.conf

##################################
option iwlagn 11n_disable=1
##################################

root@x61s-tom:/etc/modprobe.d# modprobe -r iwlagn
WARNING: /etc/modprobe.d/iwlagn.conf line 1: ignoring bad line starting with 'option'
 

buddabrod

New member
Registriert
15 Juni 2007
Beiträge
3.740
Du kannst das einzelne Paket auch einfach herunterladen und manuell installieren.
Code:
wget http://ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-iwlwifi_0.30_all.deb
dpkg -i firmware-iwlwifi_0.30_all.deb

Das ist wohl die einfachste Variante.

Ähm nö. Für was gibt es (temporäres) apt-pinning? ;)

aptitude install blafoo -t testing (falls mich meine Erinnerung nicht täuscht. Kann auch ein großes "T" gewesen sein)

tgraupne: erstelle dir für den manuellen Versuch eine wpa_supplicant.conf (die manpage dazu liefert dir quasi fertige Grundgerüste), dann per wpa_supplicant -Dwext -iwlan0 -c bla.conf wpa_supplicant starten und per dhclient/dhcpd wlan0 die IP beziehen. Das war zumindest früher erheblich zuverlässiger als Networkmanager..

Es scheint auch so, dass das testing firmware Paket zu aktuell für den laufenden Treiber ist. Welcher kernel lief da?
 

linrunner

Ubuntuversteher
Registriert
22 Juni 2007
Beiträge
12.819
Die neue Firmware iwlwifi-5000-5.ucode wird mit dem 2.6.32 niemals funktionieren. Da hat sich der Maintainer des Stable-Kernels oder ein Entwickler einen bösen Patzer geleistet. Der Treiber im 2.6.32 kann mit dem geänderten Dateiformat nichts anfangen (sieht man auch an der Fehlermeldung) -> altes Paket firmware-iwlwifi wieder installieren.

Das Problem wurde bei Ubuntu schon in proposed bereinigt (mir fiel es auch auf - beim Testen des tp-Kernels) und wurde mittlerweile auch Upstream wieder ausgebaut:

Was mich wundert ist, dass es das Problem bis in den Kernel von Debian-Stable geschafft hat. :confused:

Zu deinem eigentlichen Problem: Du wirst nicht darum herumkommen mal mit ausgeschaltetem Wifi Power Management zu testen. Ich benutze meine 5300 nur ohne, weil sonst ständig die WLAN-Verbindung einschläft und nicht wieder aufwacht.

Probleme mit dem PM treten keineswegs nur mit Linux auf, auch unter Windows kannst Du öfter in diesem Forum davon lesen.
 
Zuletzt bearbeitet:

buddabrod

New member
Registriert
15 Juni 2007
Beiträge
3.740
Was mich wundert ist, dass es das Problem bis in den Kernel von Debian-Stable geschafft hat. :confused:
Ähm das hat es nicht. Er hat ein Testing Paket im Stable System installiert ;)


Zu deinem eigentlichen Problem: Du wirst nicht darum herumkommen mal mit ausgeschaltetem Wifi Power Management zu testen. Ich benutze meine 5300 nur ohne, weil sonst ständig die WLAN-Verbindung einschläft und nicht wieder aufwacht.
iwlagn (und iwl4965 vorher) hatten/haben _immer_ das Problem mit WPA Enterprise Wlans. Evtl. hilft es die Hardwareverschlüsslung zu deaktivieren.

Probleme mit dem PM treten keineswegs nur mit Linux auf, auch unter Windows kannst Du öfter in diesem Forum davon lesen.
Definitiv.
 

tgraupne

New member
Themenstarter
Registriert
25 Feb. 2008
Beiträge
2.008
Ok, also mit "options" hat es geklappt.
Ich bin mittlerweile zu Hause und hier seit über einer Stunde stabil mit meinem 2,4GHz, g-WLAN verbunden.
Ich werde dieses g-Standard "forcen" Morgen in der Bibliothek ausprobieren.

@linrunner: Als ich iwlwifi 0.30 ausprobierte lief tatsächlich der alte .32 Kernel.
Ich könnte es mal mit dem .38 ausprobieren, doch ich werde o.g. erst einmal testen.

Ich habe lieber nur 54Mb/s und "kühle Hände", als wieder so ein heißes Eisen in der Hand, draft-n wlan.

Ich werde das Abschalten des PM aber auf jeden Fall mal testen, dass sollte ich doch einfach via tlp.conf machen können, oder?
 

Evilandi666

Geschenkeabgreifer
Registriert
1 Juli 2008
Beiträge
5.611
iwlagn (und iwl4965 vorher) hatten/haben _immer_ das Problem mit WPA Enterprise Wlans. Evtl. hilft es die Hardwareverschlüsslung zu deaktivieren.

Das stimmt aber nicht - sowohl mit 5100 als auch mit 4965 keine Probleme mit Eduroam Wlan. (Unter Arch hatte ich früher mal welche, lag aber wohl am networkmanager oder ssl paket, und man muss es Ubuntu zu gute halten: da ging es schon immer problemlos.)

Zu den Treiberproblemen: Ich würde mal einen aktuelleren Kernel in Betracht ziehen - 2.6.32 ist ja fast älter als die Wlankarten... (kam KW 49 2009)
Es ist zwar ein LTS Kernel, normalerweise werden da aber nicht großartig Treiber nachgereicht. (Wenn, dann integrieren es die Distris nachträglich.)
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben