LED-Mod: Abhilfe des Flackerns der Hintergrundbeleuchtung

Overlord

Member
Registriert
20 Dez. 2007
Beiträge
792
Wie hoch ist bei euren LED-Kits die PWM Frequenz qualitativ abgeschätzt? Bei dem X200 liegt sie leider recht niedrig. Man sieht bei niedrigster Helligkeit beim Scrollen schon Stroboscop Effekte.
 

Mornsgrans

Help-Desk
Teammitglied
Registriert
20 Apr. 2007
Beiträge
70.477
Du meinst das Flackern der LED's? - Das habe ich auf dem X61s bei dunklen Flächen bei Helligkeitsstufen unter ca. 40%.
 

el-sahef

Active member
Registriert
4 Aug. 2008
Beiträge
1.666
Wenn du löten kannst, dann wäre der hier beschriebene Umbau an der Platine mit dem LED-Treiber eine Möglichkeit, das Flackern zu reduzieren.
 

Overlord

Member
Themenstarter
Registriert
20 Dez. 2007
Beiträge
792
Danke dir für den Link, ich kann als E-Techniker sehr gut löten, das schaue ich mir mal gleich an.
 

wileE

Active member
Registriert
7 Jan. 2012
Beiträge
1.973
Wenn du eine Quelle für die beiden benötigten Kondensatoren findest, sag bitte wo man die herbekommt.

Mit meinem Kit aus der Sammelbestellung II bin ich nicht so zufrieden. Da wäre der Mod auch angebracht.
 

fishgod

New member
Registriert
5 Nov. 2014
Beiträge
8
Die Kits sind beide vor ein paar Tagen angekommen, danke nochmal an joker für die reibungslose Abwicklung.

Hab meins direkt versucht einzubauen dabei aber ein paar kurze Haare und Staubpartikel in den Screen bekommen.

Gestern hab ich mir nochmal die Zeit genommen das Display komplett zu zerlegen, alle Folien rauszunehmen einzeln zu putzen und wieder alles zusammenzusetzten.
Das ganze ist schon ein bisschen gefriemel und zeitaufwendig, dafür bin ich die Haare los wofür es sich allemal gelohnt hat.

Die Helligkeit ist überwältigend, in voller Helligkeit ist es jetzt heller als mein stationärer Bildschirm am PC. Leider sieht man ein bisschen die einzelnen LEDs (aber nicht so stark wie wie von andern Usern teilweise berichtet) und auch nur in den unteren 1-2cm vom Display. Da hier normalerweise die Taskleiste sitzt stört es nicht wirklich.

Einziges Manko ist das auf dem Inverter für mein R61 die WWAN-LED nicht bestückt ist. Scheinbar ist das WWAN-Upgrade für dieses Modell einfach nicht vorgesehen.
Dabei ist mir aufgefallen, dass der Stecker vom Display-Kabel zum Inverterboard nicht voll belegt ist. Gibt es zu der Belegung irgendwo eine Dokumentation? Interessant wäre ob ich einfach eine LED mit Vorwiderstand vom alten Inverter ablöten und auf den neuen auflöten kann, oder ob mir das ohne neues Display-Kabel nichts bringt weil die Leitungen vom Mainboard fehlen.
 

Overlord

Member
Themenstarter
Registriert
20 Dez. 2007
Beiträge
792
@wileE: Bei Farnell gibts die beiden nötigen Caps auf einer 100er Rolle. Ich habe noch einen Kollegen angeschrieben, ob er kleinere Mengen vorrätig hat.

Sobald ich die Teile besorgt habe, verschicke ich gegen Porto gerne welche an alle, die an dem High PWM Frequency Mod interessiert sind. Ich werde ihn auf jeden Fall machen. Die Inverter Platine ist genau die gleiche, wie bei dem Mod beschrieben. Sollte also dem Mod nichts mehr im Weg stehen. Meiner Meinung geht eine niedrige PWM Frequenz gar nicht, da sehe ich die Migräne schon um die Ecke kommen. :eek:
 

wileE

Active member
Registriert
7 Jan. 2012
Beiträge
1.973
@wileE: Bei Farnell gibts die beiden nötigen Caps auf einer 100er Rolle. Ich habe noch einen Kollegen angeschrieben, ob er kleinere Mengen vorrätig hat.

Also ich hätte schon Interesse an jeweils 10 Stück. Die Dinger können ja nicht die Welt kosten.

Ich hatte versucht die bei Mouser zu finden, wegen der Sammelbestellung bei mikrocontroller.net, aber als Elektronik Dummie bin ich in dem Katalog irgendwie verloren.
 

Overlord

Member
Themenstarter
Registriert
20 Dez. 2007
Beiträge
792
Zuletzt bearbeitet:

wileE

Active member
Registriert
7 Jan. 2012
Beiträge
1.973
Hast du dir step 3 in der Anleitung mal genau angeschaut? Ich bekomme da niemals ein 0603 Bauteil eingelötet.

Mit einem bedrahteten Kondensator ist das ja kein Problem. Nur habe ich da keine mit der 10V Vorgabe gefunden.

Womit ich zur nächsten Frage komme:

100nF 100000pF Case 0805 50V 10% X7R SMD Capacitors/ SMT Kondensatoren Chip

50V? Ist die Volt Angabe nur als minimal Vorraussetzung zu verstehen? Denn mit 50V gibt es die Teile doch bedrahtet.

Bei hbe kann man ja kleine Mengen aus dem Farnell Sortiment bekommen.
 

Overlord

Member
Themenstarter
Registriert
20 Dez. 2007
Beiträge
792
Eine höhere Spannungsfestigkeit kann man problemlos nutzen, das ist egal. HBE kannte ich noch nicht, da schaue ich mal nach. Den 1uF habe ich als 0805 gewählt, du hast Recht, ein 0603 wäre etwas schwierig.

Bei HBE kommt man vor allem wegen den Versandgebühren auf einen höheren Preis als bei ebay:
https://hbe-shop.de/PACK-mit-10-Stueck-Art-499687-AVX-08055C104KAT2A-KONDENSATOR-100NF-50V
https://hbe-shop.de/Art-2332603-AVX-06035A151KAT2A-KERAMIKKONDENSATOR-150PF-50V-C0G-0603

2,30€ + 0,24€ + 5,65€ = 8,19€ (Jeweils 10 Stück)

1,59€ + 1,49€ + 1,99€ = 5,07€ (Jeweils 100 Stück) bei ebay
 
Zuletzt bearbeitet:

wileE

Active member
Registriert
7 Jan. 2012
Beiträge
1.973
HBE hatte ich zufällig hier gefunden. Man kann bei Farnell die guten Suchfunktionen nutzen, und dann bei HBE eingeben.

Ich dachte da eher an diese Teile:
https://hbe-shop.de/Art-2309020-MULTICOMP-MC0805B104K500A254MM-CAP-MLCC-X7R-100NF-50V-RAD
https://hbe-shop.de/Art-1141766-VISHAY-K151J15C0GF53L2-KONDENSATOR-150PF-50V

Klar ist das teurer, aber Anschussraster 2,54mm Beinchen sind viel angenehmer zu löten.
Wenn du da keine technischen Einwände hast bestelle ich da jeweils 20x. Ich brauche auch noch anderes Zeug.

Klappt das mit den Teilen, verschicke ich dann ein paar. Ich glaube ja nicht das mehr als 5 Leute hier rufen. Für die X6x könnte ich auch das Umlöten anbieten.
 

wileE

Active member
Registriert
7 Jan. 2012
Beiträge
1.973
@Overlord du hast PN

Mod an X61 und X61T ist fertig. Nach der Anleitung hier.

Ich gewinne zwar keine Schönheitspreise für meine Lötkünste, aber es hält und funktioniert. Die Drahtbeine machen das Löten verhältnismäßig einfach.

Das Ablöten der markierten Teile ist auch flott erledigt - von bleifrei hat die Werkstatt wo diese Platinen herkommen noch nicht gehört.

Ich habe vorher/nachher Messungen der maximalen Helligkeit gemacht: man verliert knapp 20 nits.

Das ist es aber wert, denn wenn man einmal angefangen hat auf das Flackern zu achten läßt es sich nicht mehr ignorieren.

Noch jemand Bedarf an Bauteilen?


EDIT

Wer vorhat den Mod zu machen, sollte unbedingt vorher die Platine unter einer Lupe betrachten. Es gibt verschiedene Versionen.

Bei älteren Versionen funktioniert der PWM Mod nicht. Bei ab Ende 2013 gelieferten Kits sollte es das neue Layout haben.


pwm-mod-warnung0dx5h.jpg

Der PWM Mod geht mit dem Kit von 2013 auch. Ich Trottel hatte auf einem Bild von 2012 die Anschlüsse falsch beschriftet, und dann immer bei verwendung dieses Bildes als Lötvorlage die Kabel für Enable und PWM falsch angelötet.
Das geht auch mit vertauschten Anschlüssen. Der dimmbare Bereich ist dabei sogar größer, aber man bekommt halt das Flackern nicht weg.
 
Zuletzt bearbeitet:

Overlord

Member
Themenstarter
Registriert
20 Dez. 2007
Beiträge
792
Ich habe nun den Mod letzte Woche gemacht im Labor der Firma. Verwendet habe ich einmal einen 0805 0,1 uF Cap und einmal einen 0603 330pF Cap. Anfangs hat dann bei mittlerer Helligkeit eine Spule noch etwas gepfeift, das ist nun aber weg.

Als PWM Frequenz habe ich allerdings ca. 10 kHz gewählt. Der Spulenstrom im Regulator braucht etwas Zeit zum Steigen und Fallen, ist die PWM Frequenz zu hoch verliert man Helligkeit. Ich habe allerdings noch keinen Vergleich mit 24 kHz vorgenommen. Die Standard Frequenz war ungefähr 666 Hz (Mit Fotodiode und Oszi gemessen). Die neue Frequenz verifiziere ich noch, nachdem ich eine schnellere Fototransistor Schaltung gebaut habe.

Der Stromverbrauch ist nicht merklich gestiegen mit der höheren Frequenz, auch wenn höhere Schalt-Verluste zu erwarten sind. Im Idle liegt er bei meinem X200 immer noch bei circa 8 Watt mit Ubuntu und TLP.

Wenn jemand die SMD Bauteile braucht, hätte ich 150 pF und 330 pF als 0603 und 0.1 uF als 0805. (Ich habe bemerkt, dass ich gleich in der Nähe Bürklin habe). Bei Bedarf kann ich welche verschicken.

Ich möchte mich auch bei wileE bedanken, welcher mir auch ein paar Teile zugesendet hat, welche ich dann aber nicht benötigte (Habe mich für SMD entschieden). Wenn jemand diese braucht, schicke ich sie gerne kostenlos weiter.
 

wileE

Active member
Registriert
7 Jan. 2012
Beiträge
1.973
Als PWM Frequenz habe ich allerdings ca. 10 kHz gewählt.
Kein Helligkeitsverlust? Schöne Idee.
Bin gespannt auf deine Messergebnisse. Vielleicht ändere ich das auch noch. Obwohl ich die - 20 Nits gerne in Kauf genommen habe.

Es erstaunt mich auch das sich hier nicht mehr Leute an dem Flackern stören.
 

Mornsgrans

Help-Desk
Teammitglied
Registriert
20 Apr. 2007
Beiträge
70.477
Es erstaunt mich auch das sich hier nicht mehr Leute an dem Flackern stören.
Das sicherlich - nur an handwerklichem Geschick scheitert es bei den meisten.
Außerdem wäre es vielleicht ein sinnvoller Verbesserungsvorschlag für den Lieferanten
 

wileE

Active member
Registriert
7 Jan. 2012
Beiträge
1.973
Ich habe mal bei Monty nachgefragt warum er die 24 kHz Frequenz, und den damit verbundenen Helligkeitsverlust, gewählt hat.
Einfach weil diese Frequenz nicht hörbar ist. Bei 10 kHz können laut und deutlich hörbare Töne entstehen.

Ob es lärmt oder nicht lässt sich wahrscheinlich nur durch ausprobieren rausfinden. Ich denke ich bleibe da lieber bei den 24 kHZ.
 

XStoneX

Active member
Registriert
19 Sep. 2006
Beiträge
1.136
Mich stört das Flackern auch sehr. Leider sind meine Lötkünste - sagen wir mal - bescheiden bis gar nicht vorhanden. Nun meine Frage: gibt es jemanden hier, der sich da ein weiteres Mal drüber traut? Natürlich gg. Bezahlung...

Auch wenn mein T61 bald weitergegeben werden soll, der Käufer soll sich nicht am Flackern den Augenkrebs holen.

Freue mich über eine Rückmeldung! ;)

Greetz,

XStoneX
 
  • nbreview.de
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben