X6x Tablet x60t Digitizer und ´Tablet-Buttons funktionieren nicht

hansmxxx

Member
Registriert
2 März 2009
Beiträge
282
Nach Tausch des Drehgelenks und des Fingerprintreaderkabels (war zerfriemelt) gehen die Tabletfunktionen nicht mehr. Zunächst gab es gelegentliche Bluescreens bei Bildschirmberührung mit dem Stift. Daraufhin habe ich diverse Treiber gemäß Tips hier und im amerikanischen Forum probiert. Manchmal zeigten die Computereigenschaften die Stifteingabe als verfügbar an, meistens nicht. Im Geräte-Manager wird der Digitizer als funktionsfähig angezeigt. Nun habe ich nochmals alles auseinandergenommen und die mir relevant scheinenden Steckerverbindungen auf korrekten Sitz geprüft. Das Gerät läuft mit Win7.

Wie kann ich definitiv feststellen ob ein Hardwaredefekt vorliegt?
 

Nobby

Ritter der ThinkPad-Runde
Registriert
11 Jan. 2008
Beiträge
11.843
Hi, hast du das komplette Displaykabel getauscht? Also 1:1 selbe FRU oder wurde evlt. eine andere FRU verbaut?

Nobby
 

hansmxxx

Member
Themenstarter
Registriert
2 März 2009
Beiträge
282
Hi Nobby. Nein, nur das lange mit weißem Klebeband umwickelte Kabel das zum Palmrest vorne rechts führt.
 

hansmxxx

Member
Themenstarter
Registriert
2 März 2009
Beiträge
282
Heute Morgen habe ich softwareseitig nochmal alles deinstalliert was mit Tablet zu tun haben könnte. Nun habe ich im Gerätemanager nur ein "unbekanntes Gerät": Intel(R) 82801GBM (ICH7-M/U) LPC Interface Controller - 27B9 welches vielen hinreichend bekannt sein sollte.

Offensichtlich haben einige dasselbe Problem mit einem X60t gehabt. Im Netz und hier kursieren viele für mich widersprüchliche Empfehlungen welcher Treiber zu installieren ist. Die dazugehörigen Threads enden ohne für mich augenscheinlich verwertbares Ergebnis. Auch http://thinkpad-forum.de/threads/96718-Fehlende-Treiber-nach-Neuinstallation-X60T-Win7 bleibt letztlich offen in der Lösung des Problems.

Da die Geräte recht beliebt sind (oder sind's nur die Displays), hoffe ich daß Ihr mir folgende Fragen beantworten könnt:
Welcher Treiber ist für den o.g. Controller in bei einem X60t (6363-C7G) zu installieren bzw. erfolgreich installiert worden?
Welcher Treiber (Lenovo oder Wacom) funktioniert reibungslos unter Win7 mit SXGA+ Display?
Mit welcher Linux Live CD kann ich überprüfen ob es an der Software liegt?

Vorab danke für die Unterstützung.

Gruß
 

Nobby

Ritter der ThinkPad-Runde
Registriert
11 Jan. 2008
Beiträge
11.843
Hi, ich hatte das Problem auch des öfteren, Win7 installiert, SP1 drauf, alles funktionierte, dann die Updates gefahren und schwups war keine Stifteingabe mehr möglich bzw. Bluescreen beim berühren des Displays mit dem Stift.

Ich habe dann einiges an Treibern deinstalliert und neu installiert, danach ging es wieder, frag mich aber bitte nicht was ich damals alles unternommen habe um das wieder ans laufen zu bekommen.

Nobby
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben