X2xx/s (X200/s-260) X230 - WLan-Karte wird nicht erkannt

franci

New member
Registriert
5 Jan. 2019
Beiträge
8
Hallo zusammen,
ich habe seit ca 3 Monaten ein Thinkpad X230 als Laptop fürs Studium. Ich habe mir das Notebook gebraucht gekauft und direkt von Anfang an kleinere Modifikationen durchgeführt (sofort Upgrade auf 8GB RAM und 500GB SSD). Als ich einen neuen Akku bestellt hatte, musste ich durch ein vorgefertigtes BIOS-Mod aus einem Forum die Whitelist der unterstützten Akkus entfernen. Nun ist mir vor ca einer Woche die WLan-Karte kaputt gegangen. Ich habe durch den Versuch, mich über mein xubuntu (Dual Boot) in das WLan einzuloggen (der auch gescheitert ist), herausgefunden, dass auf jeden Fall das Bauteil defekt ist und nicht das Problem bei Treibern o.Ä. liegt. Daraufhin habe ich von ebay ein identisches Bauteil gekauft und es gestern eingebaut (Intel Centrino Advanced-N 6205). Trotzdem erkennt das BIOS beim Start die WLan-Karte als unauthorisiert: "1802: Unauthorized network card is plugged in - Power off and remove the miniPCI network card (8086/0082/8086/1301). System is halted."
Auf der Suche, wie ich dieses Problem lösen kann, habe ich ein coreboot empfohlen bekommen. Allerdings kommt mir das etwas riskant und aufwändig vor, auch wenn anscheinend ein coreboot mit weiteren Vorteilen verbunden ist.
Gibt es bessere Alternativen, um mein WLan mit der neuen Karte wieder zum laufen zu bekommen (zB ähnlich zum vorgefertigen BIOS-Mod für den Akku, den ich einfach als bootbaren USB-Stick in Linux gebaut und dann im Laptop ausgeführt habe), oder ist ein coreboot die beste Alternative? Und was gilt es bei einem Coreboot zu beachten? Ich würde mich nämlich nur sehr ungern von meinem Motherboard verabschieden müssen :blink:
Vielen Dank schonmal für eure Hilfe! Ich hoffe, die Anmeldung im Forum lohnt sich. :)
Viele Grüße, franci
 

iYassin

Active member
Registriert
15 Mai 2009
Beiträge
9.596
Ja, es gibt (vor allem aus dem mydigitallife.info-Forum) entsprechende BIOSse zum Flashen, die den Error 1802 deaktivieren. Beim X230 ist das allerdings etwas schwieriger - aber da du ja den Akku-Mod auch schon eingespielt hast, hast du die entsprechende Hardware verfügbar?
 

franci

New member
Themenstarter
Registriert
5 Jan. 2019
Beiträge
8
Den BIOS-Mod für den Akku habe ich als bootbaren USB-Stick in Linux gebaut und dann ausgeführt, ich habe also nicht die entsprechenden Verbindungskabel, um mich auf die Platine zu hängen. Einen Raspberry Pi habe ich aber :)
Muss man dann die von die angemerkten BIOSse per RasPi und Verbindungskabel auf der Platine flashen?
 

claas

New member
Registriert
19 März 2011
Beiträge
41
Hallo,

die Akku-Überprüfung befindet sich im EC (=Embedded Controller) und die Überprüfung der PCI-Express-Karten im BIOS. Du könntest also versuchen, als erstes das gemoddete BIOS zu flashen und dann nachsehen, ob und wie sich die Versionsnummer des EC geändert hat. Danach ggf. nochmal die EC-Firmware flashen.

Libreboot flashe ich mir auch die Tage auf mein X200. Beim X230 ist es coreboot. Allerdings muss man dafür das Thinkpad auseinanderbauen und von extern den Flash-Baustein flashen. Ist die Frage, ob du dir das zutraust, oder ob du bei euch in der Nähe einen Hackerspace mit versierten Leuten hast, die dir dabei helfen können.
 

Mornsgrans

Help-Desk
Teammitglied
Registriert
20 Apr. 2007
Beiträge
68.760
Man kann auch eine WLAN-Karte mit FRU-Nummer kaufen und den Fehlkauf verscherbeln.
 

schoerg

Active member
Registriert
12 Juni 2009
Beiträge
3.655
Auf der Suche, wie ich dieses Problem lösen kann, habe ich ein coreboot empfohlen bekommen. Allerdings kommt mir das etwas riskant und aufwändig vor, auch wenn anscheinend ein coreboot mit weiteren Vorteilen verbunden ist.
Gibt es bessere Alternativen, um mein WLan mit der neuen Karte wieder zum laufen zu bekommen (zB ähnlich zum vorgefertigen BIOS-Mod für den Akku, den ich einfach als bootbaren USB-Stick in Linux gebaut und dann im Laptop ausgeführt habe), oder ist ein coreboot die beste Alternative? Und was gilt es bei einem Coreboot zu beachten? Ich würde mich nämlich nur sehr ungern von meinem Motherboard verabschieden müssen :blink:
Ohne coreboot:

https://github.com/hamishcoleman/thinkpad-ec

Edit: ok, da gehts nicht um die Whitelist.
 
Zuletzt bearbeitet:

franci

New member
Themenstarter
Registriert
5 Jan. 2019
Beiträge
8
Nach was genau muss ich suchen, um eine Wlan-Karte zu bekommen, die direkt ohne Probleme erkannt wird? Das klingt nämlich ehrlich gesagt nach der besten und einfachsten, und vor allem sichersten Methode...
Außerdem, was hat es mit der "6300er" Karte auf sich? Die defekte Karte, die ich ausgebaut habe, war (genau wie die neue, die ich gekauft habe) eine Intel Centrino Advanced-N 6205, nur dass die neue (wahrscheinlich eine andere Revision) nicht mehr erkannt wird
 
Zuletzt bearbeitet:

Mornsgrans

Help-Desk
Teammitglied
Registriert
20 Apr. 2007
Beiträge
68.760
Die neue wird erkannt, aber eben als "unzulässig".
Zulässige Karten besitzen eine Teilenummer von Lenovo, beginnend mit FRUxxYxxxx

Leider gibt es ab dem HMM der Generation T430 keine Parts List mehr, sodass die Suche erheblich erschwert wird.
 

morini22

Active member
Registriert
22 Juli 2007
Beiträge
9.000
Dazu gibt es unser Wiki (Auch wenn es nicht immer perfekt ist ..) : https://thinkwiki.de/X230 .
Ansonsten ist immer wichtig die passende FRU zu verwenden,das hat nichts mit der Revision zu tun ,denn es ist ein "Branding" seitens Lenovo .

Gruss Uwe
 

franci

New member
Themenstarter
Registriert
5 Jan. 2019
Beiträge
8
Also: ich habe mir mittlerweile eine solche WLAN-Karte bestellt, die eine Lenovo-passende Seriennummer hat und auch laut ebay-Verkäufer aus einem Lenovo Notebook stammt. Ich habe sie eingebaut und getestet, der Laptop startet (ich habe also nicht mehr das alte Problem mit der Whitelist), allerdings funktioniert das WLAN immer noch nicht richtig. Wenn ich in den WLAN-Optionen bei Windows bin, kann ich den Button um WLAN an- und auszuschalten klicken, er verändert sich auch (also habe ich auch nicht dasselbe Problem wie mit der ursprünglichen WLAN-Karte, dort konnte ich den Button zwar klicken, aber das WLAN ist immer ausgeblieben), allerdings bleibt dort, wo normalerweise die Liste der verfügbaren Netzwerke angezeigt werden sollte, die "WLAN erneut aktivieren in ... " Option, welche eigentlich nur angezeigt werden soll, wenn das WLAN aus ist.
Ich habe gerade noch einen weiteren Test durchgeführt. Ich habe auf meinem Laptop ein Dual Boot mit xubuntu, und beim Versuch, mich in Linux mit dem WLAN zu verbinden, passiert genau dasselbe wie in Windows: WLAN ist angeblich aktiviert, aber die Liste der verfügbaren Netzwerke sieht so aus wie bei ausgeschaltetem WLAN. Meiner Meinung nach ist dies eine Methode, einen Software/Treiber Fehler auszuschließen (Correct me if I'm wrong)
Gruß, Franci
 

explit

Member
Registriert
10 Dez. 2010
Beiträge
377
Mal ne bloede frage: Hast du geschaut ob WLAN/Bluetooth Kill-Switch nicht zufaellig aktiviert wurde ? (Es ist ein kleiner Hardwareschalter ab Gehause, quasi ein FLug-Modus)
 

franci

New member
Themenstarter
Registriert
5 Jan. 2019
Beiträge
8
Tatsächlich... ich fühle mich zwar leicht veräppelt, aber es funktionniert wieder. Vielen Dank!
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben