tp_smapi Problem mit tlp unter Fedora 17 X121e

Tharin

New member
Registriert
26 Aug. 2012
Beiträge
11
Hallo Leute,
Ich habe mir als zweit Laptop ein Thinkpad 121e zugelegt und Fedora 17 darauf installiert, so weit so gut. Nun würde ich allerdings gerne noch die Akkuladeschranken definieren. Ich bin dabei nach dieser Anleitung vorgegangen: http://thinkwiki.de/TLP_-_Linux_Stromsparen#Fedora_16_und_h.C3.B6her jedoch will mir das nicht so richtig gelingen. Versuche ich die Ladeschwellen zu ändern bekomme ich immer nur den Fehler: "Error: Thinkpad battery functions not available (missing tp_smapi kernel module)".

Ich habe bis jetzt danach gegoogelt, aber noch keine funktionierende Lösung gefunden. :confused:
Für Tipps und Anregungen wäre ich dankbar.

Gruß Tharin
 

blafoo

Moderator
Teammitglied
Registriert
11 März 2011
Beiträge
7.996
Moin moin :)

Hast du das Modul mit
Code:
modprobe tp-smapi
auch geladen?

Grüße
 

Tharin

New member
Themenstarter
Registriert
26 Aug. 2012
Beiträge
11
Servus,

Code:
modprobe tp-smapi

ergibt
Code:
ERROR: could not insert 'tp_smapi': No such device or address
und da scheint auch das Problem zu liegen. tp_smapi ist installiert, kann aber wohl nicht verwendet werden? :confused:

Gruß Tharin
 

Tharin

New member
Themenstarter
Registriert
26 Aug. 2012
Beiträge
11
Okay ich hab mich mal an der Problemlösung versucht, richtig erfolgreich war ich aber nicht.

Code:
modprobe -v tp_smapi

ergibt die bekannte Fehlermeldung

Code:
insmod /lib/modules/3.5.2-3.fc17.x86_64/extra/tp_smapi/thinkpad_ec.ko force_io=1 
ERROR: could not insert 'tp_smapi': No such device or address

die wiki von ubunuusers schlägt daraufhin vor das ganze näher mit
Code:
dmesg | grep thinkpad_ec
zu spezifizieren.

Das Resultat sieht dann so aus:
Code:
[   48.737139] thinkpad_ec: thinkpad_ec_read_row: failed requesting row: (0x01:0x00)->0xfffffff0
[   48.737149] thinkpad_ec: initial ec test failed
[   52.073706] thinkpad_ec: thinkpad_ec_read_row: failed requesting row: (0x01:0x00)->0xfffffff0
[   52.073718] thinkpad_ec: initial ec test failed
[  144.815732] thinkpad_ec: thinkpad_ec_read_row: failed requesting row: (0x01:0x00)->0xfffffff0
[  144.815741] thinkpad_ec: initial ec test failed
[  461.798295] thinkpad_ec: thinkpad_ec_read_row: failed requesting row: (0x01:0x00)->0xfffffff0
[  461.798305] thinkpad_ec: initial ec test failed

damit kann ich dann nichts mehr mit anfangen und diese Fehlermeldung steht auch nicht in der wiki.

Den Modulparameter einzufügen hab ich auch schon versucht, die Aktion war allerdings nicht von Erfolg gekrönt.
 

linrunner

Ubuntuversteher
Registriert
22 Juni 2007
Beiträge
12.810
Hi,

was ist das genau für Modell des X121e? Hat es einen Intel- oder einen AMD-Prozessor?

Zeig mal bitte
Code:
sudo tlp-stat
 

Tharin

New member
Themenstarter
Registriert
26 Aug. 2012
Beiträge
11
Hey, es ist die Variante mit dem AMD Prozessor, also x121e (3051).

tlp stat

Code:
--- TLP 0.3.6 --------------------------------------------

+++ Configured Settings: /etc/default/tlp
TLP_ENABLE=1
DISK_IDLE_SECS_ON_AC=0
DISK_IDLE_SECS_ON_BAT=2
MAX_LOST_WORK_SECS_ON_AC=15
MAX_LOST_WORK_SECS_ON_BAT=60
SCHED_POWERSAVE_ON_AC=0
SCHED_POWERSAVE_ON_BAT=1
NMI_WATCHDOG=0
DISK_DEVICES="sda sdb"
DISK_APM_LEVEL_ON_AC="254 254"
DISK_APM_LEVEL_ON_BAT="128 128"
SATA_LINKPWR_ON_AC=max_performance
SATA_LINKPWR_ON_BAT=min_power
PCIE_ASPM_ON_AC=performance
PCIE_ASPM_ON_BAT=powersave
RADEON_POWER_PROFILE_ON_AC=high
RADEON_POWER_PROFILE_ON_BAT=low
WIFI_PWR_ON_AC=1
WIFI_PWR_ON_BAT=5
WOL_DISABLE=Y
SOUND_POWER_SAVE=1
SOUND_POWER_SAVE_CONTROLLER=Y
BAY_POWEROFF_ON_BAT=0
BAY_DEVICE="sr0"
RUNTIME_PM_ON_AC=on
RUNTIME_PM_ON_BAT=auto
USB_AUTOSUSPEND=1
RESTORE_DEVICE_STATE_ON_STARTUP=0
DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi"
START_CHARGE_THRESH_BAT0=60
STOP_CHARGE_THRESH_BAT0=80
START_CHARGE_THRESH_BAT1=60
STOP_CHARGE_THRESH_BAT1=80

+++ System Info
System = LENOVO ThinkPad X121e 3051A79
BIOS = 8RET52WW (1.15 )
Kernel = 3.5.2-3.fc17.x86_64 x86_64
/proc/cmdline = BOOT_IMAGE=/vmlinuz-3.5.2-3.fc17.x86_64 root=/dev/mapper/vg_bastian--linux-lv_root ro rd.luks.uuid=luks-19c72c94-c544-44ed-8a2a-b870e979e104 rd.dm=0 SYSFONT=True KEYTABLE=de rd.lvm.lv=vg_bastian-linux/lv_root rd.md=0 rd.lvm.lv=vg_bastian-linux/lv_swap LANG=en_US.UTF-8 rhgb quiet

+++ System Status
TLP power save = enabled
power source = battery

+++ Processor
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor = ondemand
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq =   780000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq =  1300000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies =  1300000 1114000  780000 [kHz]

/sys/devices/system/cpu/cpu1/cpufreq/scaling_governor = ondemand
/sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq =   780000 [kHz]
/sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq =  1300000 [kHz]
/sys/devices/system/cpu/cpu1/cpufreq/scaling_available_frequencies =  1300000 1114000  780000 [kHz]

/proc/sys/kernel/nmi_watchdog = 0

+++ Undervolting
PHC kernel not available.

+++ ThinkPad Temperatures
/proc/acpi/ibm/thermal = temperatures:    48 0 48 0 0 0 25 0
/proc/acpi/ibm/fan     = speed:          567

+++ File System
/proc/sys/vm/laptop_mode = 2
/proc/sys/vm/dirty_writeback_centisecs = 6000
/proc/sys/vm/dirty_expire_centisecs = 6000
/proc/sys/vm/dirty_ratio = 60
/proc/sys/vm/dirty_background_ratio = 1
/proc/sys/fs/xfs/age_buffer_centisecs = (not available)
/proc/sys/fs/xfs/xfssyncd_centisecs = (not available)
/proc/sys/fs/xfs/xfsbufd_centisecs = (not available)

+++ Storage Devices
/dev/sda:
          Model     = ST320LT020-9YG142                       
          Firmware  = 0003LVM1
          APM Level = 128
          scheduler = cfq

        SMART info:
            4 Start_Stop_Count          =       85 
            5 Reallocated_Sector_Ct     =        0 
            9 Power_On_Hours            =       25 [h]
          190 Airflow_Temperature_Cel   =       26 [°C]
          193 Load_Cycle_Count          =     1311 
          194 Temperature_Celsius       =       26 (0 21 0 [°C]


+++ SATA Aggressive Link Power Management
/sys/class/scsi_host/host0/link_power_management_policy = min_power

+++ PCIe Active State Power Management
/sys/module/pcie_aspm/parameters/policy = powersave

+++ Radeon Graphics
/sys/class/drm/card0/device/power_method = profile
/sys/class/drm/card0/device/power_profile = low

+++ Wireless
bluetooth = off (software)
wifi      = on
wwan      = none (no device)

wlan0(rtl8192ce): power management = off (disabled by kernel)

+++ Audio
/sys/module/snd_hda_intel/parameters/power_save = 1
/sys/module/snd_hda_intel/parameters/power_save_controller = Y

+++ Battery
ThinkPad extended battery info not available (missing tp_smapi kernel module).
/sys/class/power_supply/BAT1/manufacturer = LGC
/sys/class/power_supply/BAT1/model_name = 42T4961
/sys/class/power_supply/BAT1/cycle_count = 0
/sys/class/power_supply/BAT1/energy_full_design = 62160 [mWh]
/sys/class/power_supply/BAT1/energy_full = 62150 [mWh]
/sys/class/power_supply/BAT1/energy_now = 22230 [mWh]
/sys/class/power_supply/BAT1/power_now = 8537 [mW]
/sys/class/power_supply/BAT1/status = Discharging

+++ Runtime Power Management
/sys/bus/pci/devices/0000:00:00.0/power/control = auto [Host]
/sys/bus/pci/devices/0000:00:01.1/power/control = auto [Audio]
/sys/bus/pci/devices/0000:00:14.2/power/control = auto [Audio]
/sys/bus/pci/devices/0000:00:18.0/power/control = auto [Host]
/sys/bus/pci/devices/0000:00:18.1/power/control = auto [Host]
/sys/bus/pci/devices/0000:00:18.2/power/control = auto [Host]
/sys/bus/pci/devices/0000:00:18.3/power/control = auto [Host]
/sys/bus/pci/devices/0000:00:18.4/power/control = auto [Host]
/sys/bus/pci/devices/0000:00:18.5/power/control = auto [Host]
/sys/bus/pci/devices/0000:00:18.6/power/control = auto [Host]
/sys/bus/pci/devices/0000:00:18.7/power/control = auto [Host]
/sys/bus/pci/devices/0000:01:00.0/power/control = auto [Wireless]
/sys/bus/pci/devices/0000:02:00.0/power/control = auto [Ethernet]

+++ USB
tlp usb autosuspend = enabled
tlp usb blacklist = (not configured)

Bus 002 Device 002 ID 5986:01a6 control = auto, autosuspend_delay_ms =  2000 -- Acer, Inc Lenovo Integrated Webcam (uvcvideo)
Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 2.0 root hub (hub)
Bus 002 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 2.0 root hub (hub)
Bus 003 Device 001 ID 1d6b:0001 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 1.1 root hub (hub)
Bus 004 Device 001 ID 1d6b:0001 control = auto, autosuspend_delay_ms =  2000 -- Linux Foundation 1.1 root hub (hub)

Gruß Tharin
 

kalibari

New member
Registriert
24 Aug. 2010
Beiträge
659
/*** Checking for EC hardware ***/

/**
* thinkpad_ec_test - verify the EC is present and follows protocol
*
* Ensure the EC LPC3 channel really works on this machine by making
* an EC request and seeing if the EC follows the documented H8S protocol.
* The requested row just reads battery status, so it should be harmless to
* access it (on a correct EC).
* This test writes to IO ports, so execute only after checking DMI.
*/

DMI Test bestanden, aber eben nicht den thinkpad_ec_test. So sieht es auch beim X230 aus wenn man den DMI Test besteht. Vielleicht brauchst du eben auch acpi_call wie bei den neuen Thinkpad-Modellen?
 

linrunner

Ubuntuversteher
Registriert
22 Juni 2007
Beiträge
12.810
Ich würde auch vorschlagen, TLP 0.3.7.1 mit acpi-call zu probieren. Allerdings hat RomanX noch kein Fedora-Package für acpi-call bereitgestellt.
 

Tharin

New member
Themenstarter
Registriert
26 Aug. 2012
Beiträge
11
Morgen,

Ich habe mich mal an dem ACPI-Call Kernelmodul versucht, jedoch sieht das Resultat so aus:

Code:
modprobe -v acpi_call
FATAL: Module acpi_call not found.

wie gehts weiter?

Gruß Tharin
 

Tharin

New member
Themenstarter
Registriert
26 Aug. 2012
Beiträge
11
Okay also
Code:
depmod -a
scheint zu funktionieren. Danach bin ich der Anleitung weiter gefolgt, bis zu dem Punkt an dem man die Datei ändern soll, die die Akkuladeschranken verwaltet. Diese Datei ist jedoch nicht nicht aufzufinden, ich komme bis /etc/rc.d/ dort fehlt mir dann allerdings die rc.local.

Gruß Tharin
 

simpel

New member
Registriert
13 Okt. 2011
Beiträge
611
die /etc/rc.d/rc.local ist wohl schon seit Fedora 16 standardmäßig nicht mehr dabei - die musst du als root selbst erstellen.

P.S.
und natürlich die Datei ausführbar machen - ebenfalls als root:

Code:
chmod 755 /etc/rc.d/rc.local
 
Zuletzt bearbeitet:

RomanX

Member
Registriert
20 Sep. 2009
Beiträge
633
Moin

rc.local ist deprecated

Bitte /etc/modules-load.d verwenden
Code:
man modules-load.d

RomanX
 

simpel

New member
Registriert
13 Okt. 2011
Beiträge
611
das interessiert mich nun auch - demnach einfach nur als root die *.conf erstellen:

Code:
nano /etc/modules-load.d/tp_smapi.conf

das Modul eintragen:

Code:
tp_smapi

speichern, Neustart und fertig?

das wäre ja easy :)
 

linrunner

Ubuntuversteher
Registriert
22 Juni 2007
Beiträge
12.810
Ich glaube ihr seid hier ein wenig auf dem Holzweg. Wozu werden denn überhaupt Einträge in rc.local oder anderswo benötigt?

  • TLP lädt automatisch alle benötigten Kernelmodule (sonst hätte ich hier Supportfälle ohne Ende)
  • TLP erkennt und nutzt automatisch acpi-call um die in /etc/default/tlp konfigurierten Schwellen zu setzen (dito)
Voraussetzung ist natürlich, dass das ThinkPad die betreffenden ACPI-Funktionen auch unterstützt - was wir für's X121e noch nicht wissen.
 
Zuletzt bearbeitet:

Tharin

New member
Themenstarter
Registriert
26 Aug. 2012
Beiträge
11
So ich habe mal versucht das zu machen was simple vorgeschlagen hat, jedoch hat auch das erstellen der tp_smapi.conf keinen weiteren Erfolg gebracht, jedenfalls wird das tp_smapi Kernelmodul nicht verwendet.
hmm :confused:

Soll ich den entsprechenden Eintrag wieder löschen ?

Gruß Tharin
 

simpel

New member
Registriert
13 Okt. 2011
Beiträge
611
@linrunner

es ist doch besser, wenn du hier hin und wieder mal reinschaust.


@Tharin

linrunner's Aussage war ja nun deutlich, und er muss es schließlich wissen.

ich würde die vorgenommenen Einstellungen rückgängig machen.

und mein Post bezüglich der Erstellung einer tp_smapi conf war eigentlich mehr als Frage gedacht.

guten Abend :)
 

linrunner

Ubuntuversteher
Registriert
22 Juni 2007
Beiträge
12.810
@Tharin: weiter oben hatten wir bereits festgestellt, dass tp_smapi auf deiner Maschine nicht lädt. Daher kannst Du weitere Versuche in dieser Richtung einstellen und wir konzentrieren uns stattdessen auf acpi-call.

Im weiteren setze ich voraus, dass Du folgendes installiert hast:
  • Das acpi-call-Paket auf das kalibari verwies – verlinkt im Wiki, der Rest der Anleitung dort ist irrelevant!
  • Die Pakete für TLP 0.3.7.1 wo ich zu einer Anleitung verlinkt habe

Sobald die Voraussetzungen gegeben sind, zeig bitte
Code:
sudo tlp-stat -b
damit wir sehen können ob die Ladeschwellen über acpi-call funktionieren.
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben