TP E540 und Intel Rapid Storage + Intel Smart Response

dingo

New member
Registriert
5 Sep. 2014
Beiträge
2
Hallo Zusammen,

habe mich soeben neu im Forum registriert in der Hoffnung, dass Ihr mir weiterhelfen könnt. Habe schon den Lenovo Support kontaktiert, allerdings ohne Erfolg.

Ich besitze, seit kurzem, ein Thinkpad E540 (Intel Core i7-4702MQ, 8GB RAM, 1TB HDD (mSATA), 16GB SSD (M.2)). Und genau mit dieser 16GB SSD habe ich meine Schwierigkeiten. Laut Produktbeschreibung dienen diese 16GB als Cache. Ich habe die Funktionalität der Software "Intel Rapid Storage-Technologie" schon bei einem Freund gesehen. Er hat im Bereich "Leistung" noch die "Intel Smart Response Technologie" und bekommt eine Möglichkeit bei seiner Standardfestplatte auf "Beschleunigen" zu Klicken und kann dann die SSD auswählen. Diese ist bei Ihm auf der rechten Seite auch als "Raid" betitelt.

Bei mir sieht das leider etwas schmächtiger aus. Ich habe leider nur die Option für das "Link Power Management".
Die Software sieht bei mir aus wie folgt:
IRST_03_Leistung.PNGIRST_02b_Verwalten.PNGIRST_02a_Verwalten.PNGIRST_01_Status.PNG

Nun mag dieses Link Power Management wahrscheinlich ganz nett sein, allerdings habe ich gesehn was diese Intel Smart Response Technik für Geschwindigkeitsvorteile mit sich bringt. Bootvorgang geht sagenhaft schnell.

Des Weiteren habe ich mich natürlich schon umgehört (bzw. gelesen) dass für diese Option der SATA Controller im BIOS auf RAID stehen muss. Ich bekomme aber in meinem BIOS (J9ET92WW (2.12)) allerdings nur die Auswahl "AHCI" oder "Compatibility".

Unterstützt dieses Notebook kein RAID? Kann ich deswegen diese Intel Smart Response Technik bei mir vergessen? Oder habe ich vielleicht nur irgendetwas übersehen?

Danke schonmal für eure Antworten.
Gruß
dingo
 

Desaster

New member
Registriert
14 Juli 2011
Beiträge
513
Hallo,
such mal nach ExpressCache, dann wirst Du fündig.
Findest Du auf der Lenovo-Homepage.
Gruss
Desaster
 

dingo

New member
Themenstarter
Registriert
5 Sep. 2014
Beiträge
2
Hallo Desaster,

erstmal vielen Dank für den trivialen aber sehr hilfreichen Tipp. Vor lauter Frustration und Ärgernis über den (für mich nun noch mehr inkompetenten) Support von Lenovo vergisst man schnell nach Alternativen zu suchen.
ExpressCache (vom Lenovo DL-Portal) funktioniert nun mit meinem Thinkpad E540.

Folgende Vorgehensweise führe (in meinem Fall) zum Ziel:
1. Deinstallation der Intel RST Software + Neustart
2. Neupartitionierung via diskpart
3. Installation von ExpressCache + Neustart

Resultat nach dem ersten Neustart mit ExpressCache:

Code:
EC Cache Info==================================================


Mounted                   : Yes
Partition Size            : 14.91 GB
Reserved Size             : 3.00 MB
Volume Size               : 14.91 GB
Total Used Size           : 4.44 GB
Total Free Space          : 10.47 GB
Used Data Size            : 4.37 GB
Used Data Size on Disk    : 4.44 GB


Tiered Cache Stats
==================================================
Memory in use             : 1024.00 MB
Blocks in use             : 8188
Read Percent              : 3.80%




Cache Stats
==================================================
Cache Volume Drive Number : 1
Total Read Count          : 73365
Total Read Size           : 3.67 GB
Total Cache Read Count    : 20369
Total Cache Read Size     : 1.23 GB
Total Write Count         : 11224
Total Write Size          : 430.26 MB
Total Cache Write Count   : 3624
Total Cache Write Size    : 28.15 MB


Cache Read Percent        : 33.54%
Cache Write Percent       : 6.54%

Sieht doch für den Anfang schon recht ordentlich aus. =)

Abschließend bleibt mir nur die Frage, warum dieser kleine Hinweis beim Lenovo Support (nach zwei Anrufen und etlichen Minuten Wartezeit wegen Rücksprachen mit den "Experten") nicht durchgesickert ist. Wissen die nicht was die für Geräte verbauen? Zumal die ExpressCache Version ja (laut meinen Informationen) eine angepasste Version von Lenovo selbst ist. Naja, hauptsache funktioniert nun.

Vielen Dank nochmal @Desaster =)

Gruß
dingo
 

AbRaXaS

New member
Registriert
5 März 2015
Beiträge
11
Ich stehe seit ich mich von den Lenovo Partinionen mit Recovery Quatsch entledigt habe vor dem gleichen Problem. Ich weiß jetzt nicht mal ob das vorher richtig als Cache funktioniert hat mit der 16GB SSD. Versuche jetzt aber mir ein frisches System aufzusetzten und die SSD als Cache zu benutzten. Der Intel Treiber wird übrigens im Supportbereich bei den Downloads zum E540 angezeigt. Aber wenn man ihn installiert, das gleiche wie bei dir. Man kann nichts einstellen. Ich versuche es jetzt auch einmal mit dem ExpressCache.
 

AbRaXaS

New member
Registriert
5 März 2015
Beiträge
11
Ich hab jetzt 3 verschiedene Versionen von ExpressCache ausprobiert. 2 von der Lenovo Seite und eine von der Sundisk Seite. Die von Lenovo lassen sich installieren, aber es lässt sich nach dem Neustart keine Exe von ExpressCache über die Win8 Suche finden, über den Explorer auf den Pfad und die Exe geht nur kurz eine DOS CMD auf und direkt wieder zu und das wars. Die Version von Sundisk lässt sich nicht installieren. Findet angeblich meine Sunddisk SSD U110 16GB nicht.

Kann mir jemand weiterhelfen?
 

think_pad

Active member
Registriert
20 Feb. 2014
Beiträge
5.482
Kann mir jemand weiterhelfen?


Yes, we can! Zunächst muss man dem Programm ExpressCache erst einmal mitteilen, dass die (leere) SSD oder SanDisk-SDCard als Cache genutzt werden soll...

ECC hat folgende Optionen:

Code:
USAGE:

 ECCmd [-NOLOGO]
       [-INFO | -PARTITION | -FORMAT]


 -NOLOGO              - No copyright message will be displayed.
 -INFO                - Display ExpressCache activity information.
 -PARTITION           - Create an ExpressCache partition.
         [DriveId]    - Optional drive ID
         [PartSize]   - Optional partition size in MB
 -FORMAT              - Format the cache volume.
Verwendung von ExpressCache ohne Intel Rapid Storage:

  1. CommandPrompt mit Admin-Rechten öffnen und "diskpart" eingeben
  2. Eingabe "list disk" (liefert Nummer x der SSD, x notieren).
  3. Eingabe "select disk x" (x= ist die Nummer der SSD)
  4. Eingabe "clean" (löscht die SSD oder SDCard)
  5. Eingabe "exit" (Verlassen von diskpart)
  6. Nun wieder im CMD-Prompt wird bis zu C:\Program Files\Condusiv Technologies\ExpressCache\" navigiert
  7. Eingabe "ECCmd -partition" (Dies teilt ExpressCache mit, dass das gesamte SSD-Laufwerk verwendet wird)
  8. Fertig! Wenn es funktioniert, muss nach einem Restart im CMD-Prompt mit "ECCmd -info" eine Cache-Statistik erscheinen.
 
Zuletzt bearbeitet:

AbRaXaS

New member
Registriert
5 März 2015
Beiträge
11
Danke. Damit hat es geklappt. War die ganze Zeit auf der Suche nach einer GUI, bin gar nicht mehr auf den Gedanken gekommen, dass Config über CMD zu probieren. Man ist irgendwie zu mittlerweile zu GUI verwöhnt.
 

AbRaXaS

New member
Registriert
5 März 2015
Beiträge
11
Mittlerweile erkennt weder BIOS noch Windows meine SanDisk 16GB SSD, nur ab und zu wird sie erkannt, aber verschwindet nach einer Weile in Windows wieder.
 

think_pad

Active member
Registriert
20 Feb. 2014
Beiträge
5.482
Mittlerweile erkennt weder BIOS noch Windows meine SanDisk 16GB SSD, nur ab und zu wird sie erkannt, aber verschwindet nach einer Weile in Windows wieder.

Ich vermute mal, Du hast das Intel Rapid Storage installiert, und auf der SSD vor dem Cache keine Hidden Partition für den RAM angelegt.
 

AbRaXaS

New member
Registriert
5 März 2015
Beiträge
11
Ich bin nach der Anleitung oben vorgegangen. Aber BIOS müsste die SSD doch trotzdem erkennen oder nicht?
 

AbRaXaS

New member
Registriert
5 März 2015
Beiträge
11
Habs jetzt auf einen Hardwaredefekt eingegrenzt. Controler, Slot oder SSD. Werde mich jetzt wegen Garantie an Lenovo wenden.
 

AbRaXaS

New member
Registriert
5 März 2015
Beiträge
11
Also wohl doch kein Hardwarefehler. War bei einem Lenovo Partner vor Ort und hab den Laptop checken lassen. Die SSD läuft einwand frei. Wurde dann auch wieder die nächsten male erkannt. Wieder zu Hause fiel sie aber einen Tag später wieder aus. Der Mitarbeiter vom Lenovo Partner meinte es ist wahrscheinlich ein Treiberproblem, das auch dazu führen kann, dass der Controler nicht richtig läuft und deswegen die SSD vom BIOS auch nicht mehr erkannt wird. Jetzt habe ich heute ExpressCache deinstalliert und siehe da, sie wird seit dem jedes mal erkannt. Auf der Lenovo Seite unter Downloads für das E540 habe ich eine .exe für Intel Rapid Storage gefunden, diese entpackt anscheinend nur Treiber in den Order Driver. Aber ich kann kein Diagnose Programm ausführen um zu sehen ob die SSD nun als Cache läuft. Das Booten dauert für meinen Geschmack genauso so lange wie vorher ohne Cache.
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben