[T42p] FireGL T2 unter Ubuntu mit compiz im Dual Monitor Betrieb

marcnesium

New member
Registriert
28 Mai 2009
Beiträge
32
Hallo alle miteinander!

Ich versuche jetzt schon seit einiger Zeit hier und im Netz Hinweise zu finden, wie das T42p mit FireGL T2 unter Ubuntu (11.04) im Dual Monitor Betrieb mit compiz zum Rennen zu bewegen ist.

Der "radeon" Treiber läuft mit compiz mit einem Monitor wunderbar. Leider habe ich mich sehr an den Komfort gewöhnt und würde compiz weiterhin einsetzen.
Jedoch verwandelt sich der Inhalt der beiden Bildschirme, sobald ich das TP in die Dockingstation stelle bzw. den 2. Monitor anschließe, in eine bunte Bits und Bytes-Landschaft... Sieht für mich spontan danach aus, als ob da Speicherbereiche irgendwie durcheinander gewürfelt werden. Der Mauszeiger wird allerdings korrekt dargestellt.

Ich verwende gerade ein Ubuntu 11.04 und Treiber und compiz aus dem offiziellen repository.

Ist jemand da draußen, der Erfahrungen mit mir teilen möchte und idealerweise Dual-Monitor-Betrieb mit compiz am laufen hat?

Ich bin leider noch nicht allzulange auf dem Linux-Zug, deshalb habe ich die Entwicklung der Grafik-Chip-Treiber nicht mitbekommen. Ich habe gelesen, dass es früher mal den fglrx Treiber gab, der mal die FireGL T2 unterstützt hat. Aber da es nun KMS gibt, läuft dieser Treiber nur noch mit älteren Distributionen. Ähm, richtig? Also, ich muss zugeben, ich habe da noch nicht den glasklaren Durchblick. Bei der Recherche finde ich es erschwerend zwischen den veralteten und den wenigen aktuellen Beiträgen zu unterscheiden.
Richtig eindeutige Fehlermeldungen habe ich im Syslog noch nicht gefunden, jedoch muss ich wiederum zugeben, dass ich noch nicht besonders versiert darin bin.

Wer kann einen Erfahrungsbericht leisten und evtl. Hilfestellung bei der Einrichtung auf einem aktuellen Ubuntu leisten?

Vielen Dank schonmal!

Ciao, Marc.


Edit:

IMG_20110904_152401.jpg
 
Zuletzt bearbeitet:

linrunner

Ubuntuversteher
Registriert
22 Juni 2007
Beiträge
12.801
Hi,

das Thema fglrx kannst Du abhaken. AMD hat schon vor Jahren den Support für deine Karte entfernt und die alten Versionen laufen mit keiner noch supporteten Linux-Version. Was Du mal testen könntest ist ein 10.04-Livesystem. Ich will aber nicht verschweigen, daß auch der radeon so seine Schwierigkeiten mit älteren Karten hat.
 

marcnesium

New member
Themenstarter
Registriert
28 Mai 2009
Beiträge
32
Oh verdammt, sieht wirklich so schlecht aus? Erstmal danke für die flotte Antwort!

Ja, habe mir gerade mit unetbootbin einen 10.04 live usbstick fertig gemacht und ausprobiert...
Mit einem Monitor alles super, sobald der 2. dranhängt, werden die Effekte ausgeschaltet - immerhin! Bei 11.04 sieht man dann nur noch buntes Byte-Rauschen...

Tja, das gibt es doch nicht. Keine Möglichkeit composition im Dualhead-Betrieb zu nutzen? :(
Da hat man schon einen 3D-fähigen Grafikchip und kann ihn aber nur eingeschränkt bis gar nicht nutzen...

Aber ich will noch nicht aufgeben. Vlt ist es nur eine "Miskonfiguration". Kann mir jemand ein paar config-Dateien / Tools an den Kopf werfen, die an dieser Stelle (Ubuntu 11.04/compiz/radeon) relevant wären? Bin da noch nicht fit, aber bereit mich einzulesen.

DANKE!

Ciao, Marc.
 

linrunner

Ubuntuversteher
Registriert
22 Juni 2007
Beiträge
12.801
*boing* Erste Anlaufstation bei Ubuntu ist immer das uu.de-Wiki: http://wiki.ubuntuusers.de/Grafikkarten/ATI/radeon

Außerdem natürlich
Code:
man radeon

EDITH meint, hier wäre noch ein /etc/X11/xorg.conf Skeleton ohne Optionen:
Code:
Section "Monitor"
	Identifier 	"Generic Monitor"
EndSection

Section "Screen"
	Identifier 	"Configured Screen Device"
	Device		"Configured Video Device"
	Monitor		"Generic Monitor"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Driver		"radeon"
EndSection

EDITH2: Du solltest auch Google mal prüfen lassen, ob Compiz selbst in diesem Fall verweigert.
 
Zuletzt bearbeitet:

marcnesium

New member
Themenstarter
Registriert
28 Mai 2009
Beiträge
32
So schnell geht ein ganzer Vormittag drauf...

Noch keine Lösung...

Was ich bisher nützlich fand:

https://help.ubuntu.com/community/RadeonDriver

Es schien mal Probleme mit FireGL gegeben zu haben, die Infos scheinen aber auch alt zu sein. K.A. was davon noch aktuell ist: http://www.thinkwiki.org/wiki/Additional_options_for_the_radeon_driver

http://ubuntuforums.org/showthread.php?t=1743667

Ich habe mal KMS ausgeschaltet (ging nur per grub), hat aber keine Erkenntnisgewinn gebracht. (https://wiki.ubuntu.com/X/KernelModeSetting).

Auf der Suche nach einer Möglichkeit einen Bugreport zu senden, bin ich auf folgendes gestoßen (gleich 1. Treffer):
https://bugs.freedesktop.org/buglis...c&bug_status=__open__&product=&content=firegl

Dort habe ich mal meine Situation gepostet, mit Foto (https://bugs.freedesktop.org/show_bug.cgi?id=16226).

Ein generelles Problem mit zwei Monitoren scheint compiz laut allwissender Müllhalde nicht zu haben.

@linrunner: Hast du konkret ein T42p? Kennst du jemanden der einen hat? Ich frage, weil es mir um konkreten Erfahrungsaustausch geht...

Danke!

Schönen SO! Ciao, Marc.
 

marcnesium

New member
Themenstarter
Registriert
28 Mai 2009
Beiträge
32
Auf den bug report wurde inzwischen geantwortet (https://bugs.freedesktop.org/show_bug.cgi?id=16226#c6): Es scheint eine hardware Limitierung zu geben (maximale Texturgröße). Überschreitet der Desktop eine maximale Breite von 2048 Pixel, sollte compiz eigentlich gar nicht erst gestartet werden. Mit meinem 2. Monitor ergibt sich eine solche Situation (1600x1200 + 1280x1024). Schade, dann sehe ich ein, dass an der Stelle nichts zu holen ist. Diese Akte ist für mich geschlossen. :/
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben