Seltsame Festplattenaktivitäten unter Ubuntu 11.04 (Natty)

Typewriter

New member
Registriert
16 Okt. 2010
Beiträge
145
Hallo zusammen,
ich habe vor kurzer Zeit ein Upgrade auf Version 11.04 (von Maverick) durchgeführt und stelle jetzt gelegentlich fest, dass nach einiger Zeit im Leerlauf oder unter geringer Belastung, vorzugsweise nach dem Aufheben der Sperrung des Computers, die Festplatte anfängt auf Hochtouren zu arbeiten. Das würde mich nicht einmal so sehr stören (schließlich mache ich da ja gerade nichts), das Problem liegt darin, dass die Festplatte nicht aufhört, auch wenn ich den Computer wieder belaste. Das System reagiert dann sehr träge, das Bild stockt und vor Kurzem hat es sich auch einfach aufgehängt, nur weil ich die Maus bewegen wollte. Wenn ich es schaffe, mich abzumelden oder den Rechner neu zu starten, ist nach dem Login wieder alles normal.

1. Ist das ein Bug oder ein Feature?
2a. Wie wirkt sich der Fehler genau aus?
2b. Was beinhaltet die Funktion und wozu ist das gut?
3a. Wie kann ich den Fehler beheben?
3b. Wo kann man das abstellen?

Dazu ist vielleicht noch zu sagen, dass beim Upgrade die Fehlermeldung kam, dass ein Fehler aufgetreten ist. Der Vorgang wurde danach abgebrochen, aber ich habe trotzdem ein funktionsfähiges Natty mit allem Drum und Dran (obwohl ich aber Unity nicht nutze).

Ich hoffe auf eure Antworten, und sollte es auch nur ein Link zu einem Thread sein, den ich trotz gründlicher Suche nicht gefunden habe.

Vielen Dank im Voraus & einen freundlichen Gruß,

Typewriter
 

kalibari

New member
Registriert
24 Aug. 2010
Beiträge
659
3c. Hast du schon versucht z.B. mit htop den Prozess zu finden der dein System lahm legt?
 

sys.

Active member
Registriert
9 Aug. 2010
Beiträge
3.177
1. Das ist ein Feature: Linux hat keine Bugs (obwohl ist Klickibuntu noch ein Linux???)

- Nein, mal im Ernst: Das ist ein Fehler... Sicher dass das die Platte und nicht der Lüfter ist? Ubuntu 11.04 lastet nach einem Upgrade oft den Prozessor recht sinnfrei aus...
- Bei mir lief Ubuntu 11.04 aus dem Upgrade heraus auch mehr schlecht als recht... Eine Neuinstallation läuft erstaunlicherweise deutlich schneller.
- Ich bin mitlerweile fast komplett auf Debian gewechselt, lediglich auf dem R500 läuft noch Natty, weil ich noch nicht dazu gekommen bin das System zu migrieren, aber das ist ein anderes Thema...
 

buddabrod

New member
Registriert
15 Juni 2007
Beiträge
3.740
Wie viel Ram/Swap hast du?
Lässt sich per free -m nachprüfen.

Desweiteren kannst du während der Auslastung einfach per top oder iotop sehen, welcher Prozess daran schuld ist.
 

Typewriter

New member
Themenstarter
Registriert
16 Okt. 2010
Beiträge
145
Erstmal ein ganz großes Dankeschön für die Antworten und Hinweise.
Hier noch ein paar Rückmeldungen von mir:

1. @sys: Ich bin mir sicher, dass es die Festplatte ist. Erstens kann man das relativ leicht vom Lüfter unterscheiden (wenn der so klackert ist sowieso was falsch) und zweitens habe ich ja meine Clearplate-Lampe für Festplattenaktivität.

2. @buddabrod: Ich habe 2GB RAM und zusätzlich 1GB Swap.

3. @kalibari: Ich werde versuchen, bei der nächsten solchen Situation mal den Prozess zu finden, der das verursacht.

Und dann mal Natty ganz neu installieren (oder Debian, ich überlege das in letzter Zeit immer wieder, oder Maverick, da ging alles noch).
 

Bad TuX

Member
Registriert
25 Nov. 2009
Beiträge
36
Festplattendefekt ist auszuschließen?
Eventuell mal die SMART Daten auslesen. (zB smartmontools)
 

dirkk

Active member
Registriert
15 Apr. 2006
Beiträge
1.507
Wie lange läuft denn der Prozess dann? Kann es nicht sein, dass es die tägliche Routine (wie updatebd etc.) ist?
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben