Merkwürdigkeiten beim X31 Akku

Humpert

New member
Hallo,

bei dem Akku meines X31 (11.2003, 28 Zyklen) habe ich folgende Merkwürdigkeiten festgestellt:

Zunächst hatte er 61% der ursprünglichen Ladekapazität. Ich hab ihn ganz leer laufen lassen (aber ohne Restentladung) . Er hatte, wie gewünscht 63% der ursprünglichen Ladekapazität.
Das hab ich dann nochmal gemacht und fest gestellt, dass nur noch 53% der Kapazität vorhanden waren. So weit, so gut, alter Akku, ist eben so.

Allerdings mußte oder durfte ich feststellen, dass beim nächsten Versuch unter Beobachtung der X31 noch 1Stunde lief, obwohl die Batterieanzeigen auf 0% standen.

Das ist mir nun ein Rätsel. Vielleicht hat jemand ähnliches beobschtet und vielleicht kann mir jemand erklären, was davon zu halten ist.
Brauche ich einen neuen Akku oder ist dieser trotz der Merkwürdigkeiten noch OK, denn er läuft noch 2,5 bis 3 Stunden.

Gruß H
 

atomic-virus

New member
der akku ist voll in ordnung.

ich habe folgendes beobachtet: die anzeige der restkapazität des akkus steht irgendwann auf 0%. Normalerweise veranlasst das den user, das Netzkabel einzustecken, und den akku zu laden.

Wie du schon sagtest ist das eigentlich unnötig, da der akku noch ne ganze zeit weiter läuft. Irgendwann habe ich dann mal versucht rauszufinden, wie lange er denn noch weiterläuft und habe bemerkt, dass der rechner sich immer bei ner bestimmten minimal-akkuspannung abschaltet.

Also habe ich immer versucht, möglichst dicht an dieser spannung erst das Netzkabel einzustecken, und dabei hab ich dann folgendes bemerkt:

[Im Normalfall spricht man bei LiIo-Akkus ja davon, dass diese keinen Memoryeffekt mehr haben, also nenne ich das ganze einfach mal Kapazitätsverlust.]

Wenn ich das Netzteil einstecke, wenn Windows meldet, dass die Akkuspannung kritisch ist, also unmittelbar, nachdem die Akkukapazität auf 0% fällt, dann ist der Kapazitätsverlust pro Zyklus viel höher, als wenn man das Netzteil so dicht wie möglich an der Minimalspannung einsteckt. Teilweise scheint es den Akku sogar zu reanimieren, sprich die wirkliche akkukapazität zu erhöhen, wenn man das netzteil später einsteckt.


Das Problem bei der sache war bei mir dann immer, dass ich mir beim windows-warnen gesagt habe, dass der laptop sowieso noch ne halbe stunde durchhält, und ich mich erstmal nicht drum kümmern muss... Wenn man dann grad am arbeiten ist, geht natürlich der laptop irgendwann aus, und die daten sind weg. Blöd.

Das ganze hat mich dann dazu veranlasst, mir ein kleines Programm zu schreiben, was ich hier schon länger mal vorstellen wollte.

Nach dem start des Programms hat man eine Bedienoberfläche vor sich, in die man eine Beliebige Minimalspannung eintragen kann. Wird diese Minimalspannung unterschritten, so werden die ausgewählten aktionen durchgeführt. Als Aktionen hab ich bis jetzt Die Ausgabe einer Nachricht, das ausgeben eines Tones (wenn das in zusammenhang mit "force" gewählt wird, dann wird der ton auch dann ausgegeben, wenn das system eigentlich gemutet ist) und das versetzen des systems in den ruhezustand (der natürlich auch erzwungen werden kann, damit keine rückfragen erfolgen) eingebaut. Das ganze benutze ich jetzt seit etwa 2 monaten im testbetrieb unter windows xp auf meinem t40. Da liegt die Akku-Minimalspannung etwa bei 9250mV, die Grenze, die ich immer nutze, um das Netzteil anzuschließen liegt bei 9300mV... Wenn ich will, das das System in den Ruhezustand fährt, dann nehm ich 9400mV, da ja noch eine gewisse Zeit vergeht, bis der Arbeitsspeicher auf die Platte geschrieben wurde.

Benutzung auf eigene Gefahr.
Ich weiß nicht, wie das ganze auf anderen Plattformen wirkt.
Fragen, Wünsche, Anregungen, Feedback sind selbstverständlich erwünscht.


edit:
ich habe auf anraten von ingope hier einen neuen thread eröffnet. Das Programm findet man jetzt dort.
 

Henricus

New member
Schöne Sache, danke =). Ich war gerad eh einen A30-Akku am leerlaufen lassen, ging bis knapp unter 9000 mV ;-), dann war erst die Hintergrundbeleuchtung weg, und kurz danach war er aus...

Das Progrämmchen läuft also auch auf einem A30 mit Windows 2000 pro.
 

tom_k

Meister
Vielen Dank auch von mir,
kenne das ebenfalls mit der falschen akkuanzeige,
und immer ein auge auf die aktuelle spannung zu werfen ist irgendwie suboptimal ;)

neben dem ganzen mist den so leute wie bill produzieren ;)
endlich mal wieder was Brauchbares
(wenn das proggy sauber löppt, ist nicht persönlich, bin da immer skeptisch;)
btw, liest das prog nur unter acpi die akkudaten oder reicht schon apm, also natives 98se?

Gruss tom_k

p.s.
beim T2x liegt die Schaltschwelle mE bei ca 9.6V
 

rudolfka

New member
hallo,
wenn ich das richtig verstanden habe, machst du quasi ein permanentes rekalibrieren ohne zusätzliche Zyklen. Das ist sicherlich lebensdauererhöhend. Es ist quasi das, was der Akku von sich aus auch machen würde, wenn Bios und Windows ihn lassen würden. Als Programm interessant und auf jeden Fall besser als die Standardroutinen.
mfG
Rudolf
 

ingope

Moderator im Ruhestand
Bin grad mal beim Akku Hardcore Test.

Er steht auf 1 % seit sage und schreibe 40 min :)

Last 13840 mV zur Zeit.
 

Flexibel

Active member
Original von atomic-virus
[Im Normalfall spricht man bei LiIo-Akkus ja davon, dass diese keinen Memoryeffekt mehr haben, also nenne ich das ganze einfach mal Kapazitätsverlust.]
Es hat auch gar nichts mit dem Memoryeffekt zu tun.

Die Tankuhr geht einfach nur falsch und muss deshalb immer wieder geeicht werden.

Meinen guten AKKU, der noch 49,08 Watt hat entlade ich zum Schluss immer in der X3. Im X31/X32 ist dann auch ein AKKU drin damit automatisch umgeschaltet wird. Unterwegs soll die Tankuhr immer genau gehen und dafür muss man voll entladen.

Habe jetzt 16 Ladungen und noch 49,08 Watt von 51,83 Watt. (Der 4,8 AH - AKKU!)

Gruß Flexibel
 

atomic-virus

New member
(wenn das proggy sauber löppt, ist nicht persönlich, bin da immer skeptisch;)
hier und da kanns sein, dass es noch hapert, ich glaub wenn die meldung noch angezeigt wird und das programm geschlossen wird dann gibts ne fehlermeldung, aber ich arbeite dran ;)
(sollten irgendwelche fehler auftreten, dann kurze meldung an mich... wenn ich vom fehler weiß, kann ich ihn auch beheben)

btw, liest das prog nur unter acpi die akkudaten oder reicht schon apm, also natives 98se?
uuuh, harte frage... müsst ich mal ausprobieren (oder mag jemand anders?)
also die soundausgabe und ruhezustand funktionieren da glaub ich nicht richtig, von daher wohl sowieso nur stark eingeschränkt...

@rudolfka: permanentes rekalibrieren? ich dachte bisher immer, dass dabei noch mehr gemacht wird, aber gut... man lernt nie aus...

@ingope: und wie lange hat er noch durchgehalten?

@flexibel: memoryeffekt ist ja nur ein begriff, der für viele vielleicht greifbarer ist, als akkudekalibrierung... am ende kommts aufs gleiche raus, kürzere arbeitszeit ohne steckdose...

Das Programm dient im Prinzip nur der besseren Abschätzbarkeit, wann wirklich schluss ist, Ideen für die Weiterentwicklung schwirren mir schon im Kopf rum, z.B. ein Relay über den parallelport so zu schalten, dass der rechner genau im richtigen moment ans netz geschaltet wird.

oder eine art Restlaufzeit-anzeige, die eben auf der Spannung basiert und nicht auf der vom akku ausgegebenen restkapazität
mal sehen, wann ich wieder zeit finde...

danke fürs feedback :D
 

ingope

Moderator im Ruhestand
Das Programm ist auf jeden Fall sehr gut !

Ich würde einen Thread dafür aufmachen, hier bekommen es zuwenige mit.

Ich habe es gestern Nacht noch bis auf 11220 mV probiert.
(Bis er von alleine ausgeht war mir zu lang, ich war todmüde :) )
Das R40 piepte schon aber er lief immer noch.
Insgesamt über 50 min auf 1% ! Wahnsinn.
Normal häng ich bei 5% das Ladegerät ran

Der Hauptakku hat jetzt 1,2 Wh als noch die letzten Ladungen, ist das normal?
 

Henricus

New member
Wird beim Hauptakku jetzt 1,2 Wh mehr angezeigt? Das wäre normal und ist ein Effekt der Rekalibrierung. Die Kapazität war wohl auch schon vorher da, nur jetzt weiß es auch der Akku ;-).

P.S. Probier das auch mal mit dem Ultrabay-Akku ;).
 

ingope

Moderator im Ruhestand
Mein Hauptakku zeigte immer maximal 44,41 Wh an auf mehr kam er nicht.

Jetzt nach dem langen laufen auf 1% kommt er auf 45,61 Wh.
Das werde ich mal die nächsten Tage öfter Testen, vielleicht bekommt
man den Akku wieder etwas reaktiviert.

"Fabrikkapazität ist 57.60 Wh"


Mit dem Ultrabay Akku würd ich das gerne machen, nur wie? Das geht
ja nicht wirklich da er ja sobald der Ultrabay leer ist auf den Hauptakku geht.
 

ingope

Moderator im Ruhestand
Uih klasse, dann mach ich mal Ultrabay Akku Reanimation :D

Müsste gleich wieder voll sein der Akku :)
 

ingope

Moderator im Ruhestand
Geht ja tatsächlich :)

So nun ärgern wir mal den Ultrabay :)
Mit den Prozentzahlen gehts aber im 10 sek Takt runter :D
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben