Linux GPT / UEFI Neuinstallation Linux schlägt fehl wg. GRUB

Linux Betriebssystem

Harry_W

Member
Registriert
12 Juni 2011
Beiträge
503
Eines meiner T420 hat eine ganze Weile (gut verpackt) ungenutzt herum gelegen. Das installierte Debian (Stretch) ist ständig eingefroren, also sollte ein neues Linux drauf. Auf allen meinen Sandy Bridge TPs (mit gemoddeten Bios Versionen ohne White List und mit freiem Experten Menu) laufen seit Jahren Linux Installationen mit UEFI / GPT. Den Stick zum Installieren habe ich wie immer mit Rufus erstellt (mit GPT + UEFI). Bei der Installation partitioniere ich wie gewohnt (Neue Partitionstabelle, sda1 500MB EFI, sda2 1000MB /boot ext4, sda3 / ext4, sda4 16GB swap). Das System wird zunächst installiert, Hardware erkannt. Kurz vor Ende der Installation kommt dann plötzlich die Warnung, dass GRUB nicht auf sda installiert werden konnte und die Installation wird abgebrochen. Ich habe drei verschiedene Linux Distributionen versucht, immer mit dem gleichen Fehler.

Zuerst dachte ich an ein Problem mit der SSD. Also eine neue eingebaut, mit dem gleichen Resultat. Die Installation von GRUB schlägt wieder fehl. Im Bios sind im Experten Menu UEFI aktiviert und Legacy deaktiviert. Im Boot Menu auch entsprechend UEFI only gesetzt.

Nächster Verdacht war ein Defekt am Thinkpad. Weil aber immer erst bei GRUB gemeckert wurde, habe ich probeweise mal einen USB Stick mit Linux Mint im MBR Modus erstellt und im Bios in beiden Menus MBR statt UEFI gewählt. Damit wird Mint jetzt sauber installiert und läuft. Da aber mehrere baugleiche und auch das betroffene TP(s) bei mir seit Jahren problemlos mit UEFI laufen, verstehe ich nicht, wo jetzt plötzlich das Problem liegt.

Ich könnte zwar jetzt testweise versuchen, auf einem der anderen TPs Mint im UEFI / GPT Modus zu installieren und sehen, ob der gleiche Fehler bei GRUB auftritt. Aber dafür ein Gerät aus dem laufenden Betrieb zu nehmen, gefällt mir nicht wirklich.

Hat vielleicht jemand eine andere Idee, woher das Problem plötzlich kommen könnte? MBR funktioniert ja problemlos und die letzten Jahre war UEFI / GPT auch nie ein Problem. Hat es seit Debian Stretch irgend eine Änderung gegeben, die Ursache des Problems sein könnte? Auch wenn MBR gerade läuft, würde ich doch gerne wie bisher weiter UEFI / GPT benutzen.
 

boletusmaximus

Active member
Registriert
4 Juli 2020
Beiträge
279
Vermutlich werde ich zeitnah, also spätestens am Wochenende, auf einem T520 Ubuntu installieren und kann gerne berichten, wie es lief.
Bisher hatte ich auf ThinkPads noch keinerlei Probleme bei der Installation gehabt, außer hier:

https://thinkpad-forum.de/threads/ich-gebe-es-auf-x121e.231277/#post-2297352

Wenn du bei dem Gerät aus dem laufenden Betrieb die bisherige Festplatte ausbaust und gegen eine andere zum Testen tauscht und im BIOS nichts umstellst, bzw. es danach wieder richtig zurückstellst, sollte es eigentlich keine Probleme geben, wenn du dann eine Testinstallation durchführst.
 

fakiauso

Member
Registriert
25 Nov. 2012
Beiträge
476
Vielleicht hilft auch das hier. Gibt es außer dem fehlgeschlagenen Installieren von grub noch eine genauere Fehlermeldung? Der Tip des Installierens auf einem baugleichen T420 und dem Wechsel der Platte in das verratzte ist jedenfalls nicht schlecht als Versuch. Viel mehr Arbeit als den Tausch der SSD hast Du damit auch nicht und zumindest findest Du dann heraus, ob die saubere Installation dann auf dem maladen Book im UEFI/GPT bootet oder nicht.

Das Einfrieren von Debian deutet ggf. auch auf einen Hardwarefehler hin, der sich jetzt u.U. auf die Installation auswirkt. Jedenfalls scheint da eher das Book die Ursache zu sein.
 

Volvo-Berti

Active member
Registriert
10 März 2006
Beiträge
2.121
ich hatte beim Testen mit Debian 11 auf dem X220 auch so meine Probleme. Es war allerdings im BIOS auch Legacy und UEFI enabled. Geschrieben hatte ich den Stick auch mit Rufus als MBR. Dann habe ich mal einen stick gemacht mit Mint, das lief ohne Probleme durch. Schon seltsam, vielleicht liegts doch am Debian?
 

Harry_W

Member
Themenstarter
Registriert
12 Juni 2011
Beiträge
503
Erst mal danke für alle Antworten.

Was spricht gegen den legacy mode ???

Mit Debian 11 geht UEFI inkl. SecureBoot meist gut.
Beitrag automatisch zusammengeführt:

PS: https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/
Wie schon gesagt installiere ich seit Jahren sämtliche Thinkpads (und auch alle anderen Rechner) mit UEFI / GPT. Dass ich bei den TPs so auch mal im Notfall eine SSD zwischen den Geräten tauschen kann, ist nur einer der Gründe. Probleme in der Vergangenheit mit größeren HDDs waren ein weiterer Grund, auf MBR zu verzichten.

Nachdem ich diverse Wikis zum Thema UEFI gelesen habe und keine wirkliche Ursache für mein Problem finden konnte, habe ich einfach mal gparted als Live Iso gezogen und damit die SSD nochmal neu partitioniert. Anders als bei der gparted Version von Mint und den anderen Linux Versionen, die ich probiert hatte, hatte ich da mehr Auswahlmöglichkeiten. Also bei der Partitionstabelle 'GPT' gewählt, die EFI Partition als FAT32 erstellt und den Rest wie gehabt als ext4 und swap Partitionen. Dann wieder den Mint Live USB Stick benutzt, die Partitionen übernommen und diesmal gab es keine Fehlermeldung mehr. Mint ist sauber mit GPT / UEFI installiert und läuft.

Warum das mitgelieferte gparted der Linux Distributionen nicht das gleiche schafft, muss ich nicht verstehen. Ich gehe doch mal davon aus, dass bei einem Live Linux, das im UEFI Modus läuft (tut es, habe ich mehrfach gecheckt), das Partitionstool in der Lage sein sollte, die richtigen Dateisysteme für die Partitionstabelle und die EFI Partition zu wählen (wenn man schon nicht manuell wählen kann).

Was ich oben auch zu erwähnen vergessen habe, ist, dass ich auch zweimal der Distribution die Partitionierung überlassen habe. Also 'gesamtes Laufwerk löschen und xyz-Linux neu installieren' statt manuell zu partitionieren. Auch da kam am Ende die Fehlermeldung zur fehlgeschlagenen Installation von GRUB auf sda.

Falls jemand eine Idee hat, woran es gelegen haben könnte, würde es mich immer noch interessieren. Man lernt ja gerne dazu. Außerdem werde ich die nächste Zeit noch alle anderen Thinkpads von Debian Stretch vermutlich auf Mint 20.3 updaten. Wenn ich da nicht jedesmal noch vorher gparted Live benutzen muss, wäre das hilfreich.
 

mcb

Active member
Registriert
18 März 2009
Beiträge
4.096
Ja mit dem Umstecken hast du Recht ... ok.

Ist jetzt auch nicht die Lösung:

- mein T440s weigert sich Betriebssysteme im UEFI-Mode zu starten (Win und Linux), am T490s funktioniert es immer. :unsure:
 

Harry_W

Member
Themenstarter
Registriert
12 Juni 2011
Beiträge
503
So manches Bios bietet gar keinen Legacy Modus mehr an. Bisher hatte ich mit UEFI auch kaum Probleme. Aber mir fiel irgendwann heute ein, dass ich vor Jahren mal ein störriges Gerät mit UEFI Problemen als 'Patienten' hatte. Da war auch gparted live die Lösung.
 

Volvo-Berti

Active member
Registriert
10 März 2006
Beiträge
2.121
mal sehen, ob ich da morgen mal am macmini mal mit nem Linux-stick boote, auf dem Sparky Linux ist (Debian-basiert). das kenne ich von vor 2 Jahren und hatte mich immer überzeugt.
 

Harry_W

Member
Themenstarter
Registriert
12 Juni 2011
Beiträge
503
Wenn Debian nicht so gewaltig in den Versionsnummern hinterher hinken würde, wäre ich gerne dabei geblieben. Aber u.a. der 'veraltete' Firefox hat immer wieder Probleme gemacht, wenn Drittanbieter eine halbwegs aktuelle Version vorausgesetzt haben. Mit Mint bin ich bisher zufrieden. Nur Gnome Shell fehlt mir. Ich hatte mich an die Bedienung gewöhnt und auf Notebooks fand ich es richtig gut (bis auf die 'Entmachtung' des Users im Vergleich zum klassischen Gnome). Klar, kann man nachinstallieren. Aber der Focus bei Mint liegt eben klar auf den drei 'offiziellen' Desktops.
 
Zuletzt bearbeitet:

mcb

Active member
Registriert
18 März 2009
Beiträge
4.096
Na ja ... Firefox und Thunderbird gibt es auch direkt von Mozilla. :)

Hier läuft gerade FF 97 b2 unter Bullseye. Ja Gnome ist klasse - ich möchte nichts Anderes.
 

xsid

Active member
Registriert
29 Mai 2007
Beiträge
3.340
@mcb

Vermutlich hast Du auch ein sauber auf gesetztes System.

Thinkpads von Debian Stretch vermutlich auf Mint 20.3 updaten.

Haltet euch einfach an die offiziellen Anleitungen, dann hat man weniger Probleme.
Nicht so viel mischen.

Bei diesem Thread verknoten sich meine Synapsen.
 
Zuletzt bearbeitet:

Harry_W

Member
Themenstarter
Registriert
12 Juni 2011
Beiträge
503
Welche offizielle Anleitung denn? Den USB Stick mit dem aktuellen Mint Iso und Rufus erstellen, ist für mich der 'offizielle' Weg. Ich kenne sonst kein Tool, bei dem ich beim Erstellen des Sticks zwischen MBR und GPT bzw. Legacy und UEFI wählen kann. Rufus wird regelmäßig zum Erstellen der Installationsmedien bzw. Live Sticks empfohlen.

Und mit 'updaten' meine ich natürlich eine Neuinstallation auf eine frisch partitionierte SSD und kein Crossgrade oder ähnliche Experimente. Ich dachte, das wäre offensichtlich. Mit Update meinte ich einfach nur, dass Stretch inzwischen in die Tage gekommen ist und es Zeit für ein neues Betriebssystem wird.
 

xsid

Active member
Registriert
29 Mai 2007
Beiträge
3.340

Von Rufus sehe ich da nichts.

Vorab prüfen:


und erfragt den korrekten Start des Startmedium mit der Eingabe in das Terminal von:

mount | grep efivars
Hierbei sollte eine Ausgabe erfolgen mit folgendem Inhalt:

... /sys/firmware/efi/efivars...
Erfolgt hierbei keine Ausgabe, so ist eine Installation im EFI-Modus nicht möglich.

Dann viel Erfolg

MfG

xsid
 
Zuletzt bearbeitet:

Harry_W

Member
Themenstarter
Registriert
12 Juni 2011
Beiträge
503
Danke für die Links. Werde ich beim nächsten TP mal ausprobieren.
 

TinkTank

Member
Registriert
14 Okt. 2021
Beiträge
33
Bei der Installation partitioniere ich wie gewohnt (Neue Partitionstabelle, sda1 500MB EFI, sda2 1000MB /boot ext4, sda3 / ext4, sda4 16GB swap).

Ist es wirklich zwingend nötig zwei Bootpartitionen zu haben wenn man GPT wählt? Das war mir nämlich neu. Auch ich hatte überlegt die nächste linux ins. Über gpt zu versuchen? Und wie verhält es Sich mit der frage ob mann /boot nicht in ext2 formatieren sollte...?
 

mcb

Active member
Registriert
18 März 2009
Beiträge
4.096
Ich meine /boot braucht es nur bei vollverschlüsselten Systemen extra.
 

Harry_W

Member
Themenstarter
Registriert
12 Juni 2011
Beiträge
503
Ich lege aus Gewohnheit eine eigene /boot Partition an, falls ich doch mal verschlüsseln will. Früher hatte ich auch eine eigene /home Partition. Aber da beim Parallelbetrieb und auch bei Neuinstallationen von anderen Linux Versionen ohnehin praktisch immer Probleme bei einer gemeinsamen /home Partition auftreten, kommt nur noch /boot auf eine eigene Partition.
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben