Linux (GELÖST) Drucker Scanner an Netzwerkordner erfolglos

Linux Betriebssystem

Tetradrachm

Member
Registriert
25 Sep. 2010
Beiträge
478
Servus...

dies ist ein Crossposting - leider habe ich es etwas dringend und im Ubuntu Forum konnte mir die Antwort keiner schreiben - bzw. mögliche Lösungsversuche. Und zwar versuche ich mit einem Laser Multifunktionsdrucker einen Scan als PDF auf einem freigegebenen Netzwerkordner des Linux Server abzuspeichern. Die erste Konfiguration war ein QNAP NAS und ein öffentlicher Ordner, was einwandfrei funktioniert hatte. Das QNAP NAS wurde von einem Windows Server abgelöst - da hat es erst nicht geklappt - ich musste unter Windows 10 ein altes Protokoll herunter laden und installieren - dann hat es einwandfrei geklappt.

Da der Windows Server "abgeraucht" war - wurde dieser durch einen Linux Server ersetzt. Dort habe ich einen Benutzer, der hat einen Ordner im Netz freigegeben. Und im Drucker habe ich in der Webconsole die Möglichkeit auf den Pfad mit Benutzername und Kennwort zuzugreifen und die gescannten Dokumente als PDF abzuspeichern. Aber es wird in dem Ordner nichts abgespeichert.

Wäre der Pfad falsch oder nicht existent oder kein Zugriff darauf möglich - würde der Drucker beim Scannen eine Fehlermeldung bringen. Tut er aber nicht. Er speichert das PDF nur nicht in den Ordner ab. Von anderen Mac und Windows Rechner hat man mit dem Benutzernamen und Kennwort übrigens Vollzugriff auf den Scanner Ordner - der Ordner ist also für jeden Rechner im Netz erreichbar und man hat Lese und Schreibrechte. Das habe ich auch schon ausprobiert.

So - da Crossposting - hier ist der Thread im Ubuntu Forum:
https://forum.ubuntuusers.de/topic/scan-speichern-unter-netzwerkordner-geht-nicht/

Und das ist der Text:
ich habe hier einen Brother Laser Multifunktionsdrucker, mit dem man auch scannen kann und das Ergebnis als Datei im Netzwerk auf einem freigegebenen Ordner speichern kann. Zuerst hatte ich das "vor Jahren" auf einem QNAP NAS und einem öffentlichen Ordner - danach auf einem Windows Rechner, auf dem ich einen öffentlichen Ordner im Netzwerk freigegeben hatte. Nur unter Windows gab es Probleme - ich musste da ein altes Protokoll herunter laden / installieren - danach konnte der Scanner auch auf den Windows Ordner die gescannten Sachen als PDF abspeichern.

So - und nun ist es ein Linux ubuntu "Sever" auf dem die gescannten Dokumente in einem freigegebene Ordner als PDF abgespeichert werden sollen.

* Auf dem Linux Rechner habe ich einen Ordner freigegeben: "SERVER - Scan"

* Der Ordner ist im Netzwerk freigegeben, der Besitzer des Ordners ist der "Hauptuser" der Linux Installation

* Mit anderen Rechnern (Mac und Windows) kann ich über das Netzwerk mit dem Linux Benutzernamen und Kennwort ohne Probleme auf diesen Ordner zugreifen - und zwar lesend und schreiend (!)

* Nur der dumme - sorry - Drucker Scanner will partout nicht auf den Ordner den Scan als PDF abspeichern

Wenn der Ordner oder Pfad nicht existieren würde, würde das Panel des Druckers übrigens eine Fehlermeldung bringen! Pfad und Name müssen also stimmen. Wenn irgendwas mit dem Protokoll oder keine Schreiberechte sind - bekommt man bei dem Drucker keine Fehlermeldung! Daher denke ich, dass irgendwas beim Schreiben nicht passt. Den Drucker konfiguriere ich über das Webportal des Druckers - so kann ich Benutzername und Kennwort rein kopieren. Sprich - Benutzername und Kennwort sind am Drucker auch richtig eingestellt.

Hier mal der Screenshot des Druckermenüs - vielleicht könnt Ihr erkennen was da schief läuft? Nehme ich ein falsches Protokoll? Falsche Übertragung?

Ich habe SMB ausgewählt

Der Pfad ist: servername/SERVER - Scan

Der Linux Benutzername ist "server" und dann eben das Kennwort

Der Ordner ist unter Linus mit dem Benutzernamen und Kennwort freigegeben



Vielleicht sind hier ja mehr Linux Profis unterwegs, die mir noch einen Tipp geben können, wo ich suchen könnte nach dem Fehler.
Vielleicht ist SMB ja der falsche Weg. Vielleicht muss ich wegen SMB bei Linux noch was verändern...?!?

Danke!


9359276-IMG_2305.jpg
 

Lufo

ex: michael_dugan
Registriert
17 Jan. 2009
Beiträge
408
Mit "ich musste unter Windows 10 ein altes Protokoll herunter laden" meinst du wahrscheinlich, dass du SMB 1 aktiviert hast, richtig? Beherrscht der Scanner SMB 2 oder SMB 3?
Der Serverpfad muss das Format "\\server-name\freigabe-name" haben. Ich rate dringend davon ab, Freigaben mit Leerzeichen im Namen zu verwenden, auch wenn Windows das unterstützt. Nimm bei Bedarf Unterstriche.
Wenn du auf einem Linux-Server (samba) das SMB 1 Protokoll aktivieren willst, muss folgendes in der Samba-Konfiguration stehen:
------------------------------------------
server min protocol = NT1
ntlm auth = yes
lanman auth = yes
------------------------------------------
Achtung: SMB 1 sowie Lanman/NTLMv1 sind als unsicher zu betrachten.
 
Zuletzt bearbeitet:

ubu

Member
Registriert
23 Mai 2013
Beiträge
87
Gib auf dem Linux mal im Terminal
smbclient -L //localhost
ein, wenn da: SMB1 disabled -- no workgroup available steht ist smb1 deaktiviert, siehe Post von Lufo
 

Tetradrachm

Member
Themenstarter
Registriert
25 Sep. 2010
Beiträge
478
Mit "ich musste unter Windows 10 ein altes Protokoll herunter laden" meinst du wahrscheinlich, dass du SMB 1 aktiviert hast, richtig? Beherrscht der Scanner SMB 2 oder SMB 3?
Der Serverpfad muss das Format "\\server-name\freigabe-name" haben. Ich rate dringend davon ab, Freigaben mit Leerzeichen im Namen zu verwenden, auch wenn Windows das unterstützt. Nimm bei Bedarf Unterstriche.
Wenn du auf einem Linux-Server (samba) das SMB 1 Protokoll aktivieren willst, muss folgendes in der Samba-Konfiguration stehen:
------------------------------------------
server min protocol = NT1
ntlm auth = yes
lanman auth = yes
------------------------------------------
Achtung: SMB 1 sowie Lanman/NTLMv1 sind als unsicher zu betrachten.

1. Danke - das ist schon mal was womit ich arbeiten kann, wenn ich das alles ausprobiert habe, melde ich mich wieder.

2. Genau das - wird es gewesen sein unter Windows 10. Ich musste SMB 1 aktivieren und dazu irgendeine Datei herunterladen / installieren von Windows. Weil per Standard nicht aktiviert. Soweit ich mich erinnern kann.

3. Das wird auch das Problem wieder sein? Der alte (!) Drucker / Scanner kann wohl nur SMB 1 (sonst hätte es ja ohne unter W10 geklappt vermute ich). Dann werde ich die Linux Samba Konfiguration ändern (und berichten). Ich würde ad hoc sagen, dass es wieder daran liegt.

4. Netzwerkpfad schreibe ich so - aber wegen den Leerzeichen hast Du wohl recht. Das werde ich ändern so oder so.


Danke für den Hinweis wegen "unsicher". Da es sich hier jedoch um ein geschlossenes LAN Netzwerk handelt - wo wirklich nur intern die Rechner verbunden sind - ist das dann ok so. Ins Internet - öffentliche Netz kommt keiner der Rechner. Es gibt nur einen "Internet" Rechner der völlig abgekoppelt von allen anderen Rechnern ist.
Beitrag automatisch zusammengeführt:

Gib auf dem Linux mal im Terminal
smbclient -L //localhost
ein, wenn da: SMB1 disabled -- no workgroup available steht ist smb1 deaktiviert, siehe Post von Lufo

Ah super - das teste ich morgen gleich mal.

Danke Euch beiden - wie geschrieben - das ist mal was wo man weiter arbeiten und testen kann! Ich werde morgen berichten!
 

Tetradrachm

Member
Themenstarter
Registriert
25 Sep. 2010
Beiträge
478
Mit "ich musste unter Windows 10 ein altes Protokoll herunter laden" meinst du wahrscheinlich, dass du SMB 1 aktiviert hast, richtig? Beherrscht der Scanner SMB 2 oder SMB 3?
Der Serverpfad muss das Format "\\server-name\freigabe-name" haben. Ich rate dringend davon ab, Freigaben mit Leerzeichen im Namen zu verwenden, auch wenn Windows das unterstützt. Nimm bei Bedarf Unterstriche.
Wenn du auf einem Linux-Server (samba) das SMB 1 Protokoll aktivieren willst, muss folgendes in der Samba-Konfiguration stehen:
------------------------------------------
server min protocol = NT1
ntlm auth = yes
lanman auth = yes
------------------------------------------
Achtung: SMB 1 sowie Lanman/NTLMv1 sind als unsicher zu betrachten.

Mit Deinem Script hat es leider nicht geklappt - nachdem ich mit "smbclient -L //localhost" das ganze geprüft hatte, war SMB1 immer noch deaktiviert. Aber man versucht ja auch selber zu recherchieren und vor allem zu lernen - und daher habe ich weiter gesucht auf Basis Deiner Infos und habe hier was gefunden:

https://wiki.ubuntuusers.de/Samba_Server/smb.conf/

[global]
client min protocol = NT1
server min protocol = NT1

Das habe ich bei GLOBAL eingefügt und nach einem erneuten Test war SMB1 bereit.
Aber Danke natürlich - es ist ja auch immer gut, wenn nicht alles gleich 100% geht, was man "vorgekaut" bekommt und selber suchen und das eigene Hirn anstrengen muss. So lernt man am meisten.



Nun werde ich morgen mal den Scanner testen und hier berichten.
Beitrag automatisch zusammengeführt:

Wenn du auf einem Linux-Server (samba) das SMB 1 Protokoll aktivieren willst, muss folgendes in der Samba-Konfiguration stehen:

Gib auf dem Linux mal im Terminal


So Danke an Euch beiden.

SMB1 ist aktiviert und siehe da - auf einmal tauchen die Dateien auch im Scanner Ordner auf - sprich der Scanner kann die Dateien auf dem freigegebenen Linux Server auch abspeichern.

Thread ist damit erledigt.
 
Zuletzt bearbeitet:
  • nbreview.de
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben