WLAN und Ethernet-Verbindung gleichzeitig - ich raff's nicht!

J

JayCool

Guest
Hallihallohallöle,

ich hab' mal wieder nen Problem mit meinen beiden Rechnern.
Ich hab' beide per WLAN am Access-Point hängen.
Da ich in meinem T40 aber nur eine WLAN-Karte habe, die die 11 Mb/s-Übertragung macht, würde das Übertragen großer Dateien (ein Archiv von roundabout 4 GB) von einem Rechner auf den anderen via WLAN etwas lange dauern.

Aus dem Grund habe ich den T40 mit dem Desktop-PC über ein Crossover-Kabel verbunden.

Auf beiden Rechnern läuft Windows 2000 Professional SP4 mit allen Updates.

Außerdem habbich beide Rechner unter der Arbeitsgruppe "PRIVAT" angemeldet und für den eine Netzwerkkarte die IP 192.168.0.1, für die andere die IP 192.168.0.2 vergeben. Subnetzmaske ist 255.255.255.0 .

Leider gelingt es mir nicht, dass ich in der Netzwerkumgebung den jeweils anderen Rechner sehen kann. Als ich noch kein DSL und WLAN hatte, da ging das immer ohne Problems.

Ich habe auch mal an beiden Rechnern das WLAN abgeschaltet, aber dann hats auch ned funktioniert.

Kann mir jemand erklären, was ich da im Einzelnen einstellen muss?
Geht das überhaupt, dass man mehrere Netzwerke (WLAN und Ethernet) gleichzeitig benutzen kann?
Zusatzfrage: Wenn mehrere Netzwerke vorhanden sind, woher weiss dann zum Bleistift der Internet-Browser, von welchem Netzwerk er die bunten Bildchen abholen soll????

Gruß, Jan
 

moronoxyd

mostly harmless
Teammitglied
Ja, man kann mehrere Netzwerkkarten gleichzeitig benutzen.

Man muss dabei aber darauf achten, daß die Karten in verschiedenen Netzwerksegmenten liegen.

Wenn als die WLAN-Karte die IP 192.168.0.1 hat, dann sollte die Ethernetkarte NICHT eine IP 192.168.0.x haben. Sondern z.B. 192.168.1.1.

Wenn in einem Rechner zwei oder mehr Netzwerkkarten im gleichen Netzwerksegment sind, weiss der Rechner sonst nicht, über welchen der Anschlüsse er die Daten verschicken soll.
(Man kann ihm das sagen, über sogenannte Routen, aber das sollte man sich als Laie sparen.)

Dann sollte jede IP natürlich nur einmal vergeben sein.
D.h. auch, daß keine der Karten in den zwei Rechnern die IP des Accesspoints haben darf.

Wenn das alles stimmt kann es trotzdem schwierig sein, unter Windows Daten zwischen den zwei Rechnern auszutauschen, weil Windows-Netzwerke generell recht frickelig sind.

Du solltest erstmal schauen, ob die Verbindung auf unterer Ebene steht.
Öffne auf beiden Rechnern ein Dos-Fenster (Start -> Ausführen -> "cmd") und probier mal, ob du den jeweils anderen Rechner anpingen kannst ("ping IP_DES_ANDEREN_RECHNERS").

Solange das nicht geht stören entweder irgendwelche Firewalls oder es gibt ein Problem auf Ebene Der netzwerkkarten/-kabel.

WEnn der Ping in beide Richtungen geht gib auf jedem der Rechner wenigstens einen Ordner frei (Rechtsklick, Freigabe).
Einige Minuten danach sollte der REchner in der Netzwerkumgebung des anderen zu sehen sein.

Du kannst auch probieren, ihn direkt anzuwählen, indem du im Explorer in der Adresszeile ""\\IP_DES_ANDEREN_RECHNERS" eingibst.
 

Benerages

New member
Versuch mal folgendes:

Gehe auf Start -> Ausführen und gebe dort \\192.168.0.2 (oder 1 je nachdem welcher PC es ist) ein

IP des jeweils anderen PC's eingeben und es sollte funktionieren
 

buergernb

New member
Hi,

ich glaube das Schlagwort lautet hier "masterbrowser". Such mal bei google danach. 2 Verbindungen zwischen 2 Rechnern ist generell ohne Routing schwer handzuhaben.


BuergerNB
 
J

JayCool

Guest
Themenstarter
Erfreuliche Mitteilung! Problem gelöst!

Ich hab's jetzt doch hinbekommen, meine beiden Rechner direkt über Crossover-Kabel zu verbinden, und gleichzeitig WLAN an beiden Rechnern weiter benutzen zu können!!!

Nebenbemerkung: Ich verwende auf beiden Rechnern Win2k SP4. Ob das bei WinXP oder Vista genauso geht hab' ich keine Ahnung.

Lösung:

Auf beiden Rechnern eine Arbeitsgruppe mit gleichem Namen (z.B. PRIVAT) erstellen.

Start -> Einstellungen -> Netzwerk- und DFÜ-Verbindungen
Dort die zur Ethernet-Karte gehörende Verbindung mit rechter Maustaste anklicken (bei mir 'LAN-Verbindung 2') -> Eigenschaften

Im sich öffnenden Fenster im Karteireiter "Allgemein" die Zeile "Internetprotokoll (TCP/IP)" mit linker Maustaste anklicken, dann Button "Eigenschaften" anklicken.

Option "Folgende IP-Adresse verwenden" anklicken (normalerweise ist in diesem Fenster "IP-Adresse automatisch beziehen" eingestellt).

Beim einen Rechner in diesem Fenster
IP-Adresse: 129.254.131.89
Subnetzmaske: 255.255.0.0
eingeben

Beim anderen Rechner
IP-Adresse: 129.254.131.88
Subnetzmaske: 255.255.0.0
eingeben

OK anklicken.

Im übergeordneten Fenster ebenfalls OK anklicken.

Zur Kontrolle, ob die Werte auch übernommen wurden auf dem jeweiligen Rechner die Eingabeaufforderung (DOS-Fenster) öffnen und den Befehl ipconfig eingeben.
Die Werte müssen dann mit den obigen übereinstimmen.

Anschließend auf dem jeweiligen Rechner Laufwerke oder Ordner freigeben.

Dann auf dem Desktop auf das Icon "Netzwerkumgebung" doppelklicken und im nächsten Fenster "Benachbarte Computer" doppelklicken.

Im nächsten Fenster sollten dann beide Rechner unter ihrem jeweiligen Namen erscheinen. Doppelklick auf den Rechner fördert dann sämtliche freigegebenen Verzeichnisse, Laufwerke und Drucker ans Tageslicht.


Greetz, Jan
 

phil83

New member
Ja, diesen Tipp hat ja moronoxyd schon gegeben: Die Schnittstellen müssen in unterschiedlichen Subnets liegen.

Z.B. wie folgt:

Notebook
LAN: Subnet: 255.255.0.0, IP: 172.16.0.10, Gateway: -
WLAN: Subnet: 255.255.255.0, IP: 192.168.1.30, Gateway: 192.168.2.1

Desktop-PC
LAN: Subnet: 255.255.0.0, IP: 172.16.0.20, Gateway: -
WLAN: Subnet: 255.255.255.0, IP: 192.168.1.40, Gateway: 192.168.2.1

Dann sollte es eigentlich funktionieren.
Es muss natürlich noch drauf geachtet werden, dass nicht irgendwelche Software-FWs die Zugriffe blockieren.
 

Mornsgrans

Help-Desk
Teammitglied
Seht bitte zu, dass im Lan nur private Adressbereiche 10.10.x.x oder 192.168.x.x verwendet werden, ansonsten kann es mit anderen Adressbereichen zu Konflikten kommen.
 

phil83

New member
Original von Mornsgrans
Seht bitte zu, dass im Lan nur private Adressbereiche 10.10.x.x oder 192.168.x.x verwendet werden, ansonsten kann es mit anderen Adressbereichen zu Konflikten kommen.

172.16.0.0/12 darf aber auch benutzt werden.
 
J

JayCool

Guest
Themenstarter
Nochmal Kommando zurück!

Es ging, solange beide Rechner eingeschaltet waren.
Nach dem zwischenzeitlichen Ausschalten und Neustart funktioniert es plötzlich nicht mehr. Es ist echt zum Verzweifeln.

Nebenbemerkung:
Auf die Adresse 169.254.131.88 bin ich gekommen, weil sich die mein T40 automatisch ausgesucht hat.
Für den Desktop habbich dann einfach die nächste Nummer genommen.
S hat mal funktioniert, aber scheint wohl doch nicht so zuverlässig zu sein.

Konstruktive Vorschläge werden also immer noch gerne angenommen!
 

phil83

New member
Original von JayCool
Konstruktive Vorschläge werden also immer noch gerne angenommen!

Siehe meine Empfehlung. Ich habe in meinem Netzwerk gar nichts auf automatisch stehen. Weder die direkt per LAN-Kabel verbundenen Rechner, noch die Notebooks, die über einen WLAN-Router ins Internet gehen. Alles manuell eingerichtet.
 

Mornsgrans

Help-Desk
Teammitglied
Die 169.254.x.x ip Adressen weist WINDOWS sich selbst zu, wenn er keine vom DHCP-Server erhalten kann.

@phil83
Sorry, hab nicht mehr daran gedacht, dass dieser IP-Bereich auch für private Netzte ist.
 

tv34

New member
jetzt werden einige Netzwerkprofis die Haare aufstellen
so schaut es bei mir aus

xxx.yyy.0.1 Router der darf die Adressen xxx.yyy.0.2 und .3 vergeben
(falls Besuch kommt)

xxx.yyy.0.5 .6 .7 - 3 XP-Rechner
xxx.yyy.0.8 .9 - 2 Win98 Rechner
xxx.yyy.0.10 .11 - 2 W2k - Rechner (Datenmüllhalden/Streamingserver)
xxx.yyy.0.18 .19 - 2 Nokia DBoxen
xxx.yyy.0.40 - T40 LAN
xxx.yyy.0.41 - T40 WLAN
xxx.yyy.0.60 - 600X LAN
xxx.yyy.0.61 - 600X WLAN
xxx.yyy.0.90 .91 .92 .93 - 4 Printserver
xxx.yyy.0.99 - WLAN AP

bei allen Geräten ausser den W2k Rechnern ist der
Standardgateway xxx.yyy.0.1 und die bevorzugten/
alternativen DNS-Server eingetragen


3 XP, 2 W2k , DBoxen sind mit GB-Switches verbunden
der Rest mit 10/100er Switches
die beiden W2k Rechner sind ohne Tastatur/Monitor ,
werden über VNC fernbedient

die Hauppauge DVB-S (3) und DVB-T (2) Karten
sind im Bereich xxx.yyy.46.21 bis .25 angesiedelt
die 3 x 1394 Netzwerkadapter von den XP-Rechnern sind auf .31 bis .32
festgelegt , werden aber nicht genutzt

im WLan AP sind die MAC-Adressen der Thinkpads eingetragen

Das gesamte Netzwerk (alle Switches,Printserver,AP,DSL-Modem,Router)
kriegt erst Strom,wenn ein Computer eingeschaltet wird,bzw habe ich bei
meinem Schreibtisch noch einen Schalter falls ich nur AP/Router/Modem
brauche.

die Thinkpads laufen normalerweise über LAN , wenn sie nicht in der
Docking stehen bzw kein Kabel angeschlossen ist über WLAN

mfg Tino
 

alter-hase81

New member
SMB-(Windows-)Netzwerke sind generell ziemlich 'zickig' - wenn die IP-Konfiguration stimmt, hat es bei mir meistens geholfen, die Rechner mit ihren IP-Adressen und Rechnernamen in die lmhosts- oder hosts-Datei einzutragen (einfach mal bei Google suchen, sind glaube ich in Windows/System32/).
Dann suchen sich die Rechner nicht mehr minutenlang, versuchen keine Directory-Server zu finden (die es zu Hause ja meistens nicht gibt), und müssen nicht abwechselnd neu gestartet werden, um sich endlich zu finden...
 

Mornsgrans

Help-Desk
Teammitglied
Original von alter-hase81
SMB-(Windows-)Netzwerke sind generell ziemlich 'zickig' - wenn die IP-Konfiguration stimmt, hat es bei mir meistens geholfen, die Rechner mit ihren IP-Adressen und Rechnernamen in die lmhosts- oder hosts-Datei einzutragen (einfach mal bei Google suchen, sind glaube ich in Windows/System32/).
Dann suchen sich die Rechner nicht mehr minutenlang, versuchen keine Directory-Server zu finden (die es zu Hause ja meistens nicht gibt), und müssen nicht abwechselnd neu gestartet werden, um sich endlich zu finden...

Windows\System32\drivers\etc
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben