T60 W-LAN Schalter

DeKaWe

New member
Registriert
9 Apr. 2006
Beiträge
61
Hallo!

Bei meine T60 gibt es vorne links einen Schalter mit dem ich das W-LAN aktivieren/deaktivieren kann. Unter Windows funktioniert das auch und es wird keine Verbindung gefunden.

Starte ich openSUSE 10.3 zeigt mir der Netzwerkmanager 3 verfügbare Netze an, obwohl der Schalter auf der Stellung Off ist.

Geht es nur mir so?

Ciao Kai
 

buddabrod

New member
Registriert
15 Juni 2007
Beiträge
3.740
Aus machen -> dmesg checken und iwlist wlan0 scan.
Der networkmanager ist eine einzige Katastrophe..
 

DeKaWe

New member
Themenstarter
Registriert
9 Apr. 2006
Beiträge
61
Hallo!

Der Netzwerkmanager hat mich soeben mit einem WLAN Point (unverschlüsselt) verbunden. Also gehe ich mal davon aus der der Schalter keine Hardwarelösung ist. Das WLAN Modul läuft wohl daher ständig. Unter Windows wird das Abschalten dann bestimmt per Software erledigt.

Ciao Kai
 

buddabrod

New member
Registriert
15 Juni 2007
Beiträge
3.740
Original von DeKaWe
Hallo!

Der Netzwerkmanager hat mich soeben mit einem WLAN Point (unverschlüsselt) verbunden. Also gehe ich mal davon aus der der Schalter keine Hardwarelösung ist. Das WLAN Modul läuft wohl daher ständig. Unter Windows wird das Abschalten dann bestimmt per Software erledigt.

Ciao Kai
Welcher Kernel? Welche iwlwifi Version?
Wie schauts mit dem dmesg aus?
Hier funktioniert das, sehr alte Treiberversionen waren recht buggy.
 

donk

New member
Registriert
18 Apr. 2008
Beiträge
11
Der Schalter hat eigentlich zwei Funktionen:
1) Bluetooth ein/ausschalten
2) W-Lan aktivieren /deaktivieren

Bei Bluetooth ist der Schalter hardwareseitig, der ein USB Device ein/aushängt. Da ist zwischen Windows und Linux kein Unterschied, sofern du bluetooth an sich aktiviert hast.

Bei W-Lan ist es (jedenfalls im T60, T60p und T61) eine Treiberfrage, ob er darauf reagieren will oder nicht. Madwifi / ath5k tut's jedenfalls nicht.
Wie man den Hardware Schalter abfängt hätte ich auch noch nicht gesucht, auf's grate Wohl schätze ich irgendwo im nvram, zusätzlich zu diesem gibt es aber noch Fn+F5, den du per acpi event oder tpb mit einem Script belegen kannst, das dann das Modul lädt/entlädt. Den on/off Status muss dieses aber selbst erkennen.

Der Status unter /proc/acpi/ibm/bluetooth, der eigentlich den Status enthalten sollte setzt sich bei 2.6.25 nicht um.
 

DeKaWe

New member
Themenstarter
Registriert
9 Apr. 2006
Beiträge
61
Hallo!

Danke für die interessanten Informationen. Da ich einen WLAN Chip von Atheros in Verbindung mit dem madwifi Treiber verwende ist dir Ursache für dieses wundersame Verhalten geklärt.

Ciao Kai
 
  • nbreview.de
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben