t20 kein embedded controller und akku led blinkt nur orange

toele1410

New member
hallo

habe hier ein problem mit einem t20 hatte erst ein bad crc 175 problem. dann habe ich ein neues dump file eingespielt und das problem wa weg.

das gerät läuft soweit eigentlich nur IST IM BIOS KEIN EINTRAG BEIM EMBEDDED CONTROLLER UND DIE AKKU LED BLINKT NUR ORANGE. akku ist aber in ordnung (geteste im t23).

weiss jemand ob der embedded controller ein chip auf dem mobo ist? welcher chip ist für die ladeelektronik zuständig (wegen dem orange blinken der led)?

mfg
 

rudolfka

New member
hallo,
der Embedded-Controller regelt das Systemmanagement auf Biosebene, zB die Akkufunktionen, das Energiemangement etc. Es gehört jeweils zu einer bestimmten Biosversion eine dazu passende Embedded-Controller-Version. Diese beiden sind bei dir unterschiedlich. Bevor schlimmeres passiert, würde ich von der lenovo-Seite eine passende Biosversion mit Embedded-Controller-Bioserweiterung und Biosupfateprogramm als Diskettenversion herunterladen.
Vorausgesetzt du hast Netzteil und passenden geladenen Akku, sollte das Biosupdate kein Problem sein. Ohne die Erweiterung ist der Akku irgendwann mangels Ladung leer und es wird schwieriger.
Also auf die Biosseite fürs T20 und runterladen. Ich empfehle die letzte Biosversion vor der bei der in der Biosbeschreibung "erweiterte Akkufunktionen" ausgelobt werden. Das ist im wesentlichen eine Herstellerabfrage aus dem Akkuchip. Die unmittelbar vorrausgehende Version enthält diese Abfrage nicht und damit klappts dann auch mit dem günstigen Fremdakku.
mfG
Rudolf (T20, X20,600,e,x, 760,ED,XL,XD u.a.)
PS.:Die älteren Biosversionen findest du wenn du in der Suche unter Support Bios T20 update eingibts und ein wenig blätterst. Auf der Seite ist oben das allerneueste Bios mit Beschreibung, dann am Ende die älteren Versionen und in jeweils einem Link eine genaue Bescvhreibung der Fixes. In der Drivermatrix findest du nur die letzte Version, die ich insbes. für das T20 nicht empfehle.
 

Robbyrobot

New member
Man kann ein BIOS auch "downgraden" mit einem Trick:

- Update-Diskette (von IBM/Lenovo) mit gewünschtem BIOS erstellen
- Dateien phlash.exe, *.FL3 und *.FL1 auf eine frische Bootdisk kopieren (nur Bootdateien darauf, nicht die Update-Disk benutzen!)
- *.FL3 in PLATFORM.BIN umbenennen
- *.FL1 in BIOS.ROM umbenennen
Rechner mit der so präparierten Bootdiskette booten. Das BIOS wird automatisch geschrieben und man muß nur eine Taste am Ende drücken, damit der Rechner hinuntergefahren wird. Danach ist das neue BIOS und (beim T20-T22) Embedded Controller installiert.

Achtung! Auf dieser Weise kann man auch ein falsches BIOS installieren, denn es gibt keine Sicherheitsabfragen. Also peinlich genau darauf achten, daß man das richtige BIOS für den Rechner benutzt, sonst kann man (mit einem falschen BIOS) den Rechner unbrauchbar machen!
 

toele1410

New member
Themenstarter
bios update hat geklappt. bei der letzten version (1.22 bios) ist auch der embedded controller da, aber mit der faschen version (1.00 EC). wenn ich eine andere bios version nehme ist er wieder weg. DIE AKKU LED BLINKT AUCH NOCH ORANGE, AUCH IM AUSGESCHALTETEN ZUSTAND. ES IST AUCH EIN ORIGINAL IBM AKKU.

wenn ich mal ne live knoppix cd starte werde mir auch nur 547 von 700 mhz angezeigt. hat jemand noch ne idee????

mfg
 

rudolfka

New member
hallo,
wenn es geklappt hätte, gäbs auch keine Probleme...
Irgendwas hat nicht geklappt.
Du mußt dich sklavisch an die Anweisungen halten. Alles andere ist Unfug.
Zum vollständigen Biosupdate gehört insbesondere auch eine Reinitialisierung nach dem Update nach Neustart im Bios selbst.
Vermutlich war das embedded Controller-Bios zunächst ganz abgehängt und wird daher beim Upgrade auch nicht geflasht, weil nicht erkannt. Würde mir zu der embedded-Controller-Version, die nun gemeldet wird das passende Bios aus der Biosupdate-History heraussuchen und das flashen. Anschließend reinitialisieren und erneut das komplette Bios flashen, das du haben willst, genau nach Anweisung.
Das würd ich dann übrigens bei den eher alten Chips zweimal flashen. Kannst letzteres auch als Tick bezeichnen, erspart in seltenen Fällen aber Frust.
mfG
Rudolf
 

toele1410

New member
Themenstarter
geht leider auch nicht mit 2 mal flashen und der richtigen bios version. hab jetzt die 1.02 bios und ec 1.00 druf.

was eigenartig ist, ist das die akku led immer orange blinkt auch bei ultrabay akku. kennt jemand den chip auf dem board der für die ladeelektronik zuständig ist? wenn es einen gibt.

wenn nicht muss ich damit halt leben.

nocht ne frage, wenn ich was ins ultrabay reinstecke / rausziehe das denn das book mehrmals piep? hört nach ca 10 sekunden wieder auf?
 

Robbyrobot

New member
habe hier ein problem mit einem t20 hatte erst ein bad crc 175 problem. dann habe ich ein neues dump file eingespielt und das problem wa weg.
Bist Du ganz sicher, daß Du ein T20 Dump in das EEPROM geschrieben hast, nicht etwa eins für den T21 oder T22? Das scheint mir der einzige kritische Punkt hier, denn ansonsten verstehe ich auch nicht, warum die BIOS-Update nicht korrekt vonstatten ging.
 

rudolfka

New member
hallo,

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-4MNN8X

Auf dieser Seite mußt du eins der Biosse unten auf der Seite (du mußt fast ans Ende scrollen!) neben denen steht Embedded-Controller Version 1.00 runterladen. Ein anderes (neueres) wird niemals gehen, weil der embedded Controller dann falsch ist. Dieses alte! Bios mußt du zuerst flashen. Dann genau nach Anweisung mit F1 ins Bios, F9 drücken um alles auf default zu setzen und mit F10 speichern. Notfalls mußt du alle zu dieser Conmtrollerversion passenden alten ! Biosse ausprobieren, bis es geht! Erst dann, wenn die Versionen wieder stimmen, wird ein flashen auf neuere funktionieren! Es sind eine Reihe alte Biosse mit der Controller-Version 1.00 zusammen gelistet. Nur das zu deiner Subversion passende wird letztlich gehen.
Nocheinmal emphehle ich das vorletzte Bios, es ist das am wenigstren zickige im Endeffekt. Dieses aber erst flashen, wenn der Kontakt zwischen Bios und Controller-Bios wieder stimmt. Das mit dem doppelt flashen darfst du dir sparen. Das würd iuch ganz zum Schluß machen, wenn schon alles geht, damit nicht irgendson altersschwaches einames Bit mal umkippt.
mfG
Rudolf
p.S.: hab gesehen, du hast das älteste gelistete Bios schon probiert. Probier mal, den Akku zwischendrin, nach dem flaschen, auszubauen, dann ausschalten und im Netzbetrieb mit F1 ins Bios zu starten, dann reinitialisieren und dann das erste Bios mit embedded-Controller-Bios das eine um 0,01 höhere Nummer hat. Notiere mal die 'Ergebnisse die im Bios angezeigt werden für beide Teilbiosse. Wenn alles nichts hilft, wirst du sonst am Ende nochmal direkt flashen müssen, mit allen Risiken. Und woher das Dumpfile bekommen

2.p.S: Es müssen Bootdisketten ohne jeden V irtual-mode-Treiber sein, also ohne! himem.sys und son Zeug, möglichst auch keine Tastaturtreiber, nur die Systemfiles und Command.com, sowie der I_nhalt des jeweiligen flasharchives. Wenn irgendwelche Fehlermeldungen oder überhaupt keine Meldungen angezeigt werden, ist das wichtig, postze das bitte. Kann doch gar nicht sein, das das überhaupt nicht geht. Das Blinken kann natürlich ganz evtl davon kommen, das der Akku bereits Fehlerflags gesetzt hat. Darum im Bios kontrollieren, ob sich da was geändsert hat!
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben