Scharniere der A-Serie wieder leichtgängig machen?

schmatzler

Active member
Registriert
17 Dez. 2008
Beiträge
1.169
Hallo Leute,

ich besitze schon längere Zeit ein A20p mit SXGA+-Display, auf dem es sich dank ATI Rage, 1GHz-Pentium und Windows 98SE wunderbar zocken lässt. Ich möchte es nicht mehr missen. :love:

Allerdings hat es wie wohl alle Geräte der A-Serie auch das leidige Problem mit den immer steifer werdenden Scharnieren. Das Basecover ist bereits leicht angerissen - ich möchte dieses anhand von Mornsgrans' Anleitung mit Epoxy und Aluminiumblech reparieren. Das bringt mir aber nichts, solange ich die Scharniere nicht wieder leichtgängig machen kann und das Plastik dadurch wieder ausbricht.

Lassen sich die A-Serie-Scharniere überhaupt zerlegen? Wenn ich mir meine so ansehe, scheinen die doppelt vernietet zu sein. Ich sehe keine Möglichkeit, die Teile auseinanderzunehmen und neu zu ölen:

IMG_20170105_165443.jpgIMG_20170105_165459.jpg

Ich möchte die Lebenszeit des alten Biestes gerne noch ein wenig verlängern und wäre für Tipps sehr dankbar. :)
 

Mornsgrans

Help-Desk
Teammitglied
Registriert
20 Apr. 2007
Beiträge
69.000
Schon versucht, unter Bewegen des Scharniers die beiden Scharnierteile voneinander abzuziehen?

Leider habe ich keine A2x-Teile mehr, mit denen ich es hätte versuchen können - alles vor drei Jahren wegen Unzugs entsorgt.
 

schmatzler

Active member
Themenstarter
Registriert
17 Dez. 2008
Beiträge
1.169
Das klappt tatsächlich! Unter größter Anstrengung, habe fast die Scharnierarme verbogen. :p

Ich werde mal morgen die Teile mit einem feuchten Tuch durchziehen und dann neu ölen. Mal schauen ob es etwas bringt. Wenn ja, kann ich die alte Kiste wieder runderneuern.
 

oliveron

Active member
Registriert
18 Jan. 2011
Beiträge
1.844
Ich hoffe das ist jetzt nicht OT, aber was lässt sich mit der Ati RAGE unter Win98SE noch so zocken ?
Welche Klassiker (außer AOE II) laufen denn da ?
 

schmatzler

Active member
Themenstarter
Registriert
17 Dez. 2008
Beiträge
1.169
So ziemlich alle DOS-Games laufen darauf (bin besonders interessiert an Project Paradise, da das mit DOSBox mehr schlecht als recht läuft), The Wheel of Time, einige ATI Rage-exklusive Spiele, POD 2.0, Blood II...

Das A20p unterstützt Audio auch im richtigen DOS-Modus und nicht nur unter Windows, da es für den eingebauten CS4610-Soundchip einen richtigen DOS-Treiber mit Soundblaster-Unterstützung gibt. Außerdem habe ich die fixe Idee, eine IBM Dock II anzuschließen und dann mit einer Soundblaster-Karte meinen Sidewinder Force Feedback Pro-Joystick anzusteuern. Wenn das klappt, läuft dann auch I-War 2 darauf. Die beste Weltraumsim aller Zeiten (imho).

Das A20p ist eine tolle Maschine für alte Spiele und dank des S-Video-Ausgangs lassen sich die Games auch ganz gut mit einem Videograbber aufzeichnen. Schafft natürlich kein Crysis, aber darum geht es mir auch gar nicht.
 

schmatzler

Active member
Themenstarter
Registriert
17 Dez. 2008
Beiträge
1.169
Ich habe das Gerät mittlerweile runderneuert und wieder fitgemacht - inklusive Win98SE- und XP-Dualboot. Das war eine Höllenqual, deshalb schreibe ich meinen Prozess einfach mal hier auf.

Ich habe zuerst versucht, die Scharniere vom alten, eingetrockneten Schmierfett mit Isopropyl und einem feuchten Lappen zu reinigen was ich über den Zapfen drübergezogen habe - danach noch mit 1-2 Tropfen Feinmechaniköl versetzt.

Das brachte leider überhaupt keine Verbesserung. Sie ließen sich immer noch nicht mit der Hand bewegen und waren weiterhin sehr schwergängig.


Letztendlich blieb mir nur die radikale Option, meinen kleinen Hobbydrill mit den Schleifaufsätzen auszupacken und vom Zapfen mehrfach rundum ein wenig Material abzutragen. Dies musste ich insgesamt 3mal machen, bis ich mit dem Ergebnis zufrieden war und die Scharniere mit der Hand bewegen konnte:

https://hirnschwund.net/forum/img/members/2/IMG_20170107_193932.jpg

Danach machte ich mich an die Reparatur des Gehäuses. Zunächst habe ich eine der Muttern (nennt man die so?) mit Hilfe von Epoxy wieder im Gehäuse befestigt:
https://hirnschwund.net/forum/img/members/2/IMG_20170107_201332.jpg
https://hirnschwund.net/forum/img/members/2/IMG_20170107_201801.jpg
https://hirnschwund.net/forum/img/members/2/IMG_20170107_202013.jpg
https://hirnschwund.net/forum/img/members/2/IMG_20170107_202919.jpg

Das hat ganz gut geklappt, denn an ihrem ursprünglichen Platz war zum Glück noch so viel Material vorhanden, dass sie sich von alleine wieder hineinpressen ließ. Danach schnitt und bog ich mir ein kleines 0.8mm-Metallplättchen zurecht und platzierte es über der ausgebrochenen Stelle:

https://hirnschwund.net/forum/img/members/2/IMG_20170107_201604.jpg

Dieses Plättchen habe ich am nächsten Tag noch mit 3 Bohrlöchern versehen, mit Schleifpapier angeraut und sowohl auf der Unter- als auch auf der Rückseite mit Epoxy verklebt. Nach einem Tag Aushärtung wurde das Gerät wieder zusammengebaut...und es hält! Bombenfest! Wie im Wiki beschrieben, kann man die Schraube für die eingepresste Mutter nun sogar kaputtdrehen, wenn man will. Es gibt auch keine hässlichen Knack- und Knirschgeräusche mehr beim Öffnen des Deckels. :love:

Allerdings muss ich sagen, dass der Zahn der Zeit doch stark am Material nagt. Das Plastik erscheint mir allgemein sehr brüchig - so kam mir ein Teil des Displayrahmens bereits entgegen, der an einer Stelle fast von alleine auseinanderfiel. Das wird mit der Zeit sicher nicht angenehmer für die alten Schätze :(

---

Auf der Betriebssystemseite wollte ich einen XP- und Win 98SE-Dualboot hinbekommen und zwar so, dass beide Systeme sich auf Laufwerk C: installieren. Das Ganze hinzubekommen ist eine Tortur, aber letztendlich so möglich:

1. Zuerst wird Windows 98SE installiert. Im Gerät steckt eine 100GB-Platte, aber mehr als 30GB mag das System nicht wirklich, also erstelle ich mit Hiren's Boot CD und dem darauf befindlichen Partition Wizard erstmal eine 25GB-FAT32-Partition (primär). Damit Scandisk später nicht rumjammert, sollte diese unbedingt mit "Align" noch auf die richtige Größe gebracht werden - außerdem natürlich aktiv geschaltet sein.

98SE kann nun entspannt von CD installiert werden. Treiber dafür gibt es hier.
Dafür beachtet werden muss:
  • Der Intel Pro/100-Treiber verzögert den Systemstart erheblich, daher habe ich ihn weggelassen.
  • Das Booten von Windows in den DOS-Modus läuft nur bis BIOS-Version 1.09. Danach hat IBM irgendwas kaputtgemacht, sodass der Bildschirm im Vollbildmodus schwarz bleibt, sobald der ATI Rage-Treiber installiert wurde. Direkt booten in DOS funktioniert. BIOS 1.09 habe ich auf dem Lenovo-Server nicht mehr gefunden, aber es ist in der Datei spsuiv67.exe, die ist leicht über Google aufzufinden. Der Downgrade funktioniert nur mit Windows XP oder unter 98 mit externem Bildschirm (weil man sonst nichts sieht).
  • Weiterhin zu empfehlen für den angenehmen Betrieb sind ein PCMCIA-USB-Adapter, NUSB und das inoffizielle Service Pack für Windows 98SE.

2. Die Installation von Windows XP ist danach möglich. Hier griff ich gleich zu der Version mit dem integrierten inoffiziellen Service Pack 4 und PosReady-Update-Fähigkeit, damit ich noch eine Weile mit Sicherheitspatches versorgt werden kann. Service Pack 4 inklusive MUI-Pack zum Umschalten auf Deutsch ist hier zu finden. Man braucht natürlich eine XP-CD und -Lizenz, um seine eigene ISO erstellen zu können. ;)

Damit XP sich nicht auf Laufwerk D: installiert, muss vor der Installation auch hier wieder Hiren's Boot CD gestartet und eine NTFS-Partition als zweite primäre Partition erstellt werden. Diese muss aktiv sein.

Ich habe es jedoch leider nicht geschafft, Windows XP SP4 direkt auf dem A20p zu installieren. Es blieb immer reproduzierbar bei 23min im Setup hängen. Ein Workaround, der bei mir funktioniert hat, war die Installation auf einem alten T21 und das Rücktransferieren der Platte ins A20p. Eine Treibersuche ist nicht notwendig, da alle Treiber bereits vom System gefunden werden. :cool:

Um den Dualboot hinzubekommen, habe ich letztendlich noch Boot-US installiert.
DOS-Spiele laufen nun wunderbar:
IMG_20170109_213044.jpgvlcsnap-0254-06-26-06h21m25s963.jpg
 
Zuletzt bearbeitet:

Mornsgrans

Help-Desk
Teammitglied
Registriert
20 Apr. 2007
Beiträge
69.000
Das wäre einen Eintrag im Wiki wert - z.B. unter "Erfahrungsberichte" auf der A20 - Seite
 

schmatzler

Active member
Themenstarter
Registriert
17 Dez. 2008
Beiträge
1.169
"Die Tage" war jetzt einige Jahre später, aber immerhin. Ich habe mein Retro Dualboot-Setup im WIKI ergänzt, mit FreeDOS ist das auch deutlich einfacher umzusetzen als ursprünglich beschrieben.

Außerdem habe ich dort auch den BIOS-Bug in Verbindung mit dem schwarzen Bildschirm unter DOS ergänzt. Der hatte mich einige Nerven gekostet.
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben