Leo4all oder Kalyway auf T43?

thork

New member
Hallo Community,

bin seit gestern stolzer Besitzer eines T43 mit x600 Ati und SXGA+ Display. Mein Desktop-PC ist ein Mac und da liegt natürlich der Wunsch nahe ein Tiger oder Leopard auf dem Thinkpad zu haben (Ihr werdet lachen: ich habe sogar von meinem mittlerweile in Polen befindlichen Macbook eine Leopard Lizenz ...). Habe es gestern mal mit Leo4all und Kalyway probiert und beide male kein Erfolg gehabt. Entweder hängt er sich während der Installation auf (welche Pakete muss ich da auswählen?) oder bleibt hinterher auf der Shell hängen mit unterschiedlichen Fehlermeldungen ...

Hat jemand auf einem ähnlichen T43 das Teil zum Laufen gebracht und ein paar Tipps oder gar ein HowTo?
 

matze-peng

New member
Wenn du die Fehlermeldungen nicht nennst ist es ein wenig schwierig zu sagen wo es hängt. Prinzipiell ließe es sich nämlich installieren. Die Treiberunterstützung für dieses x600 ist bei Leopard aber nicht der Hammer. Da kannst du froh sein, wenn du wenigstens eine vernünftige Auflösung hinbekommst.
 

karlitos

New member
sse2 & sse3 Unterstützung

Hallo
Ich habe auf meinem T42 Leo4All versucht zu instalieren und ich komme gar nicht mehr in das Instalationsprogramm hinei. Der Thinkpad startet sich andauern neu.
Ich habe nachher bischen gegooglet und habe gefunden, dass die Pentium-M Prozessoren kein sse3 Befehl unterstützen. Dann kann es auch nicht gehen mit OsX,
 

thork

New member
Themenstarter
Fehlermledung bringe ich heute abend mal ein paar. War einiges dabei (immer unterschiedlich) u.a. "Waiting for Root-Device". Leo wäre nur interessant wenn ich mit 1400x1050 laufen kann. Ist die Unterstützung bei Tiger denn besser? Dann würde ich nämlich ggf. einfach ein Tiger draufziehen ... Lt. Beschreibung der 9.2 Kernel auf der DVD scheint auch SSE2 unterstützt zu werden und dass sollte der Centrino eigentlich können.
 

ingope

Moderator im Ruhestand
RE: sse2 & sse3 Unterstützung

Original von karlitos
dass die Pentium-M Prozessoren kein sse3 Befehl unterstützen. Dann kann es auch nicht gehen mit OsX,

SSE2 reicht für OSX, es muss kein SSE3 sein

Sobald ich meinen Bekannten erreiche (zur Zeit in New York bis ende nächster Woche) werde ich ihn fragen ob er hier bitte ein "How to" posten kann.
Er hatt OSX auf dem T43(p) (weiß jetzt nicht 100%ig ob er ein T43 oder ein P hat) und inzwischen hat er das Leo gezeugs drauf.

Und ja, bei Tiger ist die Unterstüzung viel besser für die etwas älteren ATIs.
 

matze-peng

New member
Original von thork
Fehlermledung bringe ich heute abend mal ein paar. War einiges dabei (immer unterschiedlich) u.a. "Waiting for Root-Device".

Du musst bei der Installation auf "customize" (bzw "anpassen") gehen und die richtigen Treiber auswählen. Beispielsweise muß beim T43 das ICHxx Modul ausgewählt werden, damit auf die Festplatte zugegriffen werden kann.

edit: Ach und für Leo4all reicht definitiv SSE2 (kA wie das bei Kalyway aussieht). Ich habs auf meinem T43 auch problemlos installiert.
Die Auflösung müsste mit Callisto machbar sein, QE+CI allerdings werden wohl nicht unterstützt.
 

thork

New member
Themenstarter
Genau das ist ja meine Frage bei Anpassen, welche Module muss ich auwählen? Das mit dem ICHxx würde ja schon mal das "waiting for root device" erklären ... Aber bekomme ich auch die volle Auflösung hin?

Okay und jetzt *Noob an*:

was ist callisto und was ist qe+ci?

Für mich ist nur wichtig ob Aperture, iPhoto und iWorks laufen ... ;) Und Wlan ...
 

matze-peng

New member
Callisto sind irgendwelche ATI-Treiber. Wie man die installiert sieher hier.

QE = Quartz Extreme
CI = Core Image

Ob Aperture und iPhoto funktionieren kann ich nicht sagen. Ich habe beides nicht. iWorks habe ich zwar, aber nicht installiert. MS Office funktioniert tadellos.

Beim WLAN kommt es darauf an, was für ein Mini PCI Adapter drin steckt. Die Intel-Karten funktionieren nur mit WEP. Atheros und Broadcom (BIOS-Hack notwendig wenn keine FRU) funktionieren komplett und werden als Airport erkannt.
 

Drummaster

New member
Ich hole das Thema mal aus der Versenkung, da ich am Wochenende versucht habe Leo4all auf meinem T42 (Version 3) zu installieren. Ich kann auch installieren, allerdings startet dann das System nach einem reboot nicht. Hat es jemand erfolgreich zum laufen bekommen und kann mir verraten wie?
 

ConeBone

New member
Ich weiß jetzt nicht, wie Leo4all aufgebaut ist bei der Install.

kalyway jedoch hat aufm T42p funktioniert.. Ohne jeglichen Vanilla Kernel oder wie die noch heißen.
SSE2 Patch auf jeden Fall mitinstallieren (war auch bei der kalyway install bei).

Sonst gabs eigentlich nichts glaub ich..

Und bei GUID und MBR musste mal schauen, wie deine Festplatte aufgeteilt ist..
Entweder bei einer einzigen Partition musste man MBR nehmen, wenn man mehr hatte, dann GUID... oder andersrum. weiß es nicht mehr soo genau.


Aber im Prinzip hat es so geklappt.. Aber war auch nicht lang aufm Thinkpad drauf, wegen der miesen FireGL T2 Unterstützung (ist unter Tiger besser).
Oder weiß da jemand, wie man das zum Laufen kriegt (am besten mit QE/CI)?


Uh.. Edith meint, der Thread wär schon recht alt. :S
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben