Fuktioniert bei euch unter Ubuntu der brightness-up Button richtig?

grimsrud

New member
Hi,

tja... Frage steht ja schon oben.
Ich habe folgendes bei meinem X31 unter Ubuntu 8.04 festgestellt: wenn ich mit FN+Ende die Helligkeit runterregle, dann bekomme ich das normal über den Monitor angezeigt (also per OSD). Wenn ich jetzt aber die Helligkeit mit FN+Pos1 wieder höher machen will, wird die Helligkeit zwar eröht, aber es erscheint nicht die Benarichtigung per OSD.
Das wäre jetzt ja nicht weiter schlimm, wenn das nicht einen nervigen Feler produzieren würde: wenn ich nämlich in der Energieverwaltung "Bildschirm bei Leerlauf abdunkeln" aktiviere, dann dunkelt der das Display auch ewas ab. Soweit so gut. Wenn ich dann aber wieder was am Thinkpad mache, wird die Helligkeit wieder hoch gestellt... aber eben nicht auf die gleiche Helligkeit wie zuvor, sondern eine Stufe darunter, was letztlich zurfolge hat, dass sich das Display beim nächsten Leerlauf wieder runterdimt (ausgehend von jetzt ja generell etwas weniger starken Helligkeit)... Das endet dann irgendwann darin, dass das Display komplett auf dunkelster Stufe läuft.
Vielleicht mal etwas verbildlicht:
1. Aktivität: 100% Helligkeit
1. Leerlauf: 80% Helligkeit
2. Aktivität: 90% Helligkeit
2. Leerlauf: 70% Helligkeit
...
So... dann habe ich mal bei launchpad.net vorbeigeschaut und in diesem Bugreport gesehen, dass das wohl damit zusammenhängt, dass FN+Pos1 kein ACPI-Event erzeugt.

Wie dem auch sei? Habt ihr unter Ubuntu 8.04 das gleiche Problem? Wenn ja, wäre es vielleicht ganz cool, wenn ihr euren Senf auch mal bei dem o.g. Bugreport dazugeben würdet :) Irgendwie scheint das dort ja niemanden so recht zu interessieren... zumindest gibt es keine Reaktion.

Munter. Grimsrud

Edit: Am einfachsten lässt sich das vermutlich dadurch herausfinden, indem ihr mal schaut, ob die Veränderung der Helligkeit über die Tastenkombinationen bei euch dazu führt, dass ihr per OSD angezeigt bekommt, dass ihr die Helligkeit verändert habt.
 
H

horsthorst

Guest
Hallo!

Ich habe das selbe Problem mit Ubuntu 8.04. Eine Lösung habe ich aber auch leider nicht....
 

morebeat

New member
Auch hier beim T43 dasselbe. Bei 7.10 Funktionierte es noch einwandfrei :(
Ich hoffe das Problem wird bald gefixt.
 

grimsrud

New member
Themenstarter
Hmmm... das sind ja schonmal ein paar, w es nicht geht. Um das vielleicht mal einzugrenzen: haben die, die das Problem haben eine Neuinstallation gemacht oder 8.04 über eine bestehende Installation drüber gebügelt? Vielleicht gibt es da j irgendwelche Konflikte?
Auf jeden Fall wäre es klasse, wenn sich die betroffenen mal bei dem Bugreport verewigen würden, damit die mal bisschen in Wallung kommen ;-)

Munter. Grimsrud
 
H

horsthorst

Guest
Problem besteht bei mir unter einer Ubuntu 8.04 Neuinstallation. Bestand aber auch schon bei der beta... ich trag mich mal im Bugreport ein. Vielleicht kommen die ja wirklich in die Hufe, wenn wir uns da alle eintragen?
 

bluefish

New member
versucht mal:

for kernels 2.6.22 and above fan control is enabled with the following in /etc/modprobe.conf:
options thinkpad_acpi fan_control=1

so hat es bei mir funktioniert.
 

sylence

New member
Jetzt mal spontan, ohne Ubuntu zu verwenden:
Wenn das Problem ist, dass der Hotkey kein ACPI-event erzeugt, thinkpad-acpi aber geladen ist,
könnte ein
Code:
echo enable,0xffff > /proc/acpi/ibm/hotkey
Abhilfe schaffen. Davor und danach mal mit
Code:
tail -f /var/log/acpid
überprüfen, ob Events mit dem Tastendruck erzeugt werden.
 

grimsrud

New member
Themenstarter
@ Sylence
Also wenn ich deinen Tip befolge, dann dreht sich das ganze um. Jetzt bringt die andere Taste kein Acpi-Event mehr. Dafür die, die vorher nicht ging... Hä?

Nun denn. Erstmal danke für deinen Tip. Wäre toll, wenn du es jetzt noch schaffen würdest, beide Tasten davon zu überzeugen, ein Acpi-Event auszulösen :) Also ich meine das ganz im Ernst. Ich habe keine Ahnung, wofür 0ffff steht, aber wenn du es weißt... vielleicht bekommen wir das dann ja noch auf die Reihe :)

Munter bleiben. Grimsrud
 

grimsrud

New member
Themenstarter
Ich habe es!!! Hahahahahaha... ich bin so geil!

Ich konnte mich daran erinenrn, dass es mal ein Problem mit thinkpad_acpi gab, bei dem man in eine bestimmte Datei, deren Name ich gerade nicht mehr weiß (nachher mal nachgucken) anstatt 0ffff 0ffffff eingeben musste.
Werde gleich mal nachsehen, ob ich die Datei noch finde. Bis gleich

Grimsrud
 

sylence

New member
Ja, das ist im thinkwiki ganz nett beschrieben. Dann hänge an meinen obigen Aufruf einfach testweise noch ein paar "f" ran...
 

bluefish

New member
merkte gerade das mein tip falsch war.
dachte das ich den fehler so löste.

verzeiht die falschinfo!


glaube es war diese änderung?

/etc/modprobe.d/thinkpad_acpi.modprobe

options thinkpad_acpi experimental=1 hotkey=enable,0xffff8f bluetooth=enable
 

fhesse

New member
...also bei mir läuft ein X31 unter Kubuntu 8.04 und da klappt das mit der Helligkeitsveränderung problemlos.
Meine THINKPAD_ACPI sieht dabei wie folgt aus:

options thinkpad_acpi hotkey=enable,0xffff8f experimental=1 fan_control=1

Hoffe das hilft weiter....
 

glober

New member
Hallo,

ich habe das Problem mit dem ACPI Event auch auf die hier erwähnte Weise behoben. Allerdings habe ich weiterhin das Problem, was Craig Meli in dem Bugreport von oben bereits beschreibt:
Wenn ich den Stromstecker rausziehe, verdunkelt sich der Bildschirm normal, stecke ich ihn wieder rein, wird aber nicht die ursprüngliche (maximale) Helligkeit wieder eingestellt, sondern ein Level drunter. Wenn ich das nun paar mal hintereinander mache, bin ich auch beim Netzbetrieb bei Level 2 angelangt. Um genau zu sein verkleinert sich der Wert beim Steckerrausziehen um 3, beim Reinstecken steigt das Level aber nur um 2 Stufen an. Irgendwo muss das doch drinstehen, bloss wo?

Gruß Rick
 

grimsrud

New member
Themenstarter
Also ich hatte nach längerem Testen dann auch wieder Probleme damit, weswegen ich den Mist wieder abgestellt habe. Jetzt regle ich wieder von Hand die Helligkeit. Schade auch, aber vielleicht läuft es dann ja mit 8.10 vernünftig? :)

Munter. Grimsrud
 

trouble

New member
unter debian besteht das problem auch.
mein workaround ist derzeit "echo enable,0xffffff > /proc/acpi/ibm/hotkey" in /etc/rc.local einzutragen. ab dann wird das osd korrekt angezeigt.

das zweite problem mit der helligkeit hab ich nicht, weil ich diese funktion nicht nutze. naja ich hab das problem ein wenig anders. wenn ich die helligkeit(mit ac) auf dunkel stelle und dann eine weile nicht am notebook arbeite regelt sich die helligkeit automatisch wieder aufs maximum. das find ich genauso nervig. gibts dafür eine brauchbare lösung?
 

Aiwaz

New member
Ich habe auch ein Problem mit der Helligkeit des Displays unter Ubuntu 8.04.
Wenn ich den Deckel zu- und wieder auf klappe ist die helligkeit immer wieder auf maximum :(
Auch wenn ich das Automatische dimmen im Leerlauf eingeschaltet habe stellt sich die helligkeit danach wieder auf maximum.
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben