FN+F5 für nicht IBM-FRU Karten nutzbar machen

twisted mind

New member
Edit: Falls jemand die Bilder braucht, findet er den Beitrag auch im Wiki! ;)

Moin,

ich habe (siehe Signatur) eine Atheros 5006XS ohne FRU in meinem T40p.

Ich schalte die Karte bei Nichtgebrauch gerne ab, um Strom (Akkuleistung) zu sparen.
BT habe ich auch verbaut also nutze ich auch FN+F5 (Software war also schon drauf).
Das habe ich bis jetzt immer über die Thinkpad-Konfiguration gemacht. Die vielen Klicks nerven am Ende ja dann doch... :sleeping:

Durch Zufall (eigentlich durchs Forentreffen in Kiel) habe ich bemerkt, das meine Karte im original IBM-Treiber in der "net5211.inf" im Driver Verzeichniss gelisted ist. Na denn... ;)

Alten Treiber gekickt, IBM drauf, Gerätemanager ansehen...alles gut, Karte wird richtig erkannt und ist betriebsbereit! WLAN funkt auch.

In den Eigenschaften der Atheros WLAN-Karte, unter Details findet man bei mir in der Pulldown-Auswahlliste den Unterpunkt "Kompatible Kennungen". An 2. Stelle steht der Wert "PCI\VEN_168C&DEV_001B".

Anhang anzeigen 6583

Hex Editor starten und TpFnF5.exe öffnen (findet ihr schon selber). Hier habe ich im "Klartext" nach einer ähnlichen Gerätekennung gesucht. Suchbegriff "VEN_168C&DEV_00" die letzten beiden Stellen habe ich einfach mal so weggelassen... ?(

Ich habe 2 Möglichkeiten gefunden, mich aber für die 2. entschieden. Die PCI Vendor ID habe ich dann angepasst und das ganze abgespeichert (vorher Sicherheitskopie der Datei anfertigen!). Kann man das auf den Bildern sehen?

Anhang anzeigen 6584

Anhang anzeigen 6585

Ergebniss? Positiv, Treffer versenkt! :thumbsup: Ich danke an dieser Stelle übrigens noch tom_k, der mich darauf gebracht hat das zu tun, was jemand anderes sich ausgedacht hat... ;) .

Anhang anzeigen 6586

Anhang anzeigen 6587

Das ganze ist also nicht von mir! Damit bekommt man aber sicher auch alle Intel Karten auf FN+F5 getrimmt.

Klaus
 
Zuletzt bearbeitet:

cyberjonny

Active member
Na wenn das nich mal cool ist! :)

Diese Lösung hätte mir vor nem viertel Jahr ne ganze Menge Zeit und Aufwand erspart... :rolleyes:
Werds bei Gelegenheit mal testen!

Gruß, Jonny
 

twisted mind

New member
Themenstarter
Moin,

@cyberjonny & Mornsgrans: Eine Schwalbe macht noch keinen Sommer... Aber danke für die Blumen. ;)

Ich dachte irgendwie, dass sich mehr Leute hier dafür interessieren würden...
Aber es gibt halt wichtigeres (mein TP quietscht hier, welcher Treiber wo, böse Bucht etc.).

Wäre trotzdem schön wenn das noch jemand anderes probiert und Erfolg/Misserfolg postet.

Und ich dachte, ich hätte mir einen Sticky verdient... ;(

Klaus
 

ingope

Moderator im Ruhestand
@ Klaus - das ist wirklich Super !

Und ich kann da auch gerne einen Sticks draus machen nur wenn wir jeden, wenn auch hier Super Tip!, zum
Sticky machen, fangen die echten Beiträge bald erst auf Seite 3 an :)

Ich finde sowas gehört ins Wiki, da wird es

A. viel besser gefunden
B. kommt er mehr der Allgemeinheit zu gute

Nur meine Meinung, was meinst du?

LG aus RD
Ingo

Edit:
Was ich durchaus gut Vorstellen kann ist, diese ganzen Sachen ins Wiki zu Schreiben und dann hier
irgendwo einen richtigen großen Thread mit Links zum Wiki zu setzen, das finde ich persönlich
viel Sinnvoller als jeden Thread zum Sticky zu machen.
 

verdi

New member
falls das burning board unterforen kann könnte man auch pro kategorie eine unterkategorie FAQs machen

so haben wir das auf gs-500.de gelöst ...

nur so als idee :)
 

twisted mind

New member
Themenstarter
Moin,

@all: Ich habe jetzt auch AC mit der nicht IBM-Atheros zum laufen gebracht... :D

Den Trick poste ich aber erst, wenn hier mal jemand postet ob FN-F5 auch bei ihm mit einer nicht IBM-FRU-Karte geht!

In diesem Sinne

Klaus
 

cunni

Erklär-Bär
Moin,

das ist ja einer hervorragende Idee (eigentlich so einleuchtend, dass jemand schon vorher darauf gekommen sein dürfte... aber so ist das mit den vermeintlich "einfachen Lösungen") :)

Ärgere dich nicht, dass du nicht mehr Feedback bekommst - ich glaube einfach, dass das neue Board noch etwas unübersichtlich ist (ich bin auch erst heute das erste Mal auf die Sache aufmerksam geworden). Weiterhin werden viele - aus Frust - auch mittlerweile eine Karte eingebaut haben, die kompatibel ist. Trotzdem sollten früher oder später einige Interessenten auftauchen... ;)

Ich würde gern beim Testen behilflich sein - aber in meinem T41 ist schon eine "freigeschaltete" Karte verbaut. Nach Ende der Garantiezeit (das dauert aber noch bis Herbst 2009 ;)) werde ich die Kiste mal öffnen und Bluetooth und eine Karte mit G-Standard einbauen.... Aber ich glaube kaum, dass du so lange warten willst und musst ;)

Grüße,
Cunni
 

msa

New member
hab's probiert, FnF5 geht jetzt, kann aber auch anderen Grund haben

Moin,

erstmal vielen Dank an Twisted Mind für die ausführlich Beschreibung und an seiner Vordenker, wäre ja ne gute Sache, wenn möglichst viele Karten praktisch bedienbar wären.

In meinem x31 ist eine Atheros-irgendwas eingebaut und bisher hat FnF5 bzw. AccessCon diese nicht als brauchbar erachtet. Die Karte manuell über die WinXP Netzwerkeinstellungen aktivieren/deaktivieren ging problemlos, Verbindung herstellen und beenden ebenfalls.

Ich habe dann mit Hilfe der Anleitung herumgebastelt und jetzt klappt es mit FnF5. Allerdings gab es dabei einige Unwägbarkeiten, so dass ich leider nicht sicher bestätigen kann, dass das beschriebene Verfahren bei einer weiteren (eigentlich nicht geeigneten) Wlan-Karte zum Erfolg geführt hat, oder ob meine vorherige Installation einfach murks war und jetzt erst so ist, wie sie sein sollte.

So bin ich vorgegangen: a) gemäß der Anleitung den IBM-Wlann-Treiber installiert (bzw. festgstellt, das ich die Dateien bereits im Verzeichnis "Driver" hatte; ich bin dann zunächst davon ausgegangen, dass dieser Treiber auch installiert ist) b) eine kompatible Kennung meiner Karte (dem GeräteManager entnommen) in die TpFnF5.exe reingeschrieben. Das hat erstmal keine Veränderung gebracht (auch nach Neustart) keine Veränderung gebracht.
Ich habe dann festgestellt, das laut TaskManager beim drücken der FnF5 nicht TpFnF5.exe sondern AcFn5.exe aktiv wird. Ein solche Datei findet sich auch bei mir im ProgrammeVerzeichnis (ja, ich müsste bei Gelegenheit XP mal neu installieren), allerdings findet sich mit dem HexEditor in dieser keine auch nur halbwegs zu Karten-Kennung passende Zeichenkette, so dass ich dort auch nichts verändert habe. Ich habe jedoch die Vermutung, dass die TpFnF5.exe gar nicht verwendet wird.
Ich habe dann nochmal denn IBM-Wlan-Treiber installiert, und jetzt geht's mit FnF5 (kann die Karte an und ausschalten, Lämpchen geht an und aus, kann verschiedenen Profile umschalten). Soweit ich noch erinnere, was vor der Treiber-Neuinstallation bei den Treiber-Infos im GeräteManager zur Wlan-Karte stand (Treiberanbieter: Atheros), hat sich dort nichts geändert. Ich kann aber leider aufgrund meines nicht vollständig dokumentierten Vorgehens nicht ausschliessen, dass ich unwissentlich eine FRU-Karte (keine Ahnung wie ich das rauskriege) habe und jetzt erstmalig den passenden IBM-Treiber installiert habe (im GeräteMan steht allerdings immer noch Treiberanbieter: Atheros).

Kurzum: bei mir funktioniert es jetzt, dank an alle dafür, aber leider ist der allgemeine Erkenntnisgewinn aus meinem speziellen Vorgehen eher mäßig. Wenn ich mehr Zeit habe (ab Mitte Juli) steht sowieso eine Neuinstallation an, dann kann ich es nochmal überprüfen (habe auch noch ein zweites x31 mit einer Broadcom-Karte, die nur mit no1802-Patch läuft, also sicher keine FRU-Karte ist, habe nur zur Zeit kein Zugriff auf dieses zweite Notebook). Ich werde berichten.
 

Cortex

New member
Moin,

habe mal versucht das ins Wiki einzubasteln!
Komme aber irgendwie nicht richtig klar... Warun sind die Bilder jetzt plötzlich so groß? 8|
Kann mir da mal bitte jemand helfen? Wie geht das im Wiki mit internen Links?

<Link >

Grüße Klaus
 

Andal

New member
Hallo zusammen,

Die Anleitung von Twisted Mind finde ich sehr gut und vor allem leicht verständlich. Genau das Richtige für einen Einsteiger wie mich :thumbsup:.
Leider hatte ich mit meiner IntelProWireless2200bg kein Glück. Ich hab die Karte eingebaut, Treiber von Lenovo gezogen und installiert. W-LAN funktioniert.
Jedoch steht unter Eingenschaften der W-LAN Karte -> Details -> Kompatible Kennungen ganz was anderes. Auch beim öffnen der FN+F5.exe mit dem HEX-Editor habe ich nicht ansatzweise etwas gefunden was dem ähnelt was unter Kompatible Kennungen bei der Atheroskarte von Twisted Mind steht. Vielleicht liegt es auch daran das ich nicht wirklich eine Ahnung von Hex habe :whistling: aber ich denke mal, wenn das mit Atheroskarten funktioniert sollte es auch mit anderen Karten gehen. Nur ist halt die Frage wo geschraubt werden muss.
Ich wär sehr dankbar wenn jemand ein paar Tipps oder Anregungen hätte was man wo noch machen kann um auch eine Intel Karte mit FN+F5 an und auszuschalten.
 

Anhänge

  • Kompatible Kennung.jpg
    Kompatible Kennung.jpg
    31,6 KB · Aufrufe: 55

Cortex

New member
Moin,

geht wohl doch nur bei Atheros... ;(

Aber die Intel Karten kann man unter Linux so umflashen, dass sie glauben, sie sind IBM-gebrandet.
Leider bin ich ein Linux Honk... ;) Vielleicht hilft mir ja moronoxyd oder schrank21 auf dem nächsten Treffen in Berlin?

Habe seit gestern eine Intel 2200BG im X31!

Klaus
 

tcone

OS X Experte
[quote='Cortex',index.php?page=Thread&postID=417982#post417982]da sucht auch noch jemand etwas ....[/quote]
da:

EDIT: gilt nur für die Intel PRO/Wireless 2200BG

Hardwarekennungen:
PCI\VEN_8086&DEV_4220&SUBSYS_27128086&REV_05
PCI\VEN_8086&DEV_4220&SUBSYS_27128086
PCI\VEN_8086&DEV_4220&CC_028000
PCI\VEN_8086&DEV_4220&CC_0280

Kompatible Kennungen:
PCI\VEN_8086&DEV_4220&REV_05
PCI\VEN_8086&DEV_4220
PCI\VEN_8086&CC_028000
PCI\VEN_8086&CC_0280
PCI\VEN_8086
PCI\CC_028000
PCI\CC_0280

Passende Gerätekennung:
pci\ven_8086&dev_4220&subsys_27128086


Viel Spass beim Patchen :)
(Keine Sorge, die Werte sind per Copy&Paste übernommen)

Gruß, Freddy
 

Cortex

New member
Moin,

@tcone: THX! :thumbsup:

ich bin heute leider "auf" 14 Stunden Arbeitstag... ;(

Link

Wer zerpatcht seine Karte zuerst? :D

Klaus
 

Andal

New member
Salve,

@tcone: Danke für Deinen Post. Ich weiss noch nicht genau was ich damit anfangen soll, bzw wo ich wass patchen muss. Ich hab mal in die TpFnF5.exe mit dem Hexeditor reingeschaut aber nichts von alle dem finden können. Muss man da an anderer Stelle was machen? Oder ist es jetzt einfach schon zu spät? 8| Danke Dir trotzdem.

@Cortex: Ich lasse einem Fachmann gerne den fortitt ^^ .

Ich wede es mir aber gerne noch mal genauer anschauen, wenn ich etwas geschlafen hab.
Dank an euch alle

Gruß, Andal
 

tcone

OS X Experte
@Andal: Du kannst Die Subsystem ID auf einer 2200BG-Karte unter Linux ändern/flashen, so dass sie als original IBM erkannt wird. Kein 1802-Patch nötig, keine anderen Hacks, die Karte läuft dann einfach.
Nur die LED macht wohl noch Probleme, weil die IBM-Karte eine andere Pinbelegung oder sogar ein anderes Platinenlayout hat.
 
  • thinkstore24.de
  • Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen
Oben