luxnote lapstore servion thinkspot
Seite 111 von 111 ErsteErste ... 1161101109110111
Ergebnis 2.201 bis 2.216 von 2216

Thema: Projektvorstellung: TLP – Linux Stromsparen

  1. #2201

    Registriert seit
    05.06.2012
    Beiträge
    606
    Danke
    70
    Thanked 139 Times in 97 Posts
    Hey,
    ich habe gerade mal etwas mit tlp herumgespielt.

    Da kam mir eine Idee auf, wäre es möglich bei der Temperaturausgabe von "tlp-stat -t" die Festplatte und eventuell den Akku miteinzubeziehen?
    Die Ausgabe ist momentan mit der CPU Temp und der Lüftereschwindigkeit so übersichtlich, dass da ein paar Zeilen mehr, dieser Übersichtlichkeit meiner Meinung nach nicht stören würden.

    Und noch eine Frage, gibt es einen besonderen Grund, warum nun für "tlp-stat" der Bindestrich eingefügt würde?
    Momentan nervt es mich persönlich noch stark diesen immer zu tippen, da ich daran noch nicht gewöhnt bin, persönlich würde ich es bevorzugen, den Bindestrich wegfallen zu lassen....

  2. #2202
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    12.507
    Danke
    15
    Thanked 316 Times in 251 Posts
    Themenstarter
    Zitat Zitat von Megalodon Beitrag anzeigen
    wäre es möglich bei der Temperaturausgabe von "tlp-stat -t" die Festplatte und eventuell den Akku miteinzubeziehen?
    Seit der Generation T410/X201 gibt es keine Sensoren für Akkus, GPU usw. mehr, nur noch CPU. Für HDD und SSD werden vorhandene Sensoren je "Disk" bei den "SMART infos" angezeigt.

    Zitat Zitat von Megalodon Beitrag anzeigen
    Und noch eine Frage, gibt es einen besonderen Grund, warum nun für "tlp-stat" der Bindestrich eingefügt würde?
    Das Kommando – ein separates Programm – ist schon immer "tlp-stat". "tlp stat" war ein Alias (sprich: Redundanz) im Programm "tlp", der bei der Umstellung der Verarbeitung der Kommando-Parameter mit TLP 1.2 entfallen ist. Du wirst dich einfach umstellen müssen, ich finde das ist kein Grund "genervt" zu sein.
    Geändert von linrunner (29.05.2019 um 20:04 Uhr)
    Gruß, linrunner
    X1C6, T450s, X220 - Ubuntu 18.04 - TLP - Ubuntu Schnelleinstieg
    -- Fehler im Anwender sind schwer zu beheben, da es meist keine Updates gibt


  3. #2203

    Registriert seit
    11.08.2011
    Beiträge
    44
    Danke
    3
    Thanked 2 Times in 2 Posts
    Zitat Zitat von Megalodon Beitrag anzeigen
    Und noch eine Frage, gibt es einen besonderen Grund, warum nun für "tlp-stat" der Bindestrich eingefügt würde?
    Momentan nervt es mich persönlich noch stark diesen immer zu tippen, da ich daran noch nicht gewöhnt bin, persönlich würde ich es bevorzugen, den Bindestrich wegfallen zu lassen....
    Leg doch einfach ein alias oder symlink an.

  4. #2204

    Registriert seit
    18.03.2009
    Beiträge
    1.929
    Danke
    54
    Thanked 117 Times in 113 Posts
    Hallo, wie installiere ich auf dem x390 unter Debian Buster etwas neueres als TLP 1.1 ?!?

    Ist für den kommenden Testbericht. Mit 1.1 lässt sich keine Akkuladeschwelle setzen und die Anleitungen mit den Backports sind alle ? für ältere Debianversionen, bin aber auch kein Profi.

    Danke !
    T490s Debian (Buster) https://www.debian.org/

  5. #2205
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    12.507
    Danke
    15
    Thanked 316 Times in 251 Posts
    Themenstarter
    @mcb: statt vorläufiger Schlussfolgerungen lese ich hier viel lieber Ausgaben:
    Code:
    sudo tlp-stat -s -c -b
    TLP 1.1 + acpi-call-dkms + Buster (mit Kernel 4.19) müssten das sehr wohl können.

    Aber installiere ruhig erstmal die 1.2.2 aus den Backports und zeige dann die Ausgaben.

    Die englische Installationsseite ist aktuell was die Backports angeht.

    Bin noch nicht dazu gekommen das Wiki nachzuziehen. Hättest Du Lust das zu übernehmen?
    Gruß, linrunner
    X1C6, T450s, X220 - Ubuntu 18.04 - TLP - Ubuntu Schnelleinstieg
    -- Fehler im Anwender sind schwer zu beheben, da es meist keine Updates gibt


  6. #2206

    Registriert seit
    18.03.2009
    Beiträge
    1.929
    Danke
    54
    Thanked 117 Times in 113 Posts
    Zitat Zitat von linrunner Beitrag anzeigen
    @mcb: statt vorläufiger Schlussfolgerungen lese ich hier viel lieber Ausgaben:
    Code:
    sudo tlp-stat -s -c -b
    TLP 1.1 + acpi-call-dkms + Buster (mit Kernel 4.19) müssten das sehr wohl können.

    Aber installiere ruhig erstmal die 1.2.2 aus den Backports und zeige dann die Ausgaben.

    Die englische Installationsseite ist aktuell was die Backports angeht.

    Bin noch nicht dazu gekommen das Wiki nachzuziehen. Hättest Du Lust das zu übernehmen?
    Danke!

    Ich probiere morgen nochmal kurz 1.1 -> aber dort geht es bisher nicht -> poste dann auch die stat-Ausgaben.

    Danke mit den Backports.

    Welches Wiki muß aktualisiert werden?

    Melde mich dann morgen.

    Gruß
    T490s Debian (Buster) https://www.debian.org/

  7. #2207
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    12.507
    Danke
    15
    Thanked 316 Times in 251 Posts
    Themenstarter
    Zitat Zitat von mcb Beitrag anzeigen
    Welches Wiki muss aktualisiert werden?
    Jetzt keins mehr .

    Ich meinte die offizielle Anleitung in deutsch.
    Gruß, linrunner
    X1C6, T450s, X220 - Ubuntu 18.04 - TLP - Ubuntu Schnelleinstieg
    -- Fehler im Anwender sind schwer zu beheben, da es meist keine Updates gibt


  8. #2208

    Registriert seit
    18.03.2009
    Beiträge
    1.929
    Danke
    54
    Thanked 117 Times in 113 Posts
    Hier die gewünschte Ausgabe (sieht alles gut aus):

    Code:
    --- TLP 1.1 --------------------------------------------
    
    +++ Configured Settings: /etc/default/tlp
    TLP_ENABLE=1
    TLP_DEFAULT_MODE=AC
    TLP_PERSISTENT_DEFAULT=0
    DISK_IDLE_SECS_ON_AC=0
    DISK_IDLE_SECS_ON_BAT=2
    MAX_LOST_WORK_SECS_ON_AC=15
    MAX_LOST_WORK_SECS_ON_BAT=60
    CPU_HWP_ON_AC=balance_performance
    CPU_HWP_ON_BAT=balance_power
    SCHED_POWERSAVE_ON_AC=0
    SCHED_POWERSAVE_ON_BAT=1
    NMI_WATCHDOG=0
    ENERGY_PERF_POLICY_ON_AC=performance
    ENERGY_PERF_POLICY_ON_BAT=power
    DISK_DEVICES="sda sdb"
    DISK_APM_LEVEL_ON_AC="254 254"
    DISK_APM_LEVEL_ON_BAT="128 128"
    SATA_LINKPWR_ON_AC="med_power_with_dipm max_performance"
    SATA_LINKPWR_ON_BAT="med_power_with_dipm min_power"
    AHCI_RUNTIME_PM_TIMEOUT=15
    PCIE_ASPM_ON_AC=performance
    PCIE_ASPM_ON_BAT=powersave
    RADEON_POWER_PROFILE_ON_AC=high
    RADEON_POWER_PROFILE_ON_BAT=low
    RADEON_DPM_STATE_ON_AC=performance
    RADEON_DPM_STATE_ON_BAT=battery
    RADEON_DPM_PERF_LEVEL_ON_AC=auto
    RADEON_DPM_PERF_LEVEL_ON_BAT=auto
    WIFI_PWR_ON_AC=off
    WIFI_PWR_ON_BAT=on
    WOL_DISABLE=Y
    SOUND_POWER_SAVE_ON_AC=0
    SOUND_POWER_SAVE_ON_BAT=0
    SOUND_POWER_SAVE_CONTROLLER=Y
    BAY_POWEROFF_ON_AC=0
    BAY_POWEROFF_ON_BAT=0
    BAY_DEVICE="sr0"
    RUNTIME_PM_ON_AC=on
    RUNTIME_PM_ON_BAT=auto
    USB_AUTOSUSPEND=1
    USB_BLACKLIST_BTUSB=0
    USB_BLACKLIST_PHONE=0
    USB_BLACKLIST_PRINTER=1
    USB_BLACKLIST_WWAN=1
    RESTORE_DEVICE_STATE_ON_STARTUP=0
    START_CHARGE_THRESH_BAT0=60
    RESTORE_THRESHOLDS_ON_BAT=1
    
    +++ System Info
    System         = LENOVO ThinkPad X390 20Q1S02M00
    BIOS           = N2JET73W (1.51 )
    Release        = Debian GNU/Linux 10 (buster)
    Kernel         = 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2 (2019-08-28) x86_64
    /proc/cmdline  = BOOT_IMAGE=/vmlinuz-4.19.0-6-amd64 root=/dev/mapper/vg-root ro quiet
    Init system    = systemd v241 (241)
    Boot mode      = BIOS (CSM, Legacy)
    
    +++ TLP Status
    State          = enabled
    Last run       = 02:29:30 PM,   7450 sec(s) ago
    Mode           = AC
    Power source   = AC
    
    +++ ThinkPad Battery Features
    tp-smapi   = inactive (kernel module 'tp_smapi' not installed)
    tpacpi-bat = active
    
    +++ ThinkPad Battery Status: BAT0 (Main / Internal)
    /sys/class/power_supply/BAT0/manufacturer                   = SMP
    /sys/class/power_supply/BAT0/model_name                     = 02DL017
    /sys/class/power_supply/BAT0/cycle_count                    =      6
    /sys/class/power_supply/BAT0/energy_full_design             =  48010 [mWh]
    /sys/class/power_supply/BAT0/energy_full                    =  49070 [mWh]
    /sys/class/power_supply/BAT0/energy_now                     =  49070 [mWh]
    /sys/class/power_supply/BAT0/power_now                      =      0 [mW]
    /sys/class/power_supply/BAT0/status                         = Full
    
    tpacpi-bat.BAT0.startThreshold                              =     60 [%]
    tpacpi-bat.BAT0.stopThreshold                               =    100 [%]
    tpacpi-bat.BAT0.forceDischarge                              =      0
    
    Charge                                                      =  100.0 [%]
    Capacity                                                    =  102.2 [%]
    Vorführeffekt ?

    Ich entlade mal ein wenig und probiere ob er danach lädt oder auch nicht ...



    Code:
    --- TLP 1.1 --------------------------------------------
    
    +++ System Info
    System         = LENOVO ThinkPad X390 20Q1S02M00
    BIOS           = N2JET73W (1.51 )
    Release        = Debian GNU/Linux 10 (buster)
    Kernel         = 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2 (2019-08-28) x86_64
    /proc/cmdline  = BOOT_IMAGE=/vmlinuz-4.19.0-6-amd64 root=/dev/mapper/vg-root ro quiet
    Init system    = systemd v241 (241)
    Boot mode      = BIOS (CSM, Legacy)
    
    +++ TLP Status
    State          = enabled
    Last run       = 05:11:01 PM,     41 sec(s) ago
    Mode           = AC
    Power source   = AC
    
    +++ ThinkPad Battery Features
    tp-smapi   = inactive (kernel module 'tp_smapi' not installed)
    tpacpi-bat = active
    
    +++ ThinkPad Battery Status: BAT0 (Main / Internal)
    /sys/class/power_supply/BAT0/manufacturer                   = SMP
    /sys/class/power_supply/BAT0/model_name                     = 02DL017
    /sys/class/power_supply/BAT0/cycle_count                    =      6
    /sys/class/power_supply/BAT0/energy_full_design             =  48010 [mWh]
    /sys/class/power_supply/BAT0/energy_full                    =  49550 [mWh]
    /sys/class/power_supply/BAT0/energy_now                     =  45300 [mWh]
    /sys/class/power_supply/BAT0/power_now                      =      0 [mW]
    /sys/class/power_supply/BAT0/status                         = Unknown (threshold effective)
    
    tpacpi-bat.BAT0.startThreshold                              =     60 [%]
    tpacpi-bat.BAT0.stopThreshold                               =    100 [%]
    tpacpi-bat.BAT0.forceDischarge                              =      0
    
    Charge                                                      =   91.4 [%]
    Capacity                                                    =  103.2 [%]
    ^^ alles gut!

    - - - Beitrag zusammengeführt - - -

    Also TLP 1.1 funktioniert auf dem X390 unter Debian Buster wie erhofft.
    Geändert von mcb (27.09.2019 um 18:14 Uhr)
    T490s Debian (Buster) https://www.debian.org/

  9. #2209
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    12.507
    Danke
    15
    Thanked 316 Times in 251 Posts
    Themenstarter
    Es kann übrigens sehr wohl sein, dass die EC Firmware beim Schreiben der Schwellen zickt, obwohl TLP alles richtig macht. Das X1C6 und 80er Modelle zeigten anfangs das Phänomen, dass sie nach erstmaligem Heruntersetzen der Stop-Schwelle keine Erhöhung mehr nehmen wollten -- siehe. Ein Update des ECP bzw. BIOS hat das Problem behoben.

    Zeigst Du auch noch die Ausgaben mit 1.2.2? Vielen Dank im voraus.
    Gruß, linrunner
    X1C6, T450s, X220 - Ubuntu 18.04 - TLP - Ubuntu Schnelleinstieg
    -- Fehler im Anwender sind schwer zu beheben, da es meist keine Updates gibt


  10. #2210

    Registriert seit
    18.03.2009
    Beiträge
    1.929
    Danke
    54
    Thanked 117 Times in 113 Posts
    Klar doch, spiele am Wochenende eh noch ein bischen rum - für den Test!
    T490s Debian (Buster) https://www.debian.org/

  11. #2211
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    12.507
    Danke
    15
    Thanked 316 Times in 251 Posts
    Themenstarter
    @mcb: Prima. Ich hab in deinem Test-Thread noch einen Wunsch gepostet.
    Gruß, linrunner
    X1C6, T450s, X220 - Ubuntu 18.04 - TLP - Ubuntu Schnelleinstieg
    -- Fehler im Anwender sind schwer zu beheben, da es meist keine Updates gibt


  12. #2212

    Registriert seit
    18.03.2009
    Beiträge
    1.929
    Danke
    54
    Thanked 117 Times in 113 Posts
    Dank der guten Anleitung:
    Code:
    --- TLP 1.2.2 --------------------------------------------
    
    +++ Configured Settings: /etc/default/tlp
    TLP_ENABLE=1
    TLP_DEFAULT_MODE=AC
    TLP_PERSISTENT_DEFAULT=0
    DISK_IDLE_SECS_ON_AC=0
    DISK_IDLE_SECS_ON_BAT=2
    MAX_LOST_WORK_SECS_ON_AC=15
    MAX_LOST_WORK_SECS_ON_BAT=60
    CPU_HWP_ON_AC=balance_performance
    CPU_HWP_ON_BAT=balance_power
    SCHED_POWERSAVE_ON_AC=0
    SCHED_POWERSAVE_ON_BAT=1
    NMI_WATCHDOG=0
    ENERGY_PERF_POLICY_ON_AC=performance
    ENERGY_PERF_POLICY_ON_BAT=power
    DISK_DEVICES="sda sdb"
    DISK_APM_LEVEL_ON_AC="254 254"
    DISK_APM_LEVEL_ON_BAT="128 128"
    SATA_LINKPWR_ON_AC="med_power_with_dipm max_performance"
    SATA_LINKPWR_ON_BAT="med_power_with_dipm min_power"
    AHCI_RUNTIME_PM_TIMEOUT=15
    PCIE_ASPM_ON_AC=performance
    PCIE_ASPM_ON_BAT=powersave
    RADEON_POWER_PROFILE_ON_AC=high
    RADEON_POWER_PROFILE_ON_BAT=low
    RADEON_DPM_STATE_ON_AC=performance
    RADEON_DPM_STATE_ON_BAT=battery
    RADEON_DPM_PERF_LEVEL_ON_AC=auto
    RADEON_DPM_PERF_LEVEL_ON_BAT=auto
    WIFI_PWR_ON_AC=off
    WIFI_PWR_ON_BAT=on
    WOL_DISABLE=Y
    SOUND_POWER_SAVE_ON_AC=0
    SOUND_POWER_SAVE_ON_BAT=0
    SOUND_POWER_SAVE_CONTROLLER=Y
    BAY_POWEROFF_ON_AC=0
    BAY_POWEROFF_ON_BAT=0
    BAY_DEVICE="sr0"
    RUNTIME_PM_ON_AC=on
    RUNTIME_PM_ON_BAT=auto
    USB_AUTOSUSPEND=1
    USB_BLACKLIST_BTUSB=0
    USB_BLACKLIST_PHONE=0
    USB_BLACKLIST_PRINTER=1
    USB_BLACKLIST_WWAN=1
    RESTORE_DEVICE_STATE_ON_STARTUP=0
    START_CHARGE_THRESH_BAT0=60
    RESTORE_THRESHOLDS_ON_BAT=1
    
    +++ System Info
    System         = LENOVO ThinkPad X390 20Q1S02M00
    BIOS           = N2JET73W (1.51 )
    Release        = Debian GNU/Linux 10 (buster)
    Kernel         = 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u1 (2019-09-20) x86_64
    /proc/cmdline  = BOOT_IMAGE=/vmlinuz-4.19.0-6-amd64 root=/dev/mapper/vg-root ro quiet
    Init system    = systemd v241 (241)
    Boot mode      = BIOS (CSM, Legacy)
    
    +++ TLP Status
    State          = enabled
    RDW state      = enabled
    Last run       = 02:54:35 PM,     40 sec(s) ago
    Mode           = AC
    Power source   = AC
    
    +++ Battery Features: Charge Thresholds and Recalibrate
    natacpi    = active (data, thresholds)
    tpacpi-bat = active (recalibrate)
    tp-smapi   = inactive (ThinkPad not supported)
    
    +++ ThinkPad Battery Status: BAT0 (Main / Internal)
    /sys/class/power_supply/BAT0/manufacturer                   = SMP
    /sys/class/power_supply/BAT0/model_name                     = 02DL017
    /sys/class/power_supply/BAT0/cycle_count                    =      6
    /sys/class/power_supply/BAT0/energy_full_design             =  48010 [mWh]
    /sys/class/power_supply/BAT0/energy_full                    =  49570 [mWh]
    /sys/class/power_supply/BAT0/energy_now                     =  45870 [mWh]
    /sys/class/power_supply/BAT0/power_now                      =      0 [mW]
    /sys/class/power_supply/BAT0/status                         = Unknown (threshold effective)
    
    /sys/class/power_supply/BAT0/charge_start_threshold         =     60 [%]
    /sys/class/power_supply/BAT0/charge_stop_threshold          =    100 [%]
    tpacpi-bat.BAT0.forceDischarge                              =      0
    
    Charge                                                      =   92.5 [%]
    Capacity                                                    =  103.2 [%]
    T490s Debian (Buster) https://www.debian.org/

  13. #2213

    Registriert seit
    01.02.2012
    Ort
    Berlin
    Beiträge
    311
    Danke
    12
    Thanked 7 Times in 6 Posts

    Wirkt sich TLP auf "Bildschirm sperren nach ..." aus?

    Mal so eine Frage zu TLP: Gibt es eine Möglichkeit, à la "tail -f" die Ausgabe von tlp-stat -b dauerhaft anzuzeigen und regelmäßig (jede Sekunde oder so) zu aktualisieren? Ich fände das praktisch, wenn ich den Lade-/Entladevorgang eines Akkus überwachen möchte...

  14. #2214

    Registriert seit
    01.12.2011
    Ort
    Hannover
    Beiträge
    5.544
    Danke
    109
    Thanked 415 Times in 330 Posts
    Du könntest:
    Code:
    watch -n 1 tlp-stat
    probieren. Hinter tlp-stat natürlich noch eventuelle Parameter.
    Nachteil: Es fängt immer oben an, wenn die Aussage sehr lang und der Bildschirm nicht sehr groß ist, bringt es eventuell wenig.
    T500 W520 T500, T480s: i7-8550U, 16GB, 1TB 970 Pro, MX150, PC: Asus Z97-A, i7-5775C@4,1GHz, 16GB 2400, 1TB SSD Homesrv: 32,5/24,5TB brt/net, Supermicro X11SSH-CTF, Xeon E3-1240v6, 32GB, SSD, LTO: 3x LTO (5&6), 125TB, Srv: einige Supermicro PDSML-LN2+, Xeon 3220, 8GB

  15. #2215
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    12.507
    Danke
    15
    Thanked 316 Times in 251 Posts
    Themenstarter
    @nsteinbach: Features die (unnötig) Akkuladung kosten, werden (normalerweise) nicht eingebaut. Bei tlp discharge/recalibrate steht hingegen das Entladen sowieso im Vordergrund, daher gibt es dort eine laufende Anzeige.
    Gruß, linrunner
    X1C6, T450s, X220 - Ubuntu 18.04 - TLP - Ubuntu Schnelleinstieg
    -- Fehler im Anwender sind schwer zu beheben, da es meist keine Updates gibt


  16. #2216

    Registriert seit
    01.02.2012
    Ort
    Berlin
    Beiträge
    311
    Danke
    12
    Thanked 7 Times in 6 Posts
    Zitat Zitat von cuco Beitrag anzeigen
    Du könntest:
    Code:
    watch -n 1 tlp-stat
    probieren. Hinter tlp-stat natürlich noch eventuelle Parameter.
    Nachteil: Es fängt immer oben an, wenn die Aussage sehr lang und der Bildschirm nicht sehr groß ist, bringt es eventuell wenig.
    Super, danke - damit funktioniert es!

    Zitat Zitat von linrunner Beitrag anzeigen
    @nsteinbach: Features die (unnötig) Akkuladung kosten, werden (normalerweise) nicht eingebaut. Bei tlp discharge/recalibrate steht hingegen das Entladen sowieso im Vordergrund, daher gibt es dort eine laufende Anzeige.
    Hups, nagut. Ich wollte den Ladevorgang überwachen, d.h. da ist auch genügend Strom verfügbar ;-)

Ähnliche Themen

  1. Antworten: 23
    Letzter Beitrag: 22.09.2010, 00:05
  2. Antworten: 2
    Letzter Beitrag: 27.05.2010, 17:26
  3. Antworten: 20
    Letzter Beitrag: 01.09.2009, 23:11
  4. IBM X41 Tablet mit Debian oder Ubuntu
    Von Frato im Forum Linux
    Antworten: 4
    Letzter Beitrag: 02.02.2009, 00:05
  5. Antworten: 6
    Letzter Beitrag: 14.10.2008, 14:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
ipWeb ok1.de Campus Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen CaptainNotebook NBWN - Notebooks wie neu