luxnote lapstore servion thinkspot
Ergebnis 1 bis 8 von 8

Thema: [Ubuntu 9.10] Lösung: Bluetooth beim Start deaktivieren

  1. #1

    Registriert seit
    31.08.2006
    Beiträge
    41
    Danke
    0
    Thanked 0 Times in 0 Posts

    [Ubuntu 9.10] Lösung: Bluetooth beim Start deaktivieren

    Auf meinem Thinkpad X60T ist nach der Installation von Ubuntu Karmic Koala Bluetooth per default eingeschaltet, falls der Schieberegler am Laptop für Wlan und Bluetooth eingeschaltet ist.

    Das mag für viele Anwender sinnvoll sein und es ist auch schön, dass Bluetooth mit Ubuntu funktioniert. Allerdings hätte ich gerne, dass Bluetooth zunächst abgeschaltet bleibt und nur Wlan aktiviert ist, da ich Bluetooth viel seltener nutze und der Dienst so nur Strom frisst.

    Zwar kann man mit "Fn + F5" Wlan und Bluetooth reihum ein- und ausschalten. Oder man kann mit einem Klick auf das Bluetooth-Applet in der oberen Symbolleiste Bluetooth per Menübefehl ausschalten. Um Bluetooth aber schon vorab zu deaktivieren:

    Öffne die Datei /etc/rc.local, die bei jedem Systemstart mit Rootrechten ausgeführt wird.

    Code:
    sudo gedit /etc/rc.local
    Füge darin vor der Zeile "exit 0" ein:
    Code:
    echo -n "disable" > /proc/acpi/ibm/bluetooth
    (Die Zeile "exit 0" muss als letzte Zeile in der Datei stehen bleiben, sonst funktioniert es nicht.)

    Nach einem Speichern und Neustart ist Bluetooth jetzt per default ausgeschaltet. Man kann es dann mühelos mit dem Applet in der Symbolleiste oder mit "Fn+F5" wieder einschalten, wenn man es denn braucht.

    Eine simple Lösung, die für mich funktioniert. Oder weiß jemand was Besseres?
    T42, 2373 FWG, Pentium M, 1,6 Ghz, * 2005, † 2008 (Flexing)
    X60T, 6363 C7G, Core2Duo L7400, * 2008
    Compaq Contura Aero, 486 SX, 33 Mhz, 20 MB RAM, 40 GB HDD, Debian 4, * 1994

  2. #2

    Registriert seit
    01.05.2006
    Beiträge
    65
    Danke
    0
    Thanked 0 Times in 0 Posts
    Danke, das ist genau das, was ich gesucht habe. Mir geht es ziemlich auf die Nerven, dass Ubuntu so viel Saft braucht. Versuche schon alles zu optimieren, aber kenne mich nicht so gut aus. Gibt es noch mehr solcher hilfreichen Tips?

    LG Spacke
    "Life isn't about waiting for a storm to pass... It's about learning how to dance in the rain."

  3. #3

    Registriert seit
    10.07.2006
    Beiträge
    237
    Danke
    0
    Thanked 0 Times in 0 Posts
    schonmal powertop versucht? das hat bei mir einiges gebracht....
    Treo 680 (PalmOS 5.4.9) Nokia E71, ThinkPad X60 (WinXP Win7, Ubuntu 9.04 9.10 10.10), Thinkpad X201 (Win7)

  4. #4

    Registriert seit
    24.06.2008
    Beiträge
    8
    Danke
    0
    Thanked 0 Times in 0 Posts
    funktioniert bis jetzt auch bei einem r61 deg.
    danke uli.
    ______________________________
    Thinkpad R61 89185 DEG

    Intel Core 2 Duo 2,1 GHz T8100 3 GB Ram

    Dualboot: Ubuntu 10.04 LTS / Win 7 Ult.

  5. #5
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    12.100
    Danke
    13
    Thanked 236 Times in 193 Posts

    RE: [Ubuntu 9.10] Lösung: Bluetooth beim Start deaktivieren

    [quote='_uli_',index.php?page=Thread&postID=700949# post700949]Eine simple Lösung, die für mich funktioniert. Oder weiß jemand was Besseres?[/quote]Es ist schon die einfachste Lösung. Allerdings wurde sie schon öfters mal "entdeckt" wie die SuFu verrät:
    [b][Linux][/b] [url='http://www.thinkpad-forum.de/thinkpad-software/linux-und-osx/p184356-deaktivieren-von-bluetooth/?highlight=%2Fproc%2Facpi%2Fibm%2Fbluetooth+rc.loc al#post184356']Deaktivieren von Bluetooth[/url]
    [Linux] ( erledigt) T500 und Ubuntu 9
    [Linux] R61: Probleme mit Bluetooth
    [Linux] Bluetooth nur on demand
    [Linux] [Intrepid] Die ersten Tage mit Intrepid Ibex RC
    [Linux] [Intrepid] Die ersten Tage mit Intrepid Ibex RC
    [Linux] [X30] (gelöst) Eigenartiges Problem mit BDC
    [Linux] T400 - Probleme unter Ubuntu 9.04
    Man könnte auch sagen gute Lösungen setzen sich durch ...
    Seit Karmic kann man Bluetooth beim Thinkpad übrigens über das Panel-icon wieder einschalten.
    Gruß, linrunner
    T450s, X220 - Ubuntu 16.04 - TLP - Ubuntu Schnelleinstieg
    -- Fehler im Anwender sind schwer zu beheben, da es meist keine Updates gibt


  6. #6

    Registriert seit
    31.08.2006
    Beiträge
    41
    Danke
    0
    Thanked 0 Times in 0 Posts
    Themenstarter
    Stimmt. Danke linrunner - hast Du ja praktisch im Mai hier genauso geschrieben. Da habe ich das Rad wohl ein weiteres Mal erfunden. Immerhin schön, dass es auch rund war.
    T42, 2373 FWG, Pentium M, 1,6 Ghz, * 2005, † 2008 (Flexing)
    X60T, 6363 C7G, Core2Duo L7400, * 2008
    Compaq Contura Aero, 486 SX, 33 Mhz, 20 MB RAM, 40 GB HDD, Debian 4, * 1994

  7. #7

    Registriert seit
    05.11.2006
    Beiträge
    826
    Danke
    0
    Thanked 0 Times in 0 Posts
    Gibts das ganze auch für das Touchpad?
    Das ist nämlich auch immer nach dem Start aktiv
    ich hab bis jetzt nur was gefunden es während dem Tippen zu deaktivieren.

    grüße

  8. #8
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    12.100
    Danke
    13
    Thanked 236 Times in 193 Posts
    Klar gibt's das.

    Erstmal mußt Du den von Dir erwähnten Haken in "System -> Einstellungen -> Maus -> Touchpad: Touchpad beim Tippen sperren" entfernen. Dann gehst Du in "System -> Einstellungen -> Startprogramme", <Hinzufügen> und gibst an Name="Touchpad aus", Befehl="synclient touchpadoff=1" (ohne die Anführungszeichen versteht sich), <Speichern>. Anschließend neu Anmelden. Mit Fn+F8 kann man es wieder an- bzw. ausschalten.

    EDITH: Lesestoff dazu hier: http://wiki.ubuntuusers.de/Touchpad
    Gruß, linrunner
    T450s, X220 - Ubuntu 16.04 - TLP - Ubuntu Schnelleinstieg
    -- Fehler im Anwender sind schwer zu beheben, da es meist keine Updates gibt


Ähnliche Themen

  1. Antworten: 16
    Letzter Beitrag: 17.02.2011, 14:03
  2. Antworten: 9
    Letzter Beitrag: 06.02.2010, 09:38
  3. Antworten: 15
    Letzter Beitrag: 08.07.2009, 11:50
  4. Probleme beim Start von Ubuntu 7.10
    Von michizwo im Forum R - Serie
    Antworten: 0
    Letzter Beitrag: 19.01.2008, 20:31
  5. "Pentium M"-Logo beim Start deaktivieren?
    Von MacGyver im Forum T - Serie
    Antworten: 78
    Letzter Beitrag: 25.02.2006, 19:14

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
CeCon ok1.de ipWeb Campus Shop Buchtmonitor gbyte - Drupal Webentwicklung