luxnote lapstore servion thinkspot
Ergebnis 1 bis 17 von 17

Thema: L470 Embedded Controller resetten?

  1. #1

    Registriert seit
    13.05.2007
    Beiträge
    543
    Danke
    0
    Thanked 6 Times in 6 Posts

    L470 Embedded Controller resetten?

    Ich habe hier auf Arbeit ein L470 mit Win10 x64. Das lief wie die anderen baugleichen Geräte "jahrelang" problemlos. Jetzt wo ich es wieder mal brauchte startet es gefühlt 10 Minuten lang, der Akkustand wird mit 255% angegeben und das Eventlog sagt, das es nicht auf den Embedded Controller zugreifen kann. CMOS-Reset habe ich schon probiert, ebenso Akku raus und round about eine halbe Minute auf den Powerknopf drücken. Hat leider nichts gebracht. Auch der Win10-Installations-USB-Stick braucht ungewöhnlich ewig zum starten. Also scheint die Win10-Installation nicht die Ursache zu sein. Wie kann man den Embedded Controller resetten, falls das überhaupt geht? BIOS ist auf dem letzten Stand Version 1.74.
    debianforum.de - die deutschsprachige Supportwebseite rund um das Debian-Projekt


  2. #2
    Help-Desk Avatar von Mornsgrans
    Registriert seit
    20.04.2007
    Ort
    Idar-Oberstein
    Beiträge
    67.618
    Danke
    58
    Thanked 1.950 Times in 1.771 Posts
    Zitat Zitat von feltel Beitrag anzeigen
    das Eventlog sagt, das es nicht auf den Embedded Controller zugreifen kann.
    1. Wie lautet die genaue Meldung?
    2. Ist TPFanControl installiert?
    3. Hast Du das BIOS schon neu initialisiert oder mal die BIOS-Batterie kurz abgeklemmt (Supervisior-Passwort wird danach abgefragt, wenn eines gesetzt ist!!!)?
    Meine frühere ThinkPad-Sammlung - Windows 10, das neue Windows XP ("XPerimental")
    Ich trinke meinen Kaffee wie Chuck Norris: Schwarz und ohne Wasser
    "Der Computer rechnet mit allem - nur nicht mit seinem Besitzer." - Dieter Hildebrandt

  3. #3

    Registriert seit
    13.05.2007
    Beiträge
    543
    Danke
    0
    Thanked 6 Times in 6 Posts
    Themenstarter
    Die Meldung kommt im System-Eventlog und lautet "Der eingebettete Controller (EC) hat nicht innerhalb des angegebenen Zeitlimits reagiert. Dies deutet auf einen Fehler in der EC-Hardware oder -Firmware hin bzw darauf das das BIOS auf die falsche Art auf den EC zugreift. Fragen Sie Ihren Computerhersteller...."

    TPFC ist nicht installiert. Das mit der BIOS-Batterie müsste ich noch probieren, da muss ich das Gerät aber mit ins Büro nehmen, dort liegt das iFixit-Werkzeug. Das ist ja schon ein Ultrabook-ifiziertes TP, wo du nicht einfach so ans Board kommst. :-|

    Ich werd jetzt mal probieren die gleiche BIOS-Version nochmal zu flashen, vielleicht hilfts.
    debianforum.de - die deutschsprachige Supportwebseite rund um das Debian-Projekt


  4. #4

    Registriert seit
    01.10.2008
    Ort
    CH-Spiez,D-Hermeskeil
    Beiträge
    1.979
    Danke
    38
    Thanked 261 Times in 195 Posts
    Manchmal bewirkt eine neue BIOS-Batterie Wunder.

  5. #5

    Registriert seit
    06.08.2006
    Ort
    Berlin
    Beiträge
    3.614
    Danke
    8
    Thanked 119 Times in 112 Posts
    Im Bios Downgrad erlauben, dann ältere Version flashen. Dann Bios-Reset und neu probieren.
    "Nicht alles was neu ist muß falsch, nicht alles was alt ist muß richtig sein."
    Asus GL702VM als Desktopersatz, X260 für unterwegs, Macbook-Air weil's benötigt wird

  6. #6
    Help-Desk Avatar von Mornsgrans
    Registriert seit
    20.04.2007
    Ort
    Idar-Oberstein
    Beiträge
    67.618
    Danke
    58
    Thanked 1.950 Times in 1.771 Posts
    Zitat Zitat von feltel Beitrag anzeigen
    "Der eingebettete Controller (EC) hat nicht innerhalb des angegebenen Zeitlimits reagiert. Dies deutet auf einen Fehler in der EC-Hardware oder -Firmware hin bzw darauf das das BIOS auf die falsche Art auf den EC zugreift. Fragen Sie Ihren Computerhersteller...."
    Ist eigentlich eine typische Meldung bei TPFanControl.
    Meine frühere ThinkPad-Sammlung - Windows 10, das neue Windows XP ("XPerimental")
    Ich trinke meinen Kaffee wie Chuck Norris: Schwarz und ohne Wasser
    "Der Computer rechnet mit allem - nur nicht mit seinem Besitzer." - Dieter Hildebrandt

  7. #7

    Registriert seit
    13.05.2007
    Beiträge
    543
    Danke
    0
    Thanked 6 Times in 6 Posts
    Themenstarter
    Sodele, wieder im Büro. Ich hab das BIOS mal testweise auf 1.71 "aktualisiert", BIOS-Defaults geladen etc. Der EC-Fehler tritt weiterhin auf und Windows braucht ca. 10 Minuten zum Start. Auch das Entfernen der CMOS-Batterie hat keinen Effekt. Da wird der EC-Controller oder sein Speicher oder was auch immer tatsächlich einen Defekt haben, und damit das ganze Board. Schade drum, denn ansonsten ist das L470 in einem guten Zustand für sein Alter. :-|
    debianforum.de - die deutschsprachige Supportwebseite rund um das Debian-Projekt


  8. #8
    Help-Desk Avatar von Mornsgrans
    Registriert seit
    20.04.2007
    Ort
    Idar-Oberstein
    Beiträge
    67.618
    Danke
    58
    Thanked 1.950 Times in 1.771 Posts
    Wäre schade drum.

    Noch ein Hinweis:
    Der Embedded Controller wird nur aktialisiert, wenn sie eine andere Versionsnummer als die derzeit installierte hat.
    EC-Updates gibt es viel seltener als BIOS Updates.
    Ob jetzt ein BIOS-Downgrade auf eine Version mit kleinerer EC-Version möglich ist, müsstest Du in der aktuellen README unter "Version History" finden.

    Eventuell kann auch ein versierter Schraube den EC mit einem Dump neu flashen.
    Meine frühere ThinkPad-Sammlung - Windows 10, das neue Windows XP ("XPerimental")
    Ich trinke meinen Kaffee wie Chuck Norris: Schwarz und ohne Wasser
    "Der Computer rechnet mit allem - nur nicht mit seinem Besitzer." - Dieter Hildebrandt

  9. #9

    Registriert seit
    06.08.2006
    Ort
    Berlin
    Beiträge
    3.614
    Danke
    8
    Thanked 119 Times in 112 Posts
    Irgendeine 1.5x-Version oder kleiner braucht es damit der EC aktualisiert wird.
    "Nicht alles was neu ist muß falsch, nicht alles was alt ist muß richtig sein."
    Asus GL702VM als Desktopersatz, X260 für unterwegs, Macbook-Air weil's benötigt wird

  10. #10

    Registriert seit
    13.05.2007
    Beiträge
    543
    Danke
    0
    Thanked 6 Times in 6 Posts
    Themenstarter
    Beim Downgrade auf 1.71 zeigte zumindest das BIOS auch an, das der EC-Controller ebenfalls auf Stand 1.71 sei; vorher waren beide auf 1.74. Das korrespondiert auch mit https://download.lenovo.com/pccbbs/m.../r0guj26ww.txt.
    debianforum.de - die deutschsprachige Supportwebseite rund um das Debian-Projekt


  11. #11

    Registriert seit
    21.09.2009
    Beiträge
    997
    Danke
    10
    Thanked 108 Times in 102 Posts
    Ist zwar mehr ein Akt der Verzweiflung aber: Gibts diese Fehler auch ohne Akku? Nicht dass der den EC wieso auch immer so massiv verwirrt... Gut ist schonmal, dass wohl die Tastatur funktioniert, Lüfterregelung anscheinend tut, du den EC flashen konntest und der Rechner auch überhaupt anspringt. Da ist mit etwas Glück nicht soo viel kaputt.

  12. #12
    Avatar von TheGrey
    Registriert seit
    24.03.2008
    Ort
    Großraum Stuttgart (Winnenden)
    Beiträge
    1.527
    Danke
    17
    Thanked 75 Times in 67 Posts
    Ich hab noch ein X201 mit so einem Problem. Weil es auch sehr warm wird wollte ich WLP erneuern, bin aber noch nicht dazu gekommen. Wärme ist bei Dir normal?
    [ ThinkPad X201 | WXGA+ | i5-560M | 8 GB | 512 GB (Crucial M4) | 802.11n | BT | WWAN | FPR | 6c ]
    [ ThinkPad X61s | SXGA+ | L7500 | 8 GB | 256 GB (Crucial C300) | 802.11n | BT | WWAN | FPR | 8c ]

  13. #13

    Registriert seit
    13.05.2007
    Beiträge
    543
    Danke
    0
    Thanked 6 Times in 6 Posts
    Themenstarter
    @TheGrey: die Wärmeentwicklung und auch das Lüfterverhalten sind normal, also in der Hinsicht nichts auffälliges. Mal läuft der Lüfter an und aber die meiste Zeit ist er gefühlt aus.
    @mitfritscher: Leider auch ohne Akku das gleiche Verhalten. Es wird dann auch erkannt, das kein Akku drin ist.
    debianforum.de - die deutschsprachige Supportwebseite rund um das Debian-Projekt


  14. #14

    Registriert seit
    21.09.2009
    Beiträge
    997
    Danke
    10
    Thanked 108 Times in 102 Posts
    Erkannt = die entsprechende LED, oder sogar vom Betriebssystem?

    Irgendwie klingt das nicht danach, als ob der EC ein gröberes Problem hat - er scheint ja grundlegend noch zu tun. Da müsste man jetzt mal gucken, was den EC so Probleme bereitet

  15. #15

    Registriert seit
    04.09.2014
    Ort
    Mannheim
    Beiträge
    11
    Danke
    0
    Thanked 0 Times in 0 Posts
    Moin,

    also entweder hat der SuperIO eine Macke, oder irgendein Gerät, dass an ihm hängt, verursacht das Problem. Vielleicht wird er einfach komplett blockiert und kann den anderen Anfragen vom Chipsatz nicht mehr antworten.
    Gerne kann auch die Tastatur dafür verantwortlich sein. Wenn du sich traust, könntest du die mal abklemmen und mit einer externen Tastatur hochfahren. Vielleicht hast du da einen Erfolg.

    Wer Interesse daran hat, hier mal ein Link zu einem Bild von dem Pinout des ECs:
    http://www.datasheetcafe.com/it8586e-datasheet-pdf/

  16. #16

    Registriert seit
    13.05.2007
    Beiträge
    543
    Danke
    0
    Thanked 6 Times in 6 Posts
    Themenstarter
    Zitat Zitat von mifritscher Beitrag anzeigen
    Erkannt = die entsprechende LED, oder sogar vom Betriebssystem?

    Irgendwie klingt das nicht danach, als ob der EC ein gröberes Problem hat - er scheint ja grundlegend noch zu tun. Da müsste man jetzt mal gucken, was den EC so Probleme bereitet
    Win10 sagt dann das es keinen Akku hat im Systray. Und wenn der Akku drin steckt, dann hat der lt Windows 255% Kapazität.
    debianforum.de - die deutschsprachige Supportwebseite rund um das Debian-Projekt


  17. #17
    Help-Desk Avatar von Mornsgrans
    Registriert seit
    20.04.2007
    Ort
    Idar-Oberstein
    Beiträge
    67.618
    Danke
    58
    Thanked 1.950 Times in 1.771 Posts
    Welche unbekannten Geräte befinden sich im Gerätemanager?
    Meine frühere ThinkPad-Sammlung - Windows 10, das neue Windows XP ("XPerimental")
    Ich trinke meinen Kaffee wie Chuck Norris: Schwarz und ohne Wasser
    "Der Computer rechnet mit allem - nur nicht mit seinem Besitzer." - Dieter Hildebrandt

Ähnliche Themen

  1. Embedded Controller Program
    Von Nobby im Forum T - Serie
    Antworten: 0
    Letzter Beitrag: 03.04.2008, 10:22
  2. Bios/Embedded Controller
    Von Newbie123 im Forum T - Serie
    Antworten: 32
    Letzter Beitrag: 27.04.2005, 12:18
  3. Bios & Embedded Controller Update
    Von Mike8 im Forum T - Serie
    Antworten: 13
    Letzter Beitrag: 29.11.2004, 09:14
  4. Antworten: 12
    Letzter Beitrag: 18.11.2004, 15:51
  5. Antworten: 4
    Letzter Beitrag: 12.11.2004, 15:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
thinkstore24.de Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen CaptainNotebook