luxnote lapstore servion thinkspot
Ergebnis 1 bis 8 von 8

Thema: X61: Booten über Netzwerk?

  1. #1

    Registriert seit
    03.05.2009
    Beiträge
    553
    Danke
    1
    Thanked 34 Times in 31 Posts

    X61: Booten über Netzwerk?

    Ich scheitere gerade am booten eines X61 üer PXE. Hat das schon mal wer von euch hinbekommen?

    Was ich bisher versucht habe: pxelinux, lpxelinux und ipxe per TFTP starten. Das funktioniert. Ich kann auch Kernel bzw. memdisk nachladen, eine initrd nachladen. Aber sobald iPXE/pxelinux den Kernel starten wollen, bleibt nur ein blinkender Cursor in der nächsten zeile stehen und das war's.

    Irgend welche Ideen, woran das liegen kann?

  2. #2
    Help-Desk Avatar von Mornsgrans
    Registriert seit
    20.04.2007
    Ort
    Idar-Oberstein
    Beiträge
    63.752
    Danke
    33
    Thanked 1.421 Times in 1.277 Posts
    Zu wenig RAM?
    Meine frühere ThinkPad-Sammlung und deren Verkauf wegen Sammlungsauflösung
    Ich trinke meinen Kaffee wie Chuck Norris: Schwarz und ohne Wasser
    "Der Computer rechnet mit allem - nur nicht mit seinem Besitzer." - Dieter Hildebrandt

  3. #3

    Registriert seit
    03.05.2009
    Beiträge
    553
    Danke
    1
    Thanked 34 Times in 31 Posts
    Themenstarter
    Eher nicht, sind 4GB. Ich hb's gestern noch geschafft, beliebige kernel+initrd zu booten, aber nur direkt über iPXE, nicht aber mit Chainloader wie GRUB oder MEMDISK. Nur, ohne MEMDISK kann ich keine CD/HD-Images booten

  4. #4
    Avatar von joker4791
    Registriert seit
    06.02.2012
    Beiträge
    1.458
    Danke
    31
    Thanked 119 Times in 106 Posts
    Habe gerade nochmal nachgeschaut, mein X61 Tablet bootet sauber über PXE in z. B. ein Parted Magic, also liegt es vmtl. an der Konfig auf Deinem PXE-Server. Mein Tablet hat ein L7500 und 4GB RAM, der DHCP/PXE-Server läuft noch unter Debian Lenny, also steinalt. Falls Du da irgendwelche Config-Files brauchst, kann ich gerne mal nachschauen.
    HW: nb51.com T70 3rd | 15'' 4:3 Daylight-LED QXGA | Intel i7-7820HQ | 32GB RAM | 256GB NVMe-SSD | SW: leider noch kein Debian
    Sammelbestellung 24 LED-Kit für T/R/X/Z-Serie u. v. m.

  5. #5

    Registriert seit
    03.05.2009
    Beiträge
    553
    Danke
    1
    Thanked 34 Times in 31 Posts
    Themenstarter
    Kannst du das Configfile fürs booten von Parted Magic posten? Ich krieg' MEMDISK auf beigen und brechen nicht dazu das runtergeladene ISO (oder HDD image) zu booten, egal für welches OS. Hab' mittlerweoile sogar die FreeDOS12 Disk probiert, ohne Erfolg.

  6. #6
    Avatar von joker4791
    Registriert seit
    06.02.2012
    Beiträge
    1.458
    Danke
    31
    Thanked 119 Times in 106 Posts
    Hier der relevante Teil aus der /etc/dhcp3/dhcpd.conf:<br>
    Code:
    subnet 192.168.0.0 netmask 255.255.255.0 {
    ...<br>  filename "pxelinux.0";
    ...<br>        option subnet-mask 255.255.255.0;           # Default subnet mask to be used by DHCP clients
            option broadcast-address 192.168.0.255;     # Default broadcastaddress to be used by DHCP clients
    ...<br>}
    <br><div>(wundert mich grad' selber, dass da sooo wenig PXE-Zeugs drinne steht)<br><br>In /var/lib/tftpboot ist dann die pxelinux.0 abgelegt, ist aber nicht mehr die originale aus der Debian-Installation, sondern - glaube ich - aus dem syslinux-Paket.<br><br>Dann gibt es bei mir noch die /var/lib/tftpboot/pxelinux.cfg/default in der das Boot-Menu abgebildet ist (daraus mal ein paar Beispiele):<br>
    Code:
    DEFAULT menu.c32
    PROMPT 0
    MENU TITLE \o/ joker's network boot menu \o/
    TIMEOUT 200
    
    LABEL d
        MENU LABEL Boot from ^disk
        localboot 0x80
    
    # MS-DOS 7.0
    label dos
        MENU DEFAULT
        MENU LABEL ^MS-DOS 7.0
        kernel memdisk
        append initrd=DOS70/dos.img
    
    #LABEL PE
        menu label Windows PE 32-Bit
        LINUX WinPE/memdisk
        APPEND iso raw
        INITRD WinPE/WinPE_x86.iso
    
    #LABEL PE_x64
        menu label Windows PE 64-Bit
        LINUX WinPE/memdisk
        APPEND iso raw
        INITRD WinPE/WinPE_x64.iso
    
    label acronistrueimage2018_32bit
      menu label Acronis True Image 2018 32-bit
      kernel /acronis/ti2018/dat2.dat
      append initrd=/acronis/ti2018/dat3.dat,/acronis/ti2018/dat4.dat force_modules=usbhid vga=791 ramdisk_size=102400 quiet
    
    label acronistrueimage2018_64bit
      menu label Acronis True Image 2018 64-bit
      kernel /acronis/ti2018/dat10.dat
      append initrd=/acronis/ti2018/dat11.dat,/acronis/ti2018/dat12.dat force_modules=usbhid vga=791 ramdisk_size=102400 quiet
    
    LABEL pmagic
            MENU LABEL Parted Magic 6.6 (2012/11/30)
            LINUX pmagic/bzImage
            INITRD pmagic/initrd.img
            APPEND edd=off load_ramdisk=1 prompt_ramdisk=0 rw vga=normal loglevel=9 max_loop=256<br>...
    <br>wobei die PE-Images auf DIESEM Server auch nicht gehen, aber mit einem provisorischen, unter Win lt. <a data-cke-saved-href="https://thinkwiki.de/Netzwerkinstallation_%28PXE%29_von_Windows_7" href="https://thinkwiki.de/Netzwerkinstallation_%28PXE%29_von_Windows_7">Anle itung im ThinkWiki</a> eingerichteten PXE-Server schon...</div><div><br></div>

    [Na toll, irgendwie würfelt die Foren-Software hier die Formatierungen ganz schön durcheinander ]

    - - - Beitrag zusammengeführt - - -

    Code:
    lambda:~# ls -l /var/lib/tftpboot/pxelinux.0
    -rwxr-xr-x 1 root root 15840  2. Jan 2009  /var/lib/tftpboot/pxelinux.0
    HW: nb51.com T70 3rd | 15'' 4:3 Daylight-LED QXGA | Intel i7-7820HQ | 32GB RAM | 256GB NVMe-SSD | SW: leider noch kein Debian
    Sammelbestellung 24 LED-Kit für T/R/X/Z-Serie u. v. m.

  7. #7

    Registriert seit
    21.09.2009
    Beiträge
    799
    Danke
    9
    Thanked 55 Times in 53 Posts
    memdisk ist ziemlich buggy, das kommt sehr auf die pxelinux-Version an, ob das geht oder nicht :-/

  8. #8

    Registriert seit
    03.05.2009
    Beiträge
    553
    Danke
    1
    Thanked 34 Times in 31 Posts
    Themenstarter
    Ok, meine config ist nicht wirklich viel anders, ich hab' halt OpenWRT auf dem Bootserver laufen. Ich hb' weder mit memdisk aus den devuan/debiuan repositories noch mit einer selbstgebauten Version aus den Sourcen von syslinux booten können. Egal welche Version von pxe loader ich genommen hab (pxelinux oder ipxe oder grub, sogar grub4dos hab' ich versucht ...), kein Erfolg. Debian netboot.tar.gz hab' ich auch versucht - kommt mit eigenem pxelinux - das startet dann zwar vesamenuc32, scheitert aber dann beim booten.

    Irgendwie war ich der Meinung, dass ich vor undenklichen Zeiten einmal memdisk erfolgreich verwendet habe. Hm .. vermutlich war das damals aber das selbe Problem.

    na ja, jetzt versuch' ich mal oib ich iSCSI zum laufen bring'. Viellecht kann ich iPXE ja eine ISO als iSCSI image unterjubeln ...

Ähnliche Themen

  1. Windows 7 aus Netzwerk booten
    Von Flatterlight im Forum Windows
    Antworten: 4
    Letzter Beitrag: 15.07.2015, 17:45
  2. Antworten: 7
    Letzter Beitrag: 27.01.2013, 19:55
  3. X6x Linux Mint 12 auf X61 über Dockingstation installiert aber kein booten möglich
    Von thinkovic im Forum X - Serie (inkl. Tablet)
    Antworten: 9
    Letzter Beitrag: 04.05.2012, 01:57
  4. booten über Netzwerk ?
    Von fishmac im Forum Windows
    Antworten: 0
    Letzter Beitrag: 21.06.2009, 13:21
  5. Linux über Netzwerk installieren... HELP
    Von Knut676 im Forum X - Serie (inkl. Tablet)
    Antworten: 14
    Letzter Beitrag: 25.08.2008, 17:44

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
ipWeb ok1.de Campus Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen CaptainNotebook NBWN - Notebooks wie neu