luxnote lapstore servion thinkspot
Ergebnis 1 bis 18 von 18

Thema: Miese Platten-Performance mit X1 Tablet Gen 3 unter Windows 10

  1. #1
    Avatar von feklee
    Registriert seit
    22.03.2013
    Ort
    Baden-Baden
    Beiträge
    257
    Danke
    31
    Thanked 3 Times in 3 Posts

    Böse Miese Platten-Performance mit X1 Tablet Gen 3 unter Windows 10

    Beim X1 Tablet Gen 3 handelt sich um ein Modell mit i7, 16 GiB RAM, Samsung 950 PRO NVMe 512 GB und Win10 Pro.

    Schon beim Übertragen von Dateien von meinem T420s (i7, 8 GiB RAM, 500 GB Samsung 840 EVO, Win7x64 Pro) habe ich deutliche Performance-Unterschiede gemerkt. Einpacken der Dateien mit WinRar (ohne Kompression) auf eine externe USB-3-Platte hat auf dem T420s vielleicht eine halbe Stunde gedauert. Das Entpacken auf dem X1 Tablet hat etwa eineinhalb Stunden gedauert. Gut, dachte ich mir, das Problem kann an USB liegen.

    Auch ist mir aufgefallen, dass das Anzeigen der Gesamtgröße eines Verzeichnisses auf dem T420s deutlich schneller ist als auf dem X1 Tablet. In diesem Fall handelte es sich um Verzeichnisse, die auf beiden Rechnern indiziert sind. Das Problem könnte also der Index sein.

    Deshalb heute ein weiterer Test, ohne USB und ohne Index. Ich habe ein großes Verzeichnis auf den Desktop kopiert. Quelle und Ziel befinden sich auf der selben Platte. Diese Operation habe ich zeitgleich auf dem T420s und auf dem X1 Tablet ausgeführt. Zum Zustand des X1 Tablet:

    • eingesteckt, mit "Power mode (plugged in): Best performance"
    • keine schwergewichtigen Programme am Laufen, auch kein Web-Browser
    • keine Indizierung auf dem Desktop
    • Windows Defender komplett aus


    Die geringste angezeigte Geschwindigkeit, die ich auf dem X1 Tablet gesehen habe, war wiederholt 500 kB/s (ja, Kilobyte pro Sekunde). Das Problem dürften Unterverzeichnisse mit vielen kleinen Dateien sein (Maildir, eine Datei pro E-Mail). Nur: Mein T420s mit Windows-7 x64 war mit der gleichen Operation früher fertig, und zwar deutlich! Als das T420s fertig war, war das X1 Tablet erst bei 48% und ich habe schließlich abgebrochen.

    Ich darf doch erwarten, dass die Performance auf dem X1 Tablet mindestens so gut ist wie auf dem T420s, oder nicht?
    Geändert von feklee (29.01.2019 um 10:42 Uhr)

  2. #2
    Avatar von gerli09
    Registriert seit
    21.05.2009
    Ort
    Köln
    Beiträge
    5.158
    Danke
    17
    Thanked 214 Times in 196 Posts
    Den AS SSD Benchmark hast du mal auf beiden Rechnern gemacht zum Vergleich?
    P51s UHD | i7 7600u | 24 GB RAM | 1 TB SSD | Win 10 Pro

  3. #3

    Registriert seit
    10.06.2008
    Ort
    Hamburg
    Beiträge
    5.535
    Danke
    1
    Thanked 299 Times in 280 Posts
    Zitat Zitat von feklee Beitrag anzeigen
    Ich darf doch erwarten, dass die Performance auf dem X1 Tablet mindestens so gut ist wie auf dem T420s, oder nicht?
    Das würde ich auf keinen Fall unterschreiben wollen....

    Leistung kommt leider immer noch von leisten und (sehr sehr vereinfacht gesprochen) je mehr Watt die Dinger wegnuckeln umso schneller sind die Prozessoren auch bei gleicher Taktrate.
    Daher sind Desktop CPUS immer noch wesentlich performanter als Mobile CPUs.

    Erschwerend kommt hinzu, dass die Tablets ja die Ultralow Power CPUs verbaut haben....

    Einfach mal auf Notebookcheck die CPUs anschauen.
    Hier mal zwei Links, von Prozessoren die Du evtl. besitzen könntest:
    T420s versus X1 Tablet

    Seit der 4.ten Generation sind die Intel CPUs immer stromsparender aber nicht unbedingt schneller geworden.

    Wie gesagt, alles sehr sehr vereinfacht dargestellt.
    System error, strike any user to continue...

    In Benutzung: T440p

  4. #4
    Avatar von Hans ganz
    Registriert seit
    05.01.2016
    Ort
    Hamburg
    Beiträge
    253
    Danke
    0
    Thanked 5 Times in 5 Posts
    Man könnte mal die Datenübertragungsrate von Festplatte und Ram auf beiden Geräten vergleichen. Die Rechenleistung könnte man auch benchmarken, insbesondere das hashen und dehashen.
    Generell steht paralleles rechnen in Zusammenhang mit seriellem rechnen.
    Gruß, Hans_ganz

    Lachen ist wie eine Butterblume, ohne den Fruchtansatz.

  5. #5
    Avatar von feklee
    Registriert seit
    22.03.2013
    Ort
    Baden-Baden
    Beiträge
    257
    Danke
    31
    Thanked 3 Times in 3 Posts
    Themenstarter
    Zitat Zitat von laptopheaven Beitrag anzeigen
    Erschwerend kommt hinzu, dass die Tablets ja die Ultralow Power CPUs verbaut haben....
    Der Device-Manager listet achtmal: Intel(R) i7-8650U CPU @ 1.90Ghz

    Ich dachte, dass im X1 Tablet der dritten Generation keine Ultra-Low-Power-CPU verbaut ist.

  6. #6

    Registriert seit
    01.12.2011
    Ort
    Hannover
    Beiträge
    5.381
    Danke
    90
    Thanked 394 Times in 308 Posts
    Das U am Ende des CPU-Namens sagt, dass es eine Ultra-Low-Voltage (ULV) CPU ist. Trotzdem müsste das Gerät aber mit deinem T420s zumindest mithalten können, daher ist da vermutlich doch was im Argen...
    T500 W520 T500, T480s: i7-8550U, 16GB, 1TB 970 Pro, MX150, PC: Asus Z97-A, i7-5775C@4,1GHz, 16GB 2400, 1TB SSD Homesrv: 32,5/24,5TB brt/net, Supermicro X11SSH-CTF, Xeon E3-1240v6, 32GB, SSD, LTO: 3x LTO (5&6), 125TB, Srv: einige Supermicro PDSML-LN2+, Xeon 3220, 8GB

  7. #7
    Avatar von SigurdWarp
    Registriert seit
    01.03.2009
    Ort
    Sauerland
    Beiträge
    639
    Danke
    27
    Thanked 106 Times in 60 Posts
    Ich habe mal auf meinem X1 Tablet 3. Generation den AS Benchmark Test laufen lassen. Ich kann bei mir keine Performance Probleme feststellen, das Gegenteil ist (subjektiv) eher der Fall.

    Ergebnis:

    Benchmark SSD.png

    Ob der Wert jetzt besonders gut oder schlecht ist, weiß ich nicht. Vielleicht hilft es ja als Info. Ich habe hier jedenfalls eine Intel SSDPEKKF512G8L werkseitig verbaut.

    EDIT: hab mal nach Vergleichszahlen geguckt, 2855 Punkte ist gar nicht so schlecht, wenn ich das so sehe :-)

    EDIT II: zu den Testbedingungen: hatte mehrere Anwendungen geöffnet, Netzstrom, "bessere Leistung" (= mittlere Stellung des Schiebers)
    Geändert von SigurdWarp (29.01.2019 um 14:19 Uhr)
    Maximum Warp

  8. #8
    Avatar von ibmthink
    Registriert seit
    30.12.2010
    Ort
    MKK ("Mich-Kennt-Keiner")
    Beiträge
    13.796
    Danke
    264
    Thanked 915 Times in 672 Posts
    Blog-Einträge
    4
    Zitat Zitat von laptopheaven Beitrag anzeigen
    Hier mal zwei Links, von Prozessoren die Du evtl. besitzen könntest:
    T420s versus X1 Tablet
    Die Links funktionieren nicht, da du einfach nur die Liste ohne konkrete Auswahl an Vergleichs-CPUs verlinkt hast. Damit das funktioniert müsstest du den Permalink nehmen.

    Zitat Zitat von laptopheaven Beitrag anzeigen
    Seit der 4.ten Generation sind die Intel CPUs immer stromsparender aber nicht unbedingt schneller geworden.

    Wie gesagt, alles sehr sehr vereinfacht dargestellt.
    Vereinfacht und inkorrekt: Die neusten stromsparenden Prozessoren mit vier Kernen sollten sehr wohl deutlich schneller sein als die nun schon uralten Dual-Core-Prozessoren der Generation T420(s). In diesem Fall dürfte das Problem wo anders liegen.
    Lenovo ThinkPad P51 | lenovo ThinkPad X301 | lenovo ThinkPad X1
    New Thinking . New ThinkPad .

  9. #9

    Registriert seit
    10.06.2008
    Ort
    Hamburg
    Beiträge
    5.535
    Danke
    1
    Thanked 299 Times in 280 Posts
    Zitat Zitat von feklee Beitrag anzeigen
    Der Device-Manager listet achtmal: Intel(R) i7-8650U CPU @ 1.90Ghz
    Ich hatte mich oben vertan. Das X1 Tablet der 3.ten Generation hat ja schon die neueste CPU der 8.ten Genertaion verbaut. Ich hatte nach einer anderen CPU Generation bei Notebookcheck geschaut... Ich hatte eine X1 Carbon der 3.ten Generation am Wickel und die ist älter, da 5.te Genration


    Auf jeden Fall mit Assd oder einem ähnlichen Tool das Alignment überprüfen, sonst wird es seeeeehr langsam beim Schreiben.

    - - - Beitrag zusammengeführt - - -

    Zitat Zitat von laptopheaven Beitrag anzeigen
    Die Links funktionieren nicht, da du einfach nur die Liste ohne konkrete Auswahl an Vergleichs-CPUs verlinkt hast. Damit das funktioniert müsstest du den Permalink nehmen.
    Ja Du hst recht., da hatte ich mich vertan.... Mea Culpa
    System error, strike any user to continue...

    In Benutzung: T440p

  10. #10

    Registriert seit
    25.04.2009
    Ort
    Oldenburg
    Beiträge
    1.048
    Danke
    117
    Thanked 76 Times in 69 Posts
    Ich habe den Benchmark auch laufen lassen und deutlich schlechtere Werte @Sigurd, allerdings mit einer Toshiba SSD:

    (Ausbalanciert im Akkubetrieb, keine anderen Programme laufend)
    Angehängte Grafiken Angehängte Grafiken
    Thinkpad L430 @Windows 8.1
    Thinkpad X230 @Linux
    Thinkpad X1 Tablet @Windows 10

  11. #11

    Registriert seit
    13.10.2012
    Beiträge
    1.104
    Danke
    4
    Thanked 39 Times in 38 Posts
    Der Device-Manager listet achtmal: Intel(R) i7-8650U CPU @ 1.90Ghz
    kommt darauf an was die software dann wirklich nutzt nur ien kern oder alle kein Hypertrading oder nur auf 1-2 kernen und / oder ......
    (Ausbalanciert im Akkubetrieb, keine anderen Programme laufend)
    dann ist ja schon mal die häfte der geschwindigkeit des PCI bus weg die NVME hängt da auch daran.
    im akku wird immer gedrosselt .
    Vereinfacht und inkorrekt: Die neusten stromsparenden Prozessoren mit vier Kernen sollten sehr wohl deutlich schneller sein als die nun schon uralten Dual-Core-Prozessoren der Generation T420(s). In diesem Fall dürfte das Problem wo anders liegen.
    genau so vereinfacht und genauso inkorrekt da ja faslt alle i7 gedrosselt werden, in den: "ach so sexy wirkenden gehäuse", weil man die währme nicht wegbekommt dazu kommt noch ob und wie viele kerne die software braucht und ob mit oder ohne HT.

    ich denke 2 kerne mit HT von der software genutzt, sind schneller als 4 kerne ohne HT mit weniger takt.
    kann sein das ich mich irre sind einfach praktische erfahrungen.

  12. #12

    Registriert seit
    25.04.2009
    Ort
    Oldenburg
    Beiträge
    1.048
    Danke
    117
    Thanked 76 Times in 69 Posts
    Zitat Zitat von gestern Beitrag anzeigen
    dann ist ja schon mal die häfte der geschwindigkeit des PCI bus weg die NVME hängt da auch daran.
    im akku wird immer gedrosselt .
    Meinethalben nochmal am Dock (d.h. am Strom ... ). Viel macht das nu echt nicht aus. Aber schon deutlich schlechter als die Intel - wobei das am Ende in der normalen Nutzung vmtl. völlig egal ist .
    Angehängte Grafiken Angehängte Grafiken
    Thinkpad L430 @Windows 8.1
    Thinkpad X230 @Linux
    Thinkpad X1 Tablet @Windows 10

  13. #13
    Avatar von ibmthink
    Registriert seit
    30.12.2010
    Ort
    MKK ("Mich-Kennt-Keiner")
    Beiträge
    13.796
    Danke
    264
    Thanked 915 Times in 672 Posts
    Blog-Einträge
    4
    Zitat Zitat von gestern Beitrag anzeigen
    genau so vereinfacht und genauso inkorrekt da ja faslt alle i7 gedrosselt werden, in den: "ach so sexy wirkenden gehäuse", weil man die währme nicht wegbekommt dazu kommt noch ob und wie viele kerne die software braucht und ob mit oder ohne HT. ich denke 2 kerne mit HT von der software genutzt, sind schneller als 4 kerne ohne HT mit weniger takt.
    Irrelevant, selbst gedrosselt sind die neuen i7-Prozessoren deutlich schneller als die alten Dual-Core-CPUs. Hyperthreading beherrschen diese Prozessoren übrigens alle.
    Lenovo ThinkPad P51 | lenovo ThinkPad X301 | lenovo ThinkPad X1
    New Thinking . New ThinkPad .

  14. #14

    Registriert seit
    01.12.2011
    Ort
    Hannover
    Beiträge
    5.381
    Danke
    90
    Thanked 394 Times in 308 Posts
    Zitat Zitat von gestern Beitrag anzeigen
    kommt darauf an was die software dann wirklich nutzt nur ien kern oder alle kein Hypertrading oder nur auf 1-2 kernen und / oder ......
    Die meisten Pack- und Entpackprogramme kommen sehr gut mit vielen Kernen klar. Außerdem sind die 1,9GHz in sofern ein bisschen irreführend, weil die CPU in der Regel bei Last auf allen Kernen auf Dauer trotzdem 2,1 GHz und eher noch darüber liefert, kurzzeitig oder bei Last auf wenigen Kernen sind sogar 4,2 GHz drin. Und wenn man dann noch die bessere Architektur gegenüber der CPU im T420s mit einbezieht, dann sollte der neue Laptop mindestens ebenbürtig sein. Laut diesem Benchmark-Vergleich: https://cpu.userbenchmark.com/Compar.../m353957vsm643 ist die neuere CPU in allen Tests mindestens 40% schneller, in einzelnen bis zu 200%. Das müsste merkbar sein

    Zitat Zitat von gestern Beitrag anzeigen
    dann ist ja schon mal die häfte der geschwindigkeit des PCI bus weg die NVME hängt da auch daran.
    Was willst du uns damit sagen? Bzw. worauf beziehst du das?


    Zitat Zitat von gestern Beitrag anzeigen
    genau so vereinfacht und genauso inkorrekt da ja faslt alle i7 gedrosselt werden, in den: "ach so sexy wirkenden gehäuse", weil man die währme nicht wegbekommt dazu kommt noch ob und wie viele kerne die software braucht und ob mit oder ohne HT.
    Ja, jede CPU wird heutzutage in der Regel durch Dinge wie maximalen Strom, maximale TDP, maximale Temperatur oder ähnliches gedrosselt. Deswegen ja auch teilweise unterschiedliche Benchmark-Ergebnisse von gleichen CPUs, je nachdem, auf welchem Mainboard mit welchen Einstellungen und mit welcher Kühlung sie betrieben werden. Das ändert aber nichts daran, dass die Dinger echt flott sind.

    Zitat Zitat von gestern Beitrag anzeigen
    ich denke 2 kerne mit HT von der software genutzt, sind schneller als 4 kerne ohne HT mit weniger takt.
    Siehe oben, die maximalen Taktraten und die Benchmark-Ergebnisse sagen etwas anderes.
    Zitat Zitat von gestern Beitrag anzeigen
    kann sein das ich mich irre sind einfach praktische erfahrungen.
    Ja, du irrst dich



    Zum Thema: Da in meinem T480s mit dem i7-8550U eine recht ähnliche CPU sitzt und auch eine flotte NVMe-SSD verbaut ist, habe ich auch mal AS SSD angeschmissen:


    Das mal zum Vergleich - jetzt ist interessant, was feklee da so für Werte bekommt. Dann kann man schauen, ob es am Datenträger oder an was anderem liegt.
    T500 W520 T500, T480s: i7-8550U, 16GB, 1TB 970 Pro, MX150, PC: Asus Z97-A, i7-5775C@4,1GHz, 16GB 2400, 1TB SSD Homesrv: 32,5/24,5TB brt/net, Supermicro X11SSH-CTF, Xeon E3-1240v6, 32GB, SSD, LTO: 3x LTO (5&6), 125TB, Srv: einige Supermicro PDSML-LN2+, Xeon 3220, 8GB

  15. #15
    Avatar von feklee
    Registriert seit
    22.03.2013
    Ort
    Baden-Baden
    Beiträge
    257
    Danke
    31
    Thanked 3 Times in 3 Posts
    Themenstarter
    So, hier die Benchmarks mit AS SSD, zunächst für das X1 Tablet 3 (Win10 x64 Pro):

    X1_Tablet_3.png

    Dann für das T420s (Win7x64 Pro):

    T420s.png

    Soweit, so gut. Ich habe dann noch meine eigenen Tests gemacht, und beim Kopieren vieler kleiner Dateien (33.633 Dateien mit Gesamtgröße 3,44 GB) war das T420s etwa dreimal so schnell wie das X1 Tablet. Habe dann noch einmal die Einstellungen für den Defender Anti Virus geprüft, denn den hatte ich ja vor ein paar Tagen ausgemacht. Doch die Real-Time-Protection war an! Da hatte ich das Kleingedruckte nicht gelesen: "You can turn off this setting for a short time before it turns back on automatically."

    Schließlich habe ich über die "Local Group Policy" den Defender Anti Virus komplett deaktiviert: Turn off Windows Defender Antivirus = Enabled

    Der erneute Kopiertest nach dem Neustart war schließlich wie erhofft: Das X1 Tablet ist deutlich schneller als das T420s.

    Was bleibt ist ein Performance-Vorteil für das T420s wenn man sich die Eigenschaften des Test-Verzeichnisses mit den kleinen Dateien anzeigen lässt. Hier hat das T420s sofort ein Ergenis parat, während das X1 Tablet ein paar Sekunden braucht.

  16. #16

    Registriert seit
    25.04.2009
    Ort
    Oldenburg
    Beiträge
    1.048
    Danke
    117
    Thanked 76 Times in 69 Posts
    Kann es sein, dass beim T420s die Dateien bereits indiziert sind, während das X1 das noch nicht getan hat?
    Thinkpad L430 @Windows 8.1
    Thinkpad X230 @Linux
    Thinkpad X1 Tablet @Windows 10

  17. #17
    Avatar von feklee
    Registriert seit
    22.03.2013
    Ort
    Baden-Baden
    Beiträge
    257
    Danke
    31
    Thanked 3 Times in 3 Posts
    Themenstarter
    Zitat Zitat von Aiphaton Beitrag anzeigen
    Kann es sein, dass beim T420s die Dateien bereits indiziert sind, während das X1 das noch nicht getan hat?
    Dachte ich auch. Ich habe den Index dann ausgemacht und das kopierte Verzeichnis umbenannt, ohne dass sich was geändert hat. Allerdings habe ich nicht neu gestartet. Werde das nochmal testen.

    - - - Beitrag zusammengeführt - - -

    OK, also erneuter Test, und das X1 Tablet ist immer noch langsamer beim Anzeigen der Eigenschaften eines Verzeichnisses, also der Anzahl der Dateien und der Größe, zum Test: 169 GB, 283.074 Dateien, 10.997 Verzeichnisse

    In diesem Fall braucht Windows 10 auf dem Tablet etwa zwölf Sekunden. Windows 7 auf dem T420s hat das Ergebnis in drei Sekunden.

    Index-Einstellungen auf dem X1 Tablet / Windows 10 (Index jeweils neu gebaut):

    X1-Tablet-3-indexing-options.png

    Und auf dem T420s / Windows 7:

    T420s-indexing-options.png

    Wie man an der Anzahl der indizierten Dateien sieht, umfasst der Index nicht das oben erwähnte Testverzeichnis.
    Geändert von feklee (01.02.2019 um 09:58 Uhr)

  18. #18
    Avatar von feklee
    Registriert seit
    22.03.2013
    Ort
    Baden-Baden
    Beiträge
    257
    Danke
    31
    Thanked 3 Times in 3 Posts
    Themenstarter
    Das Problem besteht weiterhin: Windows 10 Pro x64 ist auf deutlich schnellerer Hardware viermal langsamer beim Erstellen der Eigenschaften eines großen Testverzeichnisses als Windows 7 Pro x64.

    Obwohl ich den Index für das Verzeichnis bereits deaktiviert habe, habe ich nun auch noch das Windows-Search-Feature in Windows 7 deaktiviert und anschließend natürlich neu gestartet:

    windows-search.png

    Unter Windows 10 ist der Defender nach wie vor ausgeschaltet:

    defender.png

    Woran kann's noch liegen?

    - - - Beitrag zusammengeführt - - -

    Habe jetzt auch noch einen Test mit PowerShell gemacht:
    Code:
    Measure-Command { (get-childitem Verzeichnis -recurse | measure-object -property length -sum).sum/1GB }
    Hier braucht Windows 10 auf dem X1 Tablet 14 Sekunden, und Windows 7 auf dem T420s mehr als eine Minute. Das ist eher plausibel.

    Kann es sein, dass Windows 7 außerhalb der Indizierung noch einen Cache pflegt?

Ähnliche Themen

  1. Tablet 10 1. Gen Tablet 10 1. Gen ThinkPad Tablet 10 (1st Gen) Bildschirm Rotation funktioniert nicht
    Von brazos surfat im Forum ThinkPad Tablet
    Antworten: 10
    Letzter Beitrag: 09.08.2017, 19:32
  2. T440p T440p schlechte Audio Performance unter Windows 10
    Von Stinkpad im Forum T - Serie
    Antworten: 3
    Letzter Beitrag: 11.04.2016, 18:07
  3. Antworten: 1
    Letzter Beitrag: 02.03.2016, 06:41
  4. T400s Fragen zur System Performance unter Windows 7
    Von bauernsohn im Forum T - Serie
    Antworten: 14
    Letzter Beitrag: 25.05.2010, 18:19
  5. X2x - miese Compactflash-Performance?
    Von schrank21 im Forum X - Serie (inkl. Tablet)
    Antworten: 6
    Letzter Beitrag: 08.05.2008, 00:57

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
CeCon ok1.de ipWeb Campus Shop CaptainNotebook RO Electronic