luxnote lapstore servion thinkspot
Ergebnis 1 bis 16 von 16

Thema: Debian auf T440s - Videos laufen nicht vernünftig

  1. #1

    Registriert seit
    18.03.2009
    Beiträge
    703
    Danke
    25
    Thanked 38 Times in 37 Posts

    Debian auf T440s - Videos laufen nicht vernünftig

    Hola, leider laufen alle Videos sehr hackelig und mit "Versatz", das tritt sowohl unter Gnome als auch xfc auf.

    Getestet habe ich Firefox, VLC und den voreingestellten Videoplayer. Siehe Screenshots eines SD-YoutubeVideos.

    Gibt es ein Linux/ X-Oberfläche wo das besser funktioniert so leider unbrauchbar....

    Oder brauche ich einen neuen Thinkpad ?

    PS: Unter PureOS das auf DebianTesting basiert ist es noch schlimmer.

    Gruß

    mcb
    Angehängte Grafiken Angehängte Grafiken
    Geändert von mcb (31.07.2018 um 18:36 Uhr)
    T440s - no camera, no microphone,Trackpad with 3 buttons, ChiMei/Innolux FHD , Win64, Linux

  2. #2

    Registriert seit
    15.09.2012
    Beiträge
    1.166
    Danke
    12
    Thanked 30 Times in 29 Posts
    Was du da siehst ist Tearing und tritt auf, wenn das Video ohne vsync dargestellt wird. Helfen kann hier ein Compositor oder eine entsprechende Funktion im Grafiktreiber (modesetting kann das noch nicht, Intel Treiber möchtest du vermutlich nicht. Eventuell hat XFCE bereits einen Compositor, den du entsprechend konfigurieren kannst. Ansonsten ggf. deaktivieren und z.B. Compton nehmen. Hat viele Einstellungen, musst du mal ausprobieren (die man page ist sehr gut).

  3. #3

    Registriert seit
    18.03.2009
    Beiträge
    703
    Danke
    25
    Thanked 38 Times in 37 Posts
    Themenstarter
    Zitat Zitat von SammysHP Beitrag anzeigen
    Was du da siehst ist Tearing und tritt auf, wenn das Video ohne vsync dargestellt wird. Helfen kann hier ein Compositor oder eine entsprechende Funktion im Grafiktreiber (modesetting kann das noch nicht, Intel Treiber möchtest du vermutlich nicht. Eventuell hat XFCE bereits einen Compositor, den du entsprechend konfigurieren kannst. Ansonsten ggf. deaktivieren und z.B. Compton nehmen. Hat viele Einstellungen, musst du mal ausprobieren (die man page ist sehr gut).
    Ja Danke,

    IntelTreiber habe ich gesucht, aber nur die Info gefunden das die automatisch eingebaut sind

    Compositor?
    Compton
    https://packages.debian.org/sid/compton

    Ist das gemeint?
    T440s - no camera, no microphone,Trackpad with 3 buttons, ChiMei/Innolux FHD , Win64, Linux

  4. #4

    Registriert seit
    28.11.2007
    Beiträge
    1.523
    Danke
    1
    Thanked 32 Times in 31 Posts
    Unter XFCE ist die gesuchte VSYNC-Einstellung wie folgt zu finden:

    Anwendungsmenü bzw. Whiskermenü -> Einstellungen -> Einstellungsbearbeitung

    Dort dann unter Kanal(linke Spalte) zu xfwm4 wechseln und dort die Eigenschaft "sync_to_vblank" auf true setzen (einfach den Haken setzen). Ich glaube danach musst du dich nochmal abmelden/neustarten damit das zieht, bin mir aber nicht sicher.
    ThinkPad X41: Pentium M 1,5GHz, 2GB, 8GB CF-SSD, Debian Stretch
    ThinkCentre M58P SFF: Core2Quad Q9650, 12GB, Crucial M4, Debian Stretch

  5. #5

    Registriert seit
    24.02.2018
    Beiträge
    9
    Danke
    0
    Thanked 0 Times in 0 Posts
    Zusätzlich kann man noch folgendes machen (Hat bei mir das Youtube Tearing etc. komplett entfernt):
    Code:
    mkdir  /etc/X11/xorg.conf.d/
    Code:
    sudo nano /etc/X11/xorg.conf.d/20-intel.conf
    .conf mit diesem Inhalt füllen

    Code:
    Section "Device"
        Identifier "Intel Graphics"
        Driver "intel"
        Option "TearFree" "true"
    EndSection
    Dann auch einmal ausloggen/einloggen.
    Geändert von evidence (31.07.2018 um 22:08 Uhr)

  6. #6

    Registriert seit
    15.09.2012
    Beiträge
    1.166
    Danke
    12
    Thanked 30 Times in 29 Posts
    @evidence
    Das erfordert den Intel Treiber, der seit einiger Zeit nicht mehr automatisch installiert wird und von vielen auch nicht mehr empfohlen wird, da es seit etlichen Jahren keinen Release mehr gab.

  7. #7

    Registriert seit
    24.02.2018
    Beiträge
    9
    Danke
    0
    Thanked 0 Times in 0 Posts
    Ich war mir dessen nicht bewusst, dass es sogar empfohlen wird, den Intel Treiber zu deinstallieren. Ich habe es eben selber mal getestet.

    Vielleicht ist es ja für den ein oder Anderen noch nützlich (SammysHP hat es im zweiten Post schon treffend beschrieben, aber hier nochmal etwas detaillierter):

    Ich habe das Paket "xserver-xorg-video-intel" deinstalliert und die Config aus meinem vohrigem Post gelöscht. Nach einem Neustart hat man dann wieder massives Tearing, da dann der "modesetting Treiber genutzt wird. Unter XFCE kann man das Problem wie folgt beheben:

    1. Paket "compton" installieren
    2. Unter Einstellungen/Feineinstellungen der Fensterverwaltung/Komposit --> Haken bei Anzeigekomposit aktivieren raus nehmen
    3. Compton mit folgenden Einstellungen starten: "compton -bCG --backend glx --glx-no-stencil --vsync opengl" bzw. zusätzlich entsprechenden Eintrag unter "Sitzung und Startverhalten" vornehmen.

    Mit diesen Einstellungen habe ich kein Tearing (Youtube, VLC, mpv, etc.).
    Geändert von evidence (03.08.2018 um 12:28 Uhr)

  8. #8

    Registriert seit
    15.09.2012
    Beiträge
    1.166
    Danke
    12
    Thanked 30 Times in 29 Posts
    Wobei man die Parameter noch deutlich optimieren kann und damit mehr Performance erhält. Das muss man aber an die jeweilige Grafikkarte anpassen.

  9. #9

    Registriert seit
    18.03.2009
    Beiträge
    703
    Danke
    25
    Thanked 38 Times in 37 Posts
    Themenstarter
    Zitat Zitat von evidence Beitrag anzeigen
    Ich war mir dessen nicht bewusst, dass es sogar empfohlen wird, den Intel Treiber zu deinstallieren. Ich habe es eben selber mal getestet.

    Vielleicht ist es ja für den ein oder Anderen noch nützlich (SammysHP hat es im zweiten Post schon treffend beschrieben, aber hier nochmal etwas detaillierter):

    Ich habe das Paket "xserver-xorg-video-intel" deinstalliert und die Config aus meinem vohrigem Post gelöscht. Nach einem Neustart hat man dann wieder massives Tearing, da dann der "modesetting Treiber genutzt wird. Unter XFCE kann man das Problem wie folgt beheben:

    1. Paket "compton" installieren
    2. Unter Einstellungen/Feineinstellungen der Fensterverwaltung/Komposit --> Haken bei Anzeigekomposit aktivieren raus nehmen
    3. Compton mit folgenden Einstellungen starten: "compton -bCG --backend glx --glx-no-stencil --vsync opengl" bzw. zusätzlich entsprechenden Eintrag unter "Sitzung und Startverhalten" vornehmen.

    Mit diesen Einstellungen habe ich kein Tearing (Youtube, VLC, mpv, etc.).
    3. Schaffe ich schon nicht mehr

    Hilfe erbeten

    Danke

    mcb
    T440s - no camera, no microphone,Trackpad with 3 buttons, ChiMei/Innolux FHD , Win64, Linux

  10. #10

    Registriert seit
    28.11.2007
    Beiträge
    1.523
    Danke
    1
    Thanked 32 Times in 31 Posts
    Hast du meinen Tipp aus Beitrag 4 schon getestet?
    ThinkPad X41: Pentium M 1,5GHz, 2GB, 8GB CF-SSD, Debian Stretch
    ThinkCentre M58P SFF: Core2Quad Q9650, 12GB, Crucial M4, Debian Stretch

  11. #11

    Registriert seit
    14.06.2013
    Beiträge
    908
    Danke
    1
    Thanked 40 Times in 36 Posts
    Zitat Zitat von SammysHP Beitrag anzeigen
    @evidence
    Das erfordert den Intel Treiber, der seit einiger Zeit nicht mehr automatisch installiert wird und von vielen auch nicht mehr empfohlen wird, da es seit etlichen Jahren keinen Release mehr gab.
    Wie? Welcher Treiber denn sonst auf intel-Hardware? Der intel-xorg-Treiber ist doch nur eine relativ dünne Hülle um den intel Kernel-Treiber. Verwechselst Du eventuell "intel" mit "i810"? Letzterer ist in der Tat obsolet.

  12. #12

    Registriert seit
    15.09.2012
    Beiträge
    1.166
    Danke
    12
    Thanked 30 Times in 29 Posts
    Genau, ich meine den xf86-video-intel/xorg Treiber: https://gitlab.freedesktop.org/xorg/...86-video-intel
    Als eine dünne Hülle würde ich den nicht unbedingt bezeichnen.

  13. #13

    Registriert seit
    19.11.2008
    Beiträge
    542
    Danke
    2
    Thanked 6 Times in 6 Posts
    Oder aber, falls du flexibel bei der Distribution bist, einfach das aktuelle Ubuntu mit Gnome (Standarddesktop) installieren.

    Da läufts smooth ohne editieren von Configdateien Out of The Box...
    Aktuell: Yoga 370 - Yoga 260 - X61s
    (Historie:Helix 2 - T530 - T520 - Thinkpad 8 - X220T - T400 - X200 - X1 - W700 - W520 - X200T Outdoor - T400s - T500 - X61T SXGA+/XGA)

  14. #14

    Registriert seit
    18.03.2009
    Beiträge
    703
    Danke
    25
    Thanked 38 Times in 37 Posts
    Themenstarter
    Zitat Zitat von kristatos Beitrag anzeigen
    Hast du meinen Tipp aus Beitrag 4 schon getestet?
    Nein, aber vielen Dank - geht das auch mit einem Live-USB Stick?

    - - - Beitrag zusammengeführt - - -

    Zitat Zitat von pispot Beitrag anzeigen
    Oder aber, falls du flexibel bei der Distribution bist, einfach das aktuelle Ubuntu mit Gnome (Standarddesktop) installieren.

    Da läufts smooth ohne editieren von Configdateien Out of The Box...
    Ja ich bin da "flexibel" - Wichtig ist halt Dualboot Bitlocker & Linux verschlüsselt (nicht nur die Benutzerdaten) - unter Ubuntu hat das mit dem Tastenlosen Touchpad nicht hingehauen - das habe ich ja inzwischen ausgetauscht !

    Aber die Einrichtung von Linux bereitet mir wirklich Probleme ...

    Ich "benötige"

    125% Skalierung auf dem FullHD 14"
    TLP
    Grub2 als nur Text Bootmenü
    LUKS
    "ruckelfreie" Videos


    Das ist schon schwer trotz Hilfe aus dem Forum ...

    Gruß
    Geändert von mcb (09.08.2018 um 16:51 Uhr)
    T440s - no camera, no microphone,Trackpad with 3 buttons, ChiMei/Innolux FHD , Win64, Linux

  15. #15

    Registriert seit
    19.11.2008
    Beiträge
    542
    Danke
    2
    Thanked 6 Times in 6 Posts
    Gnome kann wohl meines Wissens nicht frei skalieren (nur doppelte DPI)
    Kubuntu 18.04 mit KDE kann zwar frei skalieren, aber da hatte ich beim testen auch tearing Effekte trotz diverser Einstellungsversuche.
    Aktuell: Yoga 370 - Yoga 260 - X61s
    (Historie:Helix 2 - T530 - T520 - Thinkpad 8 - X220T - T400 - X200 - X1 - W700 - W520 - X200T Outdoor - T400s - T500 - X61T SXGA+/XGA)

  16. #16

    Registriert seit
    24.02.2018
    Beiträge
    9
    Danke
    0
    Thanked 0 Times in 0 Posts
    Du kannst doch deine Anforderungen mit Debian + XFCE locker erreichen! (Würde ich ja erst mal versuchen, bevor du den Aufwand betreibst und eine ganz neue Distro. installierst). DPI lässt sich auch leicht in den Einstellungen anpassen.

    Zu deinem Video Ruckler Problem:
    Du hast ja scheinbar meine Anleitung befolgt. Bei Punkt 3. öffnest du ein Terminal und führst diesen Befehl aus "compton -bCG --backend glx --glx-no-stencil --vsync opengl". Dann sollten Videos ruckelfrei laufen! Klappt das bei dir?

Ähnliche Themen

  1. T6x YouTube-Videos laufen nicht flüssig (Firefox; Intel X3100)
    Von 9Johannes8s im Forum T - Serie
    Antworten: 8
    Letzter Beitrag: 18.03.2016, 18:46
  2. Antworten: 11
    Letzter Beitrag: 08.01.2013, 21:51
  3. T6x Videos laufen nicht flüssig im Vollbild
    Von hangout im Forum T - Serie
    Antworten: 6
    Letzter Beitrag: 01.09.2012, 17:20
  4. Hat einer von euch Proftpd auf Debian laufen (mit SQL)?
    Von kangaroo72 im Forum Was sonst nicht passt
    Antworten: 6
    Letzter Beitrag: 10.06.2011, 21:16
  5. Antworten: 42
    Letzter Beitrag: 19.05.2010, 10:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
CeCon ok1.de ipWeb Campus Shop CaptainNotebook gbyte - Drupal Webentwicklung