luxnote lapstore servion thinkspot
Ergebnis 1 bis 9 von 9

Thema: X260 HD-IPS Display in X250 verbaut - keine Helligkeitsregelung möglich?

  1. #1

    Registriert seit
    19.09.2006
    Ort
    Österreich / Kärnten
    Beiträge
    967
    Danke
    74
    Thanked 40 Times in 37 Posts

    X260 HD-IPS Display in X250 verbaut - keine Helligkeitsregelung möglich?

    Ich hatte wegen Aufrüstung eines X260 auf FHD-IPS das HD-IPS Display über und verpflanzte dieses sinnvollerweise ein in X250 mit HD-TN-Panel.

    Alles läuft soweit, jedoch funktioniert die Helligkeitsregelung am Display nicht. Das ist freilich keine Dauerlösung. So hoffe ich, dass ihr mir weiterhelfen könnt. An sich sollten die Panels untereinander ja kompatibel sein...

    Die Daten des HD-IPS Panels findet ihr im Anhang. Es handelt sich um ein LG LP125WH2-SPT2. Ich habe beim X250 folgendes versucht:

    - BIOS Update
    - Intel HD 5500 Treiberupdate
    - aktuellste *.inf Displaytreiber vom X260 importiert

    Es ist aktuell Windows 10 1709 mit den letzten Updates installiert. Die Helligkeitsregelung funzt nach wie vor nicht, das Display blendet ausschließlich mit maximaler Helligkeit.

    Hat jemand eine Lösung?

    Display.jpg
    @ work: Yoga I, i5, FHD IPS, 256GB SSD, 8GB
    @ home: P70, Xeon E3-1505 v5, 4K IPS, 2x512 SSD, 32GB, M5000M
    @ Frau: T460, i5, FHD IPS, 500GB SSD, 16GB

  2. #2

    Registriert seit
    19.09.2006
    Ort
    Österreich / Kärnten
    Beiträge
    967
    Danke
    74
    Thanked 40 Times in 37 Posts
    Themenstarter
    Hat niemand eine Idee? Wieder das HD-TN rein?
    @ work: Yoga I, i5, FHD IPS, 256GB SSD, 8GB
    @ home: P70, Xeon E3-1505 v5, 4K IPS, 2x512 SSD, 32GB, M5000M
    @ Frau: T460, i5, FHD IPS, 500GB SSD, 16GB

  3. #3

    Registriert seit
    01.12.2017
    Beiträge
    11
    Danke
    1
    Thanked 1 Time in 1 Post
    Also so eine richtige Antwort kann ich dir leider auch nicht geben. Ich hatte damals bei dem Wechsel von TN-HD auf FHD-IPS bei einem X240 bei mehreren Leuten von dem Problem gelesen, dass die Helligkeitsregelung nach dem Wechsel auf manchen Displays mit bestimmten FRUs dieses Verhalten zeigen - allerdings immer nur unter Windows. Unter Linux soll das wohl alles kein Problem sein, was dafür spricht, dass es irgendein Treiber-Problem ist.
    Allem, was ich bis dahin gelesen hatte war, dass es zwar Tools gibt, mit denen man die Helligkeit manuell regeln kann, dann aber nicht die Hintergrundbeleuchtung geregelt wird, sondern ein Filter über das Bild gelegt wird, der das Bild verdunkelt. Für die Akkulaufzeit ist das natürlich nicht gut.

    Vielleicht kennt ja doch jemand eine Lösung dafür, ich bin aber vorsichtig pessimistisch. Unter Linux laufen auch ganz andere Panels, siehe den Umbau eines x240 durch Jajobus.

  4. #4

    Registriert seit
    24.06.2009
    Beiträge
    420
    Danke
    15
    Thanked 6 Times in 5 Posts
    Hier ab 31:05 wird es erklärt: https://www.youtube.com/watch?v=bsC5lAqkB6Y

    Es liegt wohl am Video-BIOS, welches eine Whitelist hat. Unter Windows beachtet der Intel-Treiber diese Whitelist und deshalb kann die Helligkeit nicht eingestellt werden. So wie es aussieht, muss die EDID des Displays geflashed werden, aber wie das genau geht, übersteigt auch mein Wissen.
    IBM ThinkPad Series: Notebooks, die funktionieren!
    X240, T500 (WUXGA Glare), X200 (IPS Mod), T60 (Flexview SXGA+)

  5. #5

    Registriert seit
    03.12.2013
    Beiträge
    465
    Danke
    27
    Thanked 62 Times in 54 Posts
    Es scheint auch ohne EDID-Flash zu gehen:

    https://forum.thinkpads.com/viewtopic.php?f=69&t=125055

    Ansonsten ist es eigentlich nicht so schwierig, die EDID zu verändern. Die Kommunikation läuft über i2c, das geht mit nem Arduino o.ä. recht simpel. Vorzugsweise mit einem 3,3V Modell. Man muss aber erstmal die EDID von einem funktuonierenden Bildschirm mit gleicher Auflösung haben. Und man muss den Schreibschutz-Pin vom EDID Speicherbaustein ablöten und anheben oder abknipsen.
    T61 8898-6CG T70 14" 1st Batch 7700HQ, X62s 3rd batch mit Kühlermod: Work in Progress.

  6. #6
    Avatar von L0nestar
    Registriert seit
    27.01.2011
    Ort
    Bonn
    Beiträge
    1.394
    Danke
    271
    Thanked 82 Times in 66 Posts
    Hast du es mal mit einem Live-Linux oder so probiert? Nicht, dass es sich nur um eine ärgerliche Treibergeschichte handelt...
    ...schon mal ins Thinkwiki geschaut?
    Mitmachen lohnt sich.

  7. #7

    Registriert seit
    13.10.2012
    Beiträge
    1.095
    Danke
    4
    Thanked 40 Times in 39 Posts
    live linux ist eine gute idee , allerdings nicht um ein treiberproblem aus zu schliessen sondern um eine hardware funktion zu testen . live linux sollte die EDID schlicht ignorieren. auf jedenfall bei "älteren" versionen bei aktuellen weiss ich es nicht. wenn nicht sollte es sich aber zumindest einstellen lassen das er es ignoriert nach dem boot.

  8. #8

    Registriert seit
    07.09.2010
    Ort
    Berlin
    Beiträge
    3.327
    Danke
    5
    Thanked 119 Times in 113 Posts
    Zitat Zitat von NonesensE Beitrag anzeigen
    Ansonsten ist es eigentlich nicht so schwierig, die EDID zu verändern. Die Kommunikation läuft über i2c, das geht mit nem Arduino o.ä. recht simpel. Vorzugsweise mit einem 3,3V Modell. Man muss aber erstmal die EDID von einem funktuonierenden Bildschirm mit gleicher Auflösung haben. Und man muss den Schreibschutz-Pin vom EDID Speicherbaustein ablöten und anheben oder abknipsen.
    IMHO geht das EDID umschreiben auch mit dem Notebook selbst, ohne dass man einen Arduino an die Pins fummeln muss. Frueher (tm) waren das EEPROM auch nicht schreibgeschuetzt. Dazu sollte es alte Threads hier im Forum geben (Stichworte: T60 UXGA Panel EDID).
    BTW, der TE hat ein funktionierendes Panel, das HD-TN. Ich weiss aber nicht, ob man einfach so das EDID davon uebernehmen kann, da stehen AFAIK auch Timings drin.

  9. #9

    Registriert seit
    19.09.2006
    Ort
    Österreich / Kärnten
    Beiträge
    967
    Danke
    74
    Thanked 40 Times in 37 Posts
    Themenstarter
    Vielen Dank für eure umfangreichen Rückmeldungen.

    Ich habe soeben testweise Ubuntu vom USB-Stick gebootet und siehe da, die Helligkeitsregelung funktioniert tatsächlich. Es wird - wie "gestern" geschrieben hat, wohl tatsächlich am EDID liegen. Linux dürfte dieses allem Anschein nach ignorieren. Im BIOS funktioniert die Helligkeitsregelung nämlich auch nicht.

    Bevor ich hier Risiken mit EDID-Flashen oder dergleichen eingehe, tendiere ich eher dazu, dem X250 auch ein FHD-IPS Panel zu verpassen. Natürlich bin ich für brauchbare (risikofreie) Alternativen auch dankbar. Ich nehme mal an, dass Windows über den Intel-Grafikkartentreiber mit dem Display / EDID kommuniziert, korrekt? Oder geschieht dies über Windows direkt? Eine Softwarelösung wäre mir jedenfalls die Zufriedenstellendste.
    Geändert von XStoneX (14.02.2018 um 15:30 Uhr)
    @ work: Yoga I, i5, FHD IPS, 256GB SSD, 8GB
    @ home: P70, Xeon E3-1505 v5, 4K IPS, 2x512 SSD, 32GB, M5000M
    @ Frau: T460, i5, FHD IPS, 500GB SSD, 16GB

Ähnliche Themen

  1. Antworten: 17
    Letzter Beitrag: 08.12.2017, 18:09
  2. Verkauft Für X240/X250/X260: Display LG 12.5" HD IPS (FRU 00HN839)
    Von Maverick75 im Forum Biete ThinkPads und Zubehör
    Antworten: 8
    Letzter Beitrag: 08.07.2017, 11:46
  3. Antworten: 16
    Letzter Beitrag: 04.06.2017, 21:18
  4. Erledigt ThinkPad x240 / x250 / x260 mit FHD Display
    Von Timestheus im Forum Suche
    Antworten: 0
    Letzter Beitrag: 27.05.2017, 14:17
  5. Verkauft Lp125wf2 spb2 (x240/x250/x260 fhd ips) 80€
    Von Akira im Forum Biete ThinkPads und Zubehör
    Antworten: 17
    Letzter Beitrag: 03.08.2016, 23:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
CeCon ok1.de ipWeb Campus Shop CaptainNotebook gbyte - Drupal Webentwicklung