luxnote lapstore servion thinkspot
Seite 22 von 22 ErsteErste ... 12202122
Ergebnis 421 bis 433 von 433

Thema: Haswell ThinkPads - ClickPad mit TrackPoint-Tasten verbaubar!

  1. #421

    Registriert seit
    18.03.2009
    Beiträge
    3.442
    Danke
    70
    Thanked 256 Times in 246 Posts
    Wenn "n10gx25w" nicht funktioniert ist es kein Synaptics (den braucht man auch nicht patchen). Ev. schon installierte vorher deinstallieren.

    Windows 10 haut aber gut dazwischen, das letzte mal mußte in den gepatchten Treiber vom T450s öfters installieren / deinstallieren
    T490s Debian (Bullseye) https://www.debian.org/

  2. #422

    Registriert seit
    08.01.2014
    Beiträge
    11
    Danke
    0
    Thanked 0 Times in 0 Posts
    Edit 2: Leider friert der unten genannte Treiber für das Touchpad immer wieder ein, das Touchpad reagiert dann nicht mehr, nur ein Neustart hilft. Deswegen habe ich ihn jetzt wieder deinstalliert und bin mit dem Standardtreiber von Windows unterwegs

    Werde jetzt erstmal keine Zeit mehr in das Thema investieren. Falls jemand für sein ALPS Touchpad unter Windows 10 einen passenden Treiber findet, freue ich mich über eine kurze Rückmeldung.

    ---------------------------------------

    Edit: Ich habe es doch nochmal versucht:

    Es ist wohl kein Synaptics Touchpad, sonders eins von Alps. Ich weiß zwar nicht wie es auf der Rückseite aussieht, da es schon eingebaut ist, aber auf den Fotos vom Händler in der Bucht hat es eine glatte Oberfläche, was wohl für Alps spricht.

    Folgendes hat nun bei mir funktioniert:
    - Treiber [1] runterladen und entpacken.
    - Über den Geräte-Manager: "Treiber aktualisieren" -> auf dem Computer suchen -> Aus einer Liste verfügbarer Treiber ... -> Datenträger
    - Dann die Inf-Datei auswählen, die man vom Treiber [1] entpackt hat.

    Kein Patch o.ä. notwendig. Nur bei Windows Updates habe ich noch Updates für die Treiber deaktiviert. Mal sehen ob es hält.

    Danke für eure Hilfe!

    [1] https://support.lenovo.com/pl/en/downloads/ds101993
    Geändert von Leuli (16.04.2020 um 17:11 Uhr)

  3. #423

    Registriert seit
    30.09.2016
    Ort
    Zwischen München und Augsburg
    Beiträge
    52
    Danke
    3
    Thanked 6 Times in 6 Posts
    Ich hab's auch geschafft, für das hier im Forum erstandene W540 ein Synaptics Touchpad über ebay in China bestellt (knapp zwei Wochen Lieferzeit, trotz Corona) und gleich eingebaut - ein Traum...

    Ohne die Tipps und Tricks hier hätte ich das gar nicht versucht - danke an alle

    Gruß, Helmut

  4. #424

    Registriert seit
    22.12.2017
    Beiträge
    54
    Danke
    21
    Thanked 7 Times in 6 Posts
    Hat einer zufällig die Teile Nummer des Flex Kabels vom Trackpad? Bräuchte das für ein T440s.

    EDIT: DA30000CX10 SC10F45230

    Gleich mehrere gefunden, die Kompatibel sein sollten: DA30000DK10 DA30000ER10 DA30000EQ10 SC10G47134 SC10H22831
    Geändert von lgp (15.07.2020 um 11:15 Uhr)

  5. #425

    Registriert seit
    19.01.2013
    Beiträge
    20
    Danke
    0
    Thanked 0 Times in 0 Posts
    hallo,
    habe in meinen x240 das drei-Tasten Trackpad eingebaut, und das lief bisher wunderbar unter Windows 10.
    Nach einem Funktionsupdate für Version 1903 zickt jetzt sowohl Tastatur als auch Trackpad, beides wird nicht erkannt.
    Weder das automatische update mit lenovo vantage noch manuelle Installation des navtech Treibers führen dazu, das der Fehler behoben wird.
    Was kann ich machen? hat jemand einen X240 mit getauschtem trackpad mit neuester Windows Version (gar 2004) am laufen?
    gruss

  6. #426
    Avatar von BerndN100
    Registriert seit
    16.02.2008
    Ort
    Hauptstadt
    Beiträge
    258
    Danke
    12
    Thanked 7 Times in 5 Posts
    Die erste, entscheidende Frage wird erstmal sein.......... welches TP ist es denn?
    IBM Lenovo Thinkpad T540p, 15,6"3K, Windows 10pro/64
    IBM Lenovo 3000 N100
    , 15,4" Windows 10/32
    IBM Thinkpad SL 510, 15,6" Windows 10/64

  7. #427

    Registriert seit
    04.12.2014
    Beiträge
    1.101
    Danke
    106
    Thanked 134 Times in 125 Posts
    Brille verlegt? Der Fragesteller hat es doch erwähnt, zweimal sogar: x240.


  8. #428
    Avatar von BerndN100
    Registriert seit
    16.02.2008
    Ort
    Hauptstadt
    Beiträge
    258
    Danke
    12
    Thanked 7 Times in 5 Posts
    1. Bin kein Brillenträger
    2. TP = Touchpad

    und bevor die Klugsch..... wieder was zu bemängeln haben, ja- mein Fehler, die Abkürzung ist mehr
    als zweideutig!
    Geändert von BerndN100 (10.08.2020 um 01:29 Uhr)
    IBM Lenovo Thinkpad T540p, 15,6"3K, Windows 10pro/64
    IBM Lenovo 3000 N100
    , 15,4" Windows 10/32
    IBM Thinkpad SL 510, 15,6" Windows 10/64

  9. #429

    Registriert seit
    01.02.2008
    Ort
    Bremen-Borgfeld
    Beiträge
    514
    Danke
    3
    Thanked 3 Times in 3 Posts
    Zitat Zitat von uwe_ Beitrag anzeigen
    hat jemand einen X240 mit getauschtem trackpad mit neuester Windows Version (gar 2004) am laufen?
    Moin!
    Jo, habe bei meinem X240 seinerzeit das originale Trackpad gegen ein Synaptics 3-Tasten-Dings von ebay getauscht, und es läuft ein aktuelles 2004er (19041.423) ohne ersichtlichge Probleme. Allerdings musste ich in der Vergangenheit schon das eine oder andere mal den (ultranav[n10gx25w]) Treiber neu installieren. Lag wohl häufig an meiner damals unbedarften Art mit diesem mittlerweile runtergeschmissenen System Update umzugehen...
    Gruß, peo
    "... try SCE to AUX"

  10. #430

    Registriert seit
    30.03.2010
    Ort
    köln
    Beiträge
    23
    Danke
    3
    Thanked 0 Times in 0 Posts
    Ich habe mein mein ALPS aus der Identischen Ebay-Anzeige bei der Leuli sein Pad gekauft hat.
    Das ALPS hat allerdings keine glatte Rückseite, sondern sieht aus wie ein Synaptics.
    Ich nutze folgenden Treiber https://pcsupport.lenovo.com/de/de/p...loads/ds105378

    Die Installation dann wie gehabt über den Gerätemanager und der entpackten inf.
    Auf Anhieb funktioniert alles unter Win10 2004, mal sehen wie lange :-)
    Geändert von guido.s (18.10.2020 um 10:38 Uhr)

  11. #431

    Registriert seit
    26.08.2020
    Beiträge
    1
    Danke
    0
    Thanked 2 Times in 1 Post
    Hallo, wollte mal kurz mein Feedback zum Umbau beim X240 geben, der dann final doch funktioniert hat.

    Win 10 x64 Pro (alle Updates)
    Synaptics Pad aus der Bucht

    Erster Gedanke: Cool, mein neues Touchpad kam an.
    Nachdem die Kinder dann im Bett waren ging das Gebastel los.

    Das Pad war nach 10 Minuten eingebaut. Ich hatte nach dem Einbau aber direkt mit dem Problem zu kämpfen,
    dass erstmal garnichts funktionierte. Weder das Touchpad noch der Stick oder die 3 Tasten.
    Somit musste ich eine alte USB Maus suchen (30min) :-) Wäre ja auch zu einfach...
    Dann habe ich alles was ich an Synaptics finden konnte erstmal deinstalliert. Zwar haben nach einem Neustart dann
    die 3 Tasten des Touchpads sofort mit dem Standard Windows Treiber funktioniert jedoch blieb das Touchpad selbst tot.
    Schockstarre, mein erster Gedanke war, Flachbandkabel kaputt. Bin damit auch nicht zimperlich umgegangen,
    da mir der Laptoop einmal umgekippt ist als ich das lose aber verbundene Touchpad in der Hand hatte. Wäre ja mal wieder typisch.
    Somit habe ich dann alles wieder auf das Alte umgebaut. Ernüchterung, auch das ging nicht mehr. Misst, Charma ?
    Egal, trotzdem Treiber bei Lenovo runtergeladen, Neustart und siehe da es ging wieder, das Kabel war also heile



    Danach alles wieder umgebaut, alte Treiber gelöscht und Neustart. Dann mit der USB Maus den besagten "n10gx25w" Treiber
    entpacken lassen und manuell im Gerätemanager installiert. Nix, aber auch garnix ausser die 3 Tasten funktionierte.



    OK, nicht so schnell aufgeben. Google, google, google... Modifikation der INF-Datei, deaktivieren der signierten Treiberinstallation ,
    verhindern eines Treiberupdates und und und. Nichts hat was gebracht. Viel probiert und wohl auch viel verschlimmbessert.
    2 Stunden später hab ich irgendwo was von nem Synaptics SM-Bus gelesen, und das es damit Probleme geben kann.
    Hab sowas dann auch tatsächlich in meinem Gerätemanager gefunden. Synaptics SM-Bus oder so. KA warum der nicht deinstalliert wurde,
    oder beim manuellen Treiber update wieder installiert wurde oder von mir installiert wurde oder oder oder. KA..

    Jedenfalls solle man den Treiber mal deinstallieren und das Gerät deaktivieren. Danach Neustart und alles neu Einspielen. Und siehe da, ahaaaa,
    nach einem erneuten Neustart lebt das Touchpad plötzlich. Wenn auch nicht alle Funktionen gegeben waren und es etwas schlecht
    reagierte. Aber ey, es geht. Zufrieden war ich natürlich nicht, mit einem deaktivierten Gerät im System. Hat das Auswirkungen auf
    USB oder etwas anderes? Also weiter googlen.



    Nach etwas Recherche fand ich dann den Hinweis hier mit den Intel Treibern und das es eigentlich ein Intel SM Bus Geschichte ist.
    SM Bus device wieder aktiviert, aktuellen Intel Chipsatz Treiber für das X240 von Lenovo installiert und voilla, jetzt geht alles und es wird
    ein Intel SM Bus Gerät angezeigt ;-)

    Um zu verifizieren hab ich dann die Touchpadtreiber nochmal gelöscht. --> Neustart --> Keine Funktion des Pads mit dem Windows
    Standard Treiber nur die 3 Tasten gingen. --> n10gx25w Treiber manuell eingespiel --> Neustart --> geht.

    Um 1:30 Uhr war Papa dann im Bett.

    Hoffe das hilft vllt. jemandem und rettet eine Nacht.

    Grüße
    eldi

    EDIT:

    Mit dem oben beschriebenen Treiber funkt das Windows Update nicht dazwischen und man nutzt signierte Originaltreiber.
    Mit diesem war das 2 Finger Scrollen aber nicht so gut, da er meine Eingaben des öfteren noch als Scrolling erkannt hat,
    obwohl ich schon fertig war und eine normale Pointer Bewegung ausführen wollte. Es wurde auch immer so ein Balken als Pointer
    eingeblendet der vorher nicht da war.

    Um das zu beheben habe ich auf folgenden Treiber upgedatet. https://download.lenovo.com/pccbbs/mobiles/n1cgr22w.exe
    Das muss aber manuell mit ein paar Anpassungen geschehen.

    SynPD.inf muss modifiziert werden um das X250 Touchpad mit der X240 ID LEN0035 richtig zu nutzen.
    Den runtergeldadenen Treiber dazu NUR entpacken, nicht installieren.
    Folgende Einträge in SynPD.inf sind anzupassen.
    Mit einem Editor nach LEN0035 suchen (es gibt nur 3 Zeilen) und alle 3 Zeilen komplett löschen.
    Dann nach LEN0046 suchen (hier gibt es auch 3 Zeilen) und NUR den Teil mit LEN0046 jeweils 3 mal durch LEN0035 ersetzen.

    Alten Treiber komplett deinstallieren. (externe Maus anschließen)

    Rechner ohne Treibersignatur-Check neu starten. (Touchpad geht dann nicht mehr)
    https://praxistipps.chip.de/windows-...tivieren_39934

    Setup aus dem entpackten Treiberordner ausführen und Meldung der nicht signierten
    Treiber bestätigen (trotzdem installieren). Nicht NEU Starten

    Unbedingt OHNE Neustart Windows Updates für diese Geräte ID blocken.
    https://www.giga.de/downloads/window...-deaktivieren/
    Ich habe es über die Gruppenrichtlinien gemacht. Dazu diese 3 Zeilen einfügen

    *ACPI\VEN_LEN&DEV_0035
    ACPI\LEN0035
    *LEN0035

    Übernehmen und erst jetzt Neustarten.

    Nicht erschrecken, das Touchpad geht danach noch nicht. Wir müssen jetzt den wieder installierten Synaptics SMBUS Treiber
    im Gerätemanager unter Systemgeräte auf den Intel SMBUS umstellen. Ich glaube bei mir hat das Touchpad dann sofort ohne Neustart
    funktioniert, aber sicherheitshalber einmal Neustarten.

    So funktioniert das Touchpad bei mir ohne Einschränkungen mit den neuen Treiber.
    Geändert von eldi0s (19.01.2021 um 12:08 Uhr)

  12. Die folgenden 2 Mitglieder haben sich bei eldi0s bedankt:
    + Ozoign oder Verstecka der Dankenden
    Domski,  
  13. #432

    Registriert seit
    24.07.2009
    Ort
    Münster
    Beiträge
    350
    Danke
    3
    Thanked 6 Times in 5 Posts
    Lieber eldi,
    Ganz ganz ganz großes Lob und ein dickes Danke für deine detaillierte Analyse und Hilfestellung. Funktioniert exakt so wie du beschrieben hast!
    Ich war kurz davor, das alte Kack-Pad wieder einzubauen, weil mich dieses ewige nicht Nicht-Funktionieren des Clickpads total abgenervt hat.
    Wie dem auch sei: Es funktioniert bestens.
    Ich war heute kurz geschockt, weil das Touchpad wieder seinen Dienst verweigerte. Hier war das Lenovo Vantage Programm aber der Schuldige, indem hierrüber automatisch neue Treiber installiert wurden. Da kann man bei Windows natürlich Einstellen und Blocken so viel man möchte Ego: Auch die automatische Treiberaktualisierung im Lenovo Vantage Programm deaktivieren!

    Nochmals vielen Dank!
    T440s: i5 4200U, 12GB RAM, 250GB SSD, FHD, Windows 8.1 und das mit 3-Button Clickpad

  14. #433

    Registriert seit
    23.03.2018
    Beiträge
    18
    Danke
    1
    Thanked 1 Time in 1 Post

    Erfolgreicher Einbau in T440s (Win10 Pro 64)

    Hallo zusammen,

    da dies hier der Thread für das 3-Tasten-Touchpad ist, hänge ich meine eigenen Erfahrungen mal an.

    Das "neue" Touchpad habe ich gebraucht gekauft. Die Rückseite sieht genauso aus wie die vom Original-Touchpad. Es hatte kein Flachbandkabel. Das refurbishte T440s (Typ 20ARS32P00) lies sich nach lösen der Schrauben leicht öffnen, indem die Fingernägel im Bereich des Smartcard-Readers eingehakt wurden. Anscheinend wurde es schon ein paar mal geöffnet. Ein Foto von den Innereien hilft hinterher, die Positionen der internen Schrauben wiederzufinden!

    Ich habe die Tastatur nicht entfernt, dazu später mehr.
    Durch lösen der Schrauben der Hauptplatine sowie einiger Kabel gelang es mir, die Hauptplatine etwas anzuheben und zur Seite zu schieben. Dadurch konnten alle 4 Schrauben des Touchpads gelöst werden.
    Das alte Kabel vom Original-Touchpad passte ans neue Touchpad, und dieses lies sich problemlos einbauen. Danach sprang das Laptop nicht mehr an!
    Ein schmales Flachbandkabel auf der linken Seite (Wenn man auf die Unterseite schaut, Touchpad vorne) war die Ursache. Mit diesem angeschlossenen Kabel lief der Rechner wieder. Hurra, ein erster Erfolg nach etwa 30 Minuten. Ein Test mit Lubuntu 20.10 Desktop vom USB-Stick zeigte, dass nur das Touchpad funktioniert, nicht aber die Tasten oder das Trackpad.
    Funfact: Als kleine Erinnerung an die kurze gemeinsame Zeit hat Lubuntu 20.10 was an der Systemuhr verstellt.
    Unter Windows war die Uhr dann 1 Stunde zurück und musste neu synchronisiert werden.

    Das fest installierte Betriebssystem ist Windows 10 Pro 64Bit 20H2 deutsch.
    Ohne weitere Änderungen funktionierte nur das Touchfeld selbst, die Tasten nicht, und auch nicht der Trackpoint. OK, das ist zumindest mal eine konsistente Situation. Bevor ich das Gerät erneut öffnete, erst mal den UltraNav-Treiber über Apps deinstalliert und den aktuellen vom Treiber vom T450s installiert.
    Nö, da ändert sich nichts.

    Und was ist mit dem überall erwähnten n10gx25w.exe? Ja, das geht besser, die Tasten funktionieren, aber trotz abgeklemmten Treiberupdates waren nach dem nächsten reboot die Tasten wieder weg.
    Das Trackpad lief gar nicht. Vielleicht was mit dem Kabel zum Trackpad?
    Nach dem Ausbau der Tastatur, der ähnlich lange gedauert hat wie der Einbau des Touchpads, erkannte ich dass sich das schmalere der zwei
    Flachbandkabel etwas aus der Halterung gelöst hatte. Ich nutzte die Gelegenheit die Tastatur auszubauen und mal mit Druckluft durchzupusten.
    Irgendwas knirscht ab und zu da drin. Beide Kabel angeschlossen, neuer Versuch mit Windows 10:
    - Im Geräte-Manager das Synaptics-Touchpad inklusive seiner Treiber deinstalliert.
    - n10gx25w.exe gestartet aber am Ende nicht installiert.
    - Neustart
    - Im Geräte-Manager ist eine neu entdeckte PS/2-Maus
    - Diese Maus bekam über "Treiber aktualisieren"/"Auf meinem Computer nach Treibern suchen" den gerade auf der Festplatte ausgepackten
    Ultranav Treiber untergeschoben (in C:\DRIVERS\WIN\UNAV\WinWDF\x64)
    - Neustart

    - Im Geräte-Manager erscheint jetzt ein Thinkpad Ultranav Pointing Device ---> Läuft!!

    Jetzt noch das Erreichte so gut es geht gegen automatischen Vandalismus schützen:
    - Unter "Einstellungen" nach "Geräteinstallationseinstellungen ändern" suchen,
    und dort die automatische Suche nach Treibern deaktivieren.

    - Neustart

    ---> Läuft immer noch.

    Aus Neugier nochmal Lubuntu gestartet: Die Tasten und der Trackpad funktionieren "out of the box"
    (Ja, die Uhr habe ich danach auch nochmal umstellen müssen )

    Grüße an alle Schrauber

    Lötzinn

    Ich kann alle verstehen die vor soviel "Fummelei" zurückschrecken.
    Denen, die auf halbem Weg verzweifeln sage ich: Gebt nicht auf!
    Geändert von Lötzinn (24.02.2021 um 16:08 Uhr)

  15. The Following User Says Thank You to Lötzinn For This Useful Post:

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
thinkstore24.de Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen CaptainNotebook