luxnote lapstore servion thinkspot
Ergebnis 1 bis 18 von 18

Thema: OSX Lion auf dem Thinkpad T61 [Volle Anleitung mit Treibern!]

  1. #1
    Avatar von julianstroebel
    Registriert seit
    19.05.2012
    Ort
    BaWü
    Beiträge
    513
    Danke
    8
    Thanked 9 Times in 9 Posts

    OSX Lion auf dem Thinkpad T61 [Volle Anleitung mit Treibern!]

    Hallo,
    ich habe es geschafft Lion auf dem T61 zum laufen zu bringen. Ich schreibe nun hier eine komplette Anleitung und stelle alle Treiber die ich bisher habe zu Verfügung.

    Ich möchte noch darauf hinweisen das das was ihr mit euerem Thinkpad macht auf euere Verantwortung geht!

    Also, fangen wir an. Ihr benötigt:

    - Thinkpad T61 (wichtig mit Intel Grafik, Nvidia wird nicht unterstützt!)
    - MyHack Installer (link)
    - Einen bestehenden Mac (egal ob SL oder L oder Hackintosh)
    - Mein Treiberpaket (link)
    - Einen min. 8GB großen USB Stick
    - Install ESD von der Lion Installation
    - Etwas Gedult

    1. USB Medium erstellen.

    Also ihr müsste (wenn ihr es nicht mehr habt) die Installation von Lion im Programme Ordner besitzen. Wenn diese im Programme Ordner ist schließt ihr eueren USB Stick an und öffnet den MyHack Installer. Dort müsst ihr euer Passwort eingeben und bekommt kurz darauf ein Fenster mit einer Liste. Aus dieser Liste wählt ihr "Create OSX Installer" und wählt im nächsten abschnitt "Create OS X 10.7 Install Disk". Nun wählt ihr eueren Formatierten (auf Mac OSX Journaled und Master Boot Record) USB Stick aus der Liste aus und drückt OK. Dann bekommt ihr ein Fenster indem ihr die Quelle auswählen müsst. Drückt auf "Browse Manually" und wählt "Install ESD.dmg" aus der Lion Installation aus. Nun dauert es eine weile, geht euch einen Kaffee holen oder macht sonstiges

    Ist die Installation fertig zieht ihr mein Treiberpaket auf den USB Stick. Mehr müsst ihr an diesem Stick nicht verändern.

    2. Lion Installieren.

    Nun startet ihr von euerem USB Stick (F12 am Start). Die Installation startet Automatisch. Wählt euere Sprache aus. Drückt im nächsten Fenster in der Menüleiste (oben) auf Dienstprogramme und wählt das Festplatten Dienstprogramm von Apple. Nun wählt ihr links euere HDD oder SSD aus und drückt auf Partitionieren. Nun könnt ihr eine Partition hinzufügen (kleines Plus) oder die Festplatte löschen. Um die Festplatte zu löschen wählt in der Liste "1 Partition" aus. Nun muss diese in "Mac OSX Journaled" und unter den Optionen "GUID-Partitiontabelle" auswählen. Wenn die Festplatte formatiert ist schließt ihr das Fenster und kommt zurück zur Installation. Dort wählt ihr nun euere Festplatte aus.

    Die Installation läuft nun bis zum Schluss durch. Am Ende hängt die Installation, einfach warten, da myHack Installationen durchführt.

    3. Treiber installieren.

    Nun öffnet ihr am neuen System den USB Stick. Dort öffnet ihr den Ordner mit meinen Treibern. Benutzt dann den Kext Wizard um alle Kext's zu installieren.


    Das war es eigentlich WLAN, LAN und Bluetooth funktionieren noch nicht, aber danach suche ich zurzeit nach einer Lösung.

    Viel Spaß wünsche ich euch!

    Gruß Julian
    Geändert von julianstroebel (11.07.2012 um 13:29 Uhr)
    Thinkpad x280 - i7 8650U - 16GB RAM - 512GB M.2 SSD
    Dell Precision M4700 -
    i7 3740QM - 32GB RAM - 256GB mPCI SSD - 256GB SATA SSD
    Synology DS1817+ / Synology DS111 / ESXI 6.5

  2. #2
    Avatar von B$TIStalin
    Registriert seit
    30.01.2010
    Ort
    Bad Mergentheim
    Beiträge
    484
    Danke
    12
    Thanked 11 Times in 11 Posts
    für WLAN wirst du eine atheros Karte brauchen
    T430s (2353-2NU) | W700ds (2752-E7G) | Twist S230u (3347-7RG)

  3. #3
    Avatar von julianstroebel
    Registriert seit
    19.05.2012
    Ort
    BaWü
    Beiträge
    513
    Danke
    8
    Thanked 9 Times in 9 Posts
    Themenstarter
    ja schon öfters gehört
    Thinkpad x280 - i7 8650U - 16GB RAM - 512GB M.2 SSD
    Dell Precision M4700 -
    i7 3740QM - 32GB RAM - 256GB mPCI SSD - 256GB SATA SSD
    Synology DS1817+ / Synology DS111 / ESXI 6.5

  4. #4

    Registriert seit
    13.07.2008
    Beiträge
    111
    Danke
    0
    Thanked 0 Times in 0 Posts
    Hi

    Der Link mit deinen Treibern funzt nicht
    MfG Michael
    __________________________________________________ _______

  5. #5
    Avatar von julianstroebel
    Registriert seit
    19.05.2012
    Ort
    BaWü
    Beiträge
    513
    Danke
    8
    Thanked 9 Times in 9 Posts
    Themenstarter
    ups... werde gleich dannach schauen
    Thinkpad x280 - i7 8650U - 16GB RAM - 512GB M.2 SSD
    Dell Precision M4700 -
    i7 3740QM - 32GB RAM - 256GB mPCI SSD - 256GB SATA SSD
    Synology DS1817+ / Synology DS111 / ESXI 6.5

  6. #6
    war noch nicht drin Avatar von Alteshaus21
    Registriert seit
    08.11.2010
    Ort
    Münsterland
    Beiträge
    4.546
    Danke
    278
    Thanked 31 Times in 31 Posts
    Blog-Einträge
    1
    Danke Werde ich die nächsten Tage austesten!
    W530, T60, T61, Z61, R61, X200, 600X

    Wer IFA fährt, fährt nie verkehrt

  7. #7
    Avatar von julianstroebel
    Registriert seit
    19.05.2012
    Ort
    BaWü
    Beiträge
    513
    Danke
    8
    Thanked 9 Times in 9 Posts
    Themenstarter
    Ihr müsst euch noch ein bisschen Gedulden :/

    Bildschirmfoto 2012-07-11 um 10.04.27.png
    Thinkpad x280 - i7 8650U - 16GB RAM - 512GB M.2 SSD
    Dell Precision M4700 -
    i7 3740QM - 32GB RAM - 256GB mPCI SSD - 256GB SATA SSD
    Synology DS1817+ / Synology DS111 / ESXI 6.5

  8. #8
    Avatar von iYassin
    Registriert seit
    15.05.2009
    Beiträge
    8.887
    Danke
    86
    Thanked 265 Times in 237 Posts
    Probiere für LAN mal die AppleIntelE1000e.kext.
    Bluetooth sollte eigentlich OOTB gehen. Deaktiviere BT mal im BIOS, starte dann OS X, fahre das T61 wieder herunter, aktiviere BT wieder und starte dann erneut OS X. Wenn du nun die Systemeinstellungen öffnest und dort auf "Netzwerk" klickst, sollte OS X dir eigentlich mitteilen, dass ein neuer Bluetooth-Netzwerkanschluss gefunden wurde - dann auf "Anwenden" klicken, oben auf "Alle anzeigen", dann sollte BT verfügbar sein. Falls nicht, probiere mal das hier (das ist zwar für 10.6.8, aber du kannst das 1:1 für 10.7 übernehmen): http://thinkpad-forum.de/threads/136...etooth-Problem

    Hast du eigentlich eine DSDT? Wenn nicht - es lohnt sich: Speedstep inkl. aller P- und C-States, Helligkeitsregelung, Lüftersteuerung, ...
    ThinkPad T470p | Core i7-7820HQ 2.9 GHz | 24GB RAM | 1TB SSD | Windows 10 Pro x64
    Dell PowerEdge T20 | Xeon E3-1225v3 3,2 GHz | 16GB RAM | 80GB SSD + 12 TB HDD | OpenMediaVault 4
    X230t - T420s - X201 - T61 QXGA - T42 - T41 - T40 - 600X

  9. #9

    Registriert seit
    10.04.2012
    Beiträge
    10
    Danke
    0
    Thanked 0 Times in 0 Posts
    coole Sache, werde ich demnächst mal ausprobieren. OSX 10.6.8 lief immer ohne Probleme bei mir, aber Lion bekam ich nie wirklich sauber ans Laufen... Irgendwie gab es immer wieder Abstürze wegen Grafiktreibern und Programme liefen extrem instabil (besonders Finder ist andauern abgestürzt), weswegen ich das Projekt dann erstmal in den Sand gesetzt hatte. Aber jetzt scheint es ja keine großen Probleme mehr zu geben, also werd ich es nochmal probieren. Muss nur noch irgendwo eine leere Festplatte zum rumexperimentieren finden
    @julian: Hat dein T61 auch die X3100 Grafik von Intel ?? Wenn ja, dann sind unsere Thinkpads wohl ziemlich gleich zu handhaben und ich hätte gute Chancen.
    Schade, dass im neuen Mountain Lion der Support für ältere integrierte Intel-Grafikchips (u.a. X3100) gestrichen wurde..Wenn das laufen wprde, wäre schon echt nice, aber läuft ja nicht einmal auf dem MacBook von nem Freund...

  10. #10
    Avatar von julianstroebel
    Registriert seit
    19.05.2012
    Ort
    BaWü
    Beiträge
    513
    Danke
    8
    Thanked 9 Times in 9 Posts
    Themenstarter
    Jo, habe das T61 mit der Intel Grafik. Aber habe OSX nicht mehr!
    Thinkpad x280 - i7 8650U - 16GB RAM - 512GB M.2 SSD
    Dell Precision M4700 -
    i7 3740QM - 32GB RAM - 256GB mPCI SSD - 256GB SATA SSD
    Synology DS1817+ / Synology DS111 / ESXI 6.5

  11. #11

    Registriert seit
    10.04.2012
    Beiträge
    10
    Danke
    0
    Thanked 0 Times in 0 Posts
    Zitat Zitat von julianstroebel Beitrag anzeigen
    Jo, habe das T61 mit der Intel Grafik. Aber habe OSX nicht mehr!
    Warum? Lief Lion doch nicht so gut oder was war der Grund. Wenn ich noch ne leere Festplatte finde, werde ich mich mal über Weihnachten mit Lion für mein T61 beschäftigen. Hoffentlich bekomme ich es diesmal zum Laufen...

  12. #12

    Registriert seit
    02.02.2009
    Beiträge
    230
    Danke
    3
    Thanked 3 Times in 3 Posts
    Zitat Zitat von TP-OSx86 Beitrag anzeigen
    Warum? Lief Lion doch nicht so gut oder was war der Grund.
    ich kann nur für ein T60 und X60s mit SL und einem T410 mit Lion sprechen, aber grundsätzlich kommt es darauf an, was man damit macht (machen will).

    Als Spielerei und zum "es geht doch" taugt Mac OS auf dem ThinkPad alle Mal.

    Will man aber wirklich alles am laufen haben und auch so das man damit arbeiten kann und das es nach dem nächsten Update so bleibt, muss man da eine Menge (mehr) Zeit investieren als alles einmal installieren. Ist ein nerviges und langwieriges Gefummel und nach dem dritten oder vierten Laptop macht es keinen Spaß mehr. Irgendwann soll es einfach nur noch funktionieren, zuverlässig, dauerhaft!

    Das fängt mit Video an und hört mit der Tastaturbelegung noch lange nicht auf.

    Auf meinem T60 und X60s ist z.B. die Flash-Video-Wiedergabe recht ruckelig, auf dem T60 geht der Sound nach Suspend/Resume nicht richtig und manches Mal crashed eine Anwendung oder es gibt einfach einen Kernel Panic.

    Auf dem T410 mit Lion läuft es insgesamt deutlich besser, allerdings habe ich z.B. Flash gar nicht installiert und bislang gehen weder WLAN noch WAN. Für beides braucht es andere Hardware und ein angepasstes BIOS, auch nicht jedermanns Sache.

    Jetzt könnte man sagen, kauf doch einen Mac. Hab ich, einen alten Mac Mini, ich hatte ein 15" MB Pro und nun ein 13" MB Pro und was soll ich sagen. Im Vergleich zu den ThinkPads einfach sch... Hardware, Spiegel-Display, verkrüppelte Tastatur wo für mich wichtige Tasten fehlen, kein TrackPoint sondern nur ein SchmierPad. Das ganze dann noch elend teuer und gebraucht kaum zu bekommen.

    Und insgesamt muss ich sagen, das Mac OS auch nicht immer das "Gelbe vom Ei" ist, für mich viel besser als Windows zwar, aber seit 10.6 hat sich Mac OS in meinen Augen eher nicht zu seinem Vorteil entwickelt, außerdem besteht bei Apple grundsätzlich das Problem mit dem Weglassen von 20% der benötigten Funktionen (die man dann meist für Geld oder viel Zeit nachrüsten kann).

    Ein weiteres Problem ist die Tastaturbelegung, die man zwar mit "KeyRemap4MacBook" recht gut hinbekommt, aber nicht immer funktionierendes Pos1/Ende, Bild hoch/runter oder Alt + X/C/V statt Strg + X/C/V sind Ärgernisse die auf Dauer stören können, vor allem wenn man in mehreren "Welten" unterwegs ist.


    Eigentlich wäre Linux eine Alternative, da funktioniert das meiste ohne Gefummel, da stören mich aber Sachen wie (fast) jährlich nötige Systemupdates, mangelnde Konsistenz in der Bedienung, kaputte Module nach einem Kernel-Update usw., außerdem gibt es dort einfach manche kommerzielle Software nicht, Beispiel wäre eine gut funktionierende OCR mit PDF-Erstellung.

    Schwieriges Thema also, eigentlich war OS/2 das System was mir (sehr) lange Zeit alles geboten hat, inzwischen ist es damit leider vorbei, vor allem weil es auf moderner Hardware nicht mehr vernünftig läuft und das Basis-System aufgrund einiger Beschränkungen mit moderner Software wie OpenOffice 3.2 oder Firefox 10 nicht mehr so richtig tut.
    Grüße,

    mac4tp

  13. #13

    Registriert seit
    06.04.2012
    Beiträge
    105
    Danke
    0
    Thanked 0 Times in 0 Posts
    Lasst uns diesen alten Faden ruhig ein wenig weiterspinnen.
    Ich habe in der Familie jetzt zwei T60 mit 10.6.8 am Laufen und bis auf Flash induzierte Browser-Abstürze gibt es kaum Probleme.
    Die T61 werden momentan recht günstig, da werde ich auch mal eins mit Lion ausrüsten.

    Allerdings stimme ich mac4tp voll zu, seit 10.6.6 hat sich mit OSX nix zum Bessern gewandelt und die allermeisten Applikationen laufen mit 10.6.X ebenso gut wie mit (Mountain) Lion.
    Mission Control und Launch Pad sind ganz nett, aber die virtuellen Arbeitsflächen in GNU/Linux sind bei weitem besser, finde ich.
    T60 1951Y2C - Macintosh PPC - Hackintosh Intel und AMD

  14. #14

    Registriert seit
    31.03.2012
    Ort
    Bochum
    Beiträge
    20
    Danke
    0
    Thanked 0 Times in 0 Posts
    @24bit Sitze gerade an einem T61 das mit ML ausgestattet ist und muss sagen die Installation auf dem T61 (NV140m) lief bei weitem am reibungslosesten von allen HackBooks, die ich bisher installiert habe. Es lohnt auf jeden Fall bei einem günstigen T61 zu zugreifen

    in einem stimme ich Mac4tp allerdings auch zu, will man ein stabiles System, dass man voll produktiv nutzen kann bedarf es einiger Arbeit bis die Thinkpad´s auch diverse Updates schadlos überstehen. Ob man sich das antun möchte steht dann auf einem anderen Blatt Papier ich jedenfalls habe es bisher noch nicht bereut und ich setze meine Thinkpads beide produktiv mit OSX ein (das T60 mit Lion und das T61 jetzt mit ML).

  15. #15

    Registriert seit
    06.04.2012
    Beiträge
    105
    Danke
    0
    Thanked 0 Times in 0 Posts
    Hey rumble, schön mal wieder was von dir zu hören!
    Vor dem NV flexing hast du in dem Fall keine Angst? Ich besorge mir ev. auch so eine alte Möhre mit Nvidia Grafik, ML auf einem T61 - das wäre ein schönes schwarzes MacBook.
    Die X3100 ist für ML leider kaum brauchbar, OpenGL läuft zwar, aber der X3100 64bit hack (beta) steht scheinbar auf wackeligen Beinen. Vielleicht bessert da noch jemand nach, es gab ja ein paar X3100 MacBooks.
    Hast du zufällig einen SD Kartenleser mit 10.8 am Laufen? Das Transcend Teil ist ja OSX kompatibel, der Treiber auf der Herstellerseite wird aber nur für 10.7.4 oder niedriger angeboten.
    T60 1951Y2C - Macintosh PPC - Hackintosh Intel und AMD

  16. #16

    Registriert seit
    31.03.2012
    Ort
    Bochum
    Beiträge
    20
    Danke
    0
    Thanked 0 Times in 0 Posts
    ​Hey 24bit,

    sorry das ich erst jetzt antworte, war ein wenig im Stress die letzten Tage

    Was das NV Flexing angeht habe ich davor Respekt, da ich inzwischen auch ein Opfer davon geworden bin was aber weniger schlimm war da mich mein T61 gerade mal 29€ (ebay) und einen StructureFrame nebst Basecover für ein T60 (lag eh rum) im Tausch gegen ein intaktes TFT Panel gekostet hat. Ich hab das T61 auf ebay als Defekt für 29€ gekauft (Display Bruch) und wollte es eigentlich als Teilespender für ein Frankenpad nutzen aber zum einen war das TP bis auf das gebrochene Display wirklich in einem sehr guten Zustand und zum anderen hatte ich mal wieder erst geboten und dann gelesen und letztlich gelernt 15.4 zoll wide passt niemals nicht in 14 zoll 4:3 es sei denn man sägt das halbe board ab...

    Wie auch immer ich hatte ein paar Tage Spaß mit dem Dingen und dann war Ende im Gelände. Zwar hat das backen des Boards noch mal ne Woche gebracht aber dann war endgültig vorbei (Fehler trat erneut auf und das ausgerechnet beim flashen des Bios). Ich bin dann erstmal wieder auf das T60 umgestiegen aber irgendwie hat mich das T61 gefangen und nicht mehr losgelassen und so hab ich mal wieder ebay durchforstet und bin auf ein passendes Mainboard gestoßen das zu einem Preis von 70€ (Sofort Kauf) angeboten wurde. Nach Rückfrage beim Anbieter habe ich dann zugeschlagen, das Board ist was den NV Bug angeht unkritisch die GPU trägt als Produktionsdatum 48/08 und gehört somit zur überarbeiteten Version. Fazit 99€ investiert und ein inzwischen wirklich bewährtes T61 bekommen, was will man mehr? OSX läuft hier rund und selbst der eingebaute Cardraeder (Ricoh) läuft ohne murren mit der entsprechenden KEXT. Die Temperaturen sind allesamt im Grünen Bereich (CPU: 42, GPU: 52 Grad) aktuell ohne, dass der Lüfter sich unangenehm bemerkbar macht und auch unter Last wird es selten mehr als ein seichtes säuseln...

    Gruß rumble

  17. #17

    Registriert seit
    09.01.2014
    Beiträge
    3
    Danke
    0
    Thanked 0 Times in 0 Posts
    Hallo rumble

    Ich bin neu hier im Forum und möchte auf meinem T61 mit Intel Grafik, gerne SL oder Lion installieren.
    Hast Du vielleicht eine gute Anleitung, die es auch einem Anfänger erlaubt, dies durch zu führen ?

    Gruß profun1



    Gesendet von meinem iPhone mit Tapatalk
    Using Tapatalk

  18. #18

    Registriert seit
    09.01.2014
    Beiträge
    3
    Danke
    0
    Thanked 0 Times in 0 Posts
    Hallo,


    könntest Du noch mal das Treiber Paket online stellen, ist leider down.


    Gruß Ralf


    Gesendet von meinem iPhone mit Tapatalk
    Using Tapatalk

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
CeCon Preiswerte-IT - Gebrauchte Lenovo Notebooks kaufen CaptainNotebook NBWN - Notebooks wie neu