JMS Hardware&Software luxnote servion thinkspot
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 20 von 33

Thema: TUTORIAL: nicht IBM WLAN karte (2200/2915) im Thinkpad

  1. #1

    Registriert seit
    04.01.2008
    Ort
    Halberstadt
    Beiträge
    258
    Danke
    0
    Thanked 1 Time in 1 Post

    TUTORIAL: nicht IBM WLAN karte (2200/2915) im Thinkpad

    Hallo,

    hatte das oben genannte Problem und habe mir dafür eine passende Lösung gesucht und wollte euch daran teilhaben lassen.

    Ausgangssituation: ThinkPad R52 1862-A14 ohne WLAN + intel 2200abg aus nem alten ASUS Notebook

    Problemstellung: beim Boot der uns allen bekannte Fehler 1802 (kein no-1802 Patch zeigte Wirkung)

    Die Lösung: Änderung der Subsystem ID der WLAN Karte


    Was ihr benötigt:
    1) Knoppix 3.8.2 (andere sollen auch funktionieren aber diese soll die stabilste sein)
    2) http://www.geocities.com/sonyirclib/ipw2200.tar.gz (fertig gepatchter ipw2200 treiber für Linux welcher auf EEPROM schreiben kann)
    3) ethtool (integriert in Knoppix)

    Die Prozedur:
    Ich habe da mir kein anderes Notebook mit miniPCI Steckplatz zur Verfügung stand eine ungewöhnliche lösung gewählt. Zum Bearbeiten des ROM´s muss der PC zugriff auf die Karte haben, ist mit Fehler 1802 schwer möglich, also entschloss
    ich mich die Karte im laufenden Betrieb einzubauen. Dazu hat sich bewährt ohne Karte im Book den rechner einschalten und F12 drücken, kurze Zeit darauf erscheint das Bootmenü >>> Dann die Karte Sorgfältig in den Steckplatz schieben und verriegeln. Befehle sind mit einer # davor gekennzeichnet, diese bitte nicht mit eingeben...

    1. Knoppix starten
    2. auf den Pinguin klicken >>> ROOTSHELL

    #iwconfig > da seht ihr welcher euer WLAN Adapter ist (eth0 oder eth1)
    #ethtool -e ethX (das X müsst ihr mit eurer Adapternummer vom WLAN ersetzen) >>> daraufhin seht ihr den DUMP eures 256Bit EEPROM´s

    #mkdir /usr/tmp
    #cd /usr/tmp
    #wget http://www.geocities.com/sonyirclib/ipw2200.tar.gz (dafür braucht ihr eine bestehende Netzwerkverbindung über Ethernet oder ihr ladet die datei direkt vorher runter und passt die verzeichnisse an)
    #tar xvzf ipw2200.tar.gz
    #cd ipw2200-1.0.3
    #sh unload
    #sh load

    #ethtool -E ethX magic 0x2200 offset 0x08 value 0x12 (damit ändert ihr die Subsystem ID eurer orginalen Intel Karte von 27028086 auf 27128086)
    WICHTIG: denkt daran das X durch euren Adapter zu ersetzen und die Zeile genau so ein zu geben.....

    Dann nur noch ein Neustart und ihr habt eine WLAN Karte zu wenigstens 1/4 des Orginalpreises. Einziges Manko ist das die WLAN LED nicht funktioniert, da arbeite ich noch dran.....

    Viel Spaß beim Basteln!
    Lenovo T440p / i7-4800MQ / 16GB DDR3L / SAmsung 840 EVO 1TB / WLAN AC / Geforce GT 730M
    Dell E6410 i7 620M / 4GB DDR3 / Corsair Force 120 SSD / BT / DraftN WLAN / Intel GMA
    HP Elitebook 8560p / i7 / 4GB / 240GB OCZ SSD / BT / DraftN WLAN (Dienstnotebook)

  2. #2
    OS X Experte Avatar von tcone
    Registriert seit
    07.04.2008
    Ort
    Berlin
    Beiträge
    1.830
    Danke
    0
    Thanked 0 Times in 0 Posts
    Zitat Zitat von 'Zerox86',index.php?page=Thread&postID=390887#post 390887
    also entschloss ich mich die Karte im laufenden Betrieb einzubauen.
    Mutig, mutig... Respekt! Habe ich mit einem BIOS-Chip auch mal gemacht, aber bei einer PCI-Karte ist das sicherlich etwas riskanter.
    X61 gibt Gas T7300 SXGA+ (HV121P01-101) 160GB X25-M AR9280 | X61 T7300 UL-Panel 4965AGN (H.264-Renderknecht) | X61 7674-GS3 |X61s L7500 SXGA+ WD5000BEVT AR5008 | T41 1,7@2,26GHz 11a/b/g II | R32 1,6GHz | 240X 500MHz | 570 366MHz ->Verkaufe X60/s Mainboards

  3. #3

    Registriert seit
    04.01.2008
    Ort
    Halberstadt
    Beiträge
    258
    Danke
    0
    Thanked 1 Time in 1 Post
    Themenstarter
    Zitat Zitat von 'tcone',index.php?page=Thread&postID=390893#post39 0893
    Zitat Zitat von 'Zerox86',index.php?page=Thread&postID=390887#post 390887
    also entschloss ich mich die Karte im laufenden Betrieb einzubauen.
    Mutig, mutig... Respekt! Habe ich mit einem BIOS-Chip auch mal gemacht, aber bei einer PCI-Karte ist das sicherlich etwas riskanter.
    ja sicher, aber no Risk no Fun. Und solange es Funktioniert ist es ja auch ne Top Sache.....*g*
    Lenovo T440p / i7-4800MQ / 16GB DDR3L / SAmsung 840 EVO 1TB / WLAN AC / Geforce GT 730M
    Dell E6410 i7 620M / 4GB DDR3 / Corsair Force 120 SSD / BT / DraftN WLAN / Intel GMA
    HP Elitebook 8560p / i7 / 4GB / 240GB OCZ SSD / BT / DraftN WLAN (Dienstnotebook)

  4. #4
    OS X Experte Avatar von tcone
    Registriert seit
    07.04.2008
    Ort
    Berlin
    Beiträge
    1.830
    Danke
    0
    Thanked 0 Times in 0 Posts
    Zitat Zitat von 'Zerox86',index.php?page=Thread&postID=390930#post 390930
    ja sicher, aber no Risk no Fun. Und solange es Funktioniert ist es ja auch ne Top Sache.....*g*
    Auf jeden Fall. Deine Aktion finde ich auch wirklich gut.
    Andere Leute hätten vielleicht eine anderes Notebook bzw. TP mit 1802-Patch genommen und erst *dann* die PCI-ID geändert. Geheult hätte ich aber trotzdem, wenn beim Hot-Swapping was passiert wäre
    Wünsche Dir viel Glück mit der LED!
    X61 gibt Gas T7300 SXGA+ (HV121P01-101) 160GB X25-M AR9280 | X61 T7300 UL-Panel 4965AGN (H.264-Renderknecht) | X61 7674-GS3 |X61s L7500 SXGA+ WD5000BEVT AR5008 | T41 1,7@2,26GHz 11a/b/g II | R32 1,6GHz | 240X 500MHz | 570 366MHz ->Verkaufe X60/s Mainboards

  5. #5

    Registriert seit
    04.01.2008
    Ort
    Halberstadt
    Beiträge
    258
    Danke
    0
    Thanked 1 Time in 1 Post
    Themenstarter
    Zitat Zitat von 'tcone',index.php?page=Thread&postID=391008#post39 1008
    Zitat Zitat von 'Zerox86',index.php?page=Thread&postID=390930#post 390930
    ja sicher, aber no Risk no Fun. Und solange es Funktioniert ist es ja auch ne Top Sache.....*g*
    Auf jeden Fall. Deine Aktion finde ich auch wirklich gut.
    Andere Leute hätten vielleicht eine anderes Notebook bzw. TP mit 1802-Patch genommen und erst *dann* die PCI-ID geändert. Geheult hätte ich aber trotzdem, wenn beim Hot-Swapping was passiert wäre
    Wünsche Dir viel Glück mit der LED!
    ja, mit der LED wird noch spaßig, hab gelesen das es ein ansteuerungsproblem sein Soll weil ein PIN bei IBM anders belegt (optional) ist....
    Lenovo T440p / i7-4800MQ / 16GB DDR3L / SAmsung 840 EVO 1TB / WLAN AC / Geforce GT 730M
    Dell E6410 i7 620M / 4GB DDR3 / Corsair Force 120 SSD / BT / DraftN WLAN / Intel GMA
    HP Elitebook 8560p / i7 / 4GB / 240GB OCZ SSD / BT / DraftN WLAN (Dienstnotebook)

  6. #6

    Registriert seit
    22.04.2008
    Beiträge
    70
    Danke
    0
    Thanked 0 Times in 0 Posts
    funktioniert denn alles andere? wie Access Connections oder Fn+F5?
    MfG Michael

    I
    BM
    lenovo Thinkpad T61 7663 13G Core2Duo T7500, 4096MB RAM, 320GB HDD, 14,1" WXGA+, DVDRW/CDRW, Windows 7 Ultimate 64Bit

  7. #7

    Registriert seit
    04.01.2008
    Ort
    Halberstadt
    Beiträge
    258
    Danke
    0
    Thanked 1 Time in 1 Post
    Themenstarter
    ja, Access Connections und Fn+F5 funktionieren einwandfrei
    Zitat Zitat von 'URB',index.php?page=Thread&postID=391279#post3912 79
    funktioniert denn alles andere? wie Access Connections oder Fn+F5?
    Lenovo T440p / i7-4800MQ / 16GB DDR3L / SAmsung 840 EVO 1TB / WLAN AC / Geforce GT 730M
    Dell E6410 i7 620M / 4GB DDR3 / Corsair Force 120 SSD / BT / DraftN WLAN / Intel GMA
    HP Elitebook 8560p / i7 / 4GB / 240GB OCZ SSD / BT / DraftN WLAN (Dienstnotebook)

  8. #8

    Registriert seit
    03.12.2006
    Ort
    Thinkpadhausen
    Beiträge
    3.101
    Danke
    0
    Thanked 0 Times in 0 Posts
    Moin Zerox86,

    finde ich top, dass sich auch andere Leute um das Thema kümmern...
    Was du wohl zu erwähnen vergessen hast, ist dass der "no 1802 Patch" bei den R52 nicht geht!

    Es ist immer besser, eine Quelle anzugeben, wenn etwas nicht auf eigenem Mist gewachsen ist, finde ich.

    Hole ich dann hier für dich nach. Quelle: http://stachon.webpark.cz/ipw-eeprom.html

    Hier gibt es auch einen Thread dazu. Für die LED gibt es momentan noch keine Lösung, aber ich mag nicht so recht glauben, dass IBM das Platinen Layout geändert hat. Muss also irgendwie doch gehen! Die Lösung von Jak im englischen Wiki stellt für mich keine Lösung da, weil die LED dann immer brennt, auch wenn die WLAN-Karte deaktiviert ist.

    Wichtig ist auch, dass der WLAN-Treiber von IBM/Lenovo benutzt wird, damit FN-F5 funktioniert! Mit dem Intel Treiber geht das nie.

    Diese Geschichte geht für die Intel Karten leider nicht, da die nicht IBM Karten unter "Exclude" gelistet sind.
    Deine Karte ist an 2. Stelle gelistet, meine habe ich markiert... 8) Anhang 6801

    Klaus
    „Ich bin wie ich bin. Die einen kennen mich, die anderen können mich.“

  9. #9

    Registriert seit
    05.05.2008
    Beiträge
    117
    Danke
    0
    Thanked 0 Times in 0 Posts

    Lösung für die LED

    Hallo

    Ich bin sehr gespannt, on jemand eine Lösung für das LED-Problem findet, ich habe zur Zeit schon aufgegeben. In meinem Thread kann man darüber auch schon einiges lesen.
    Zusammengefasst :
    T42 2374-6G5
    2915a/b/g
    Fn + F5 funktioniert sagenhaft, auch keine Fehler 1802 Meldung
    LED -
    Und die Pinbelegung entspricht auf jeden Fall nicht der in Thinkwiki
    Es bleiben noch die Pins an der Rückseite, die lassen sich aber nicht gut durchmessen.

    Grüße Karel
    T42 2374-6G5

  10. #10

    Registriert seit
    05.05.2008
    Beiträge
    117
    Danke
    0
    Thanked 0 Times in 0 Posts
    Wieder keine Hoffnung für das LED Problem ? ;(
    T42 2374-6G5

  11. #11

    Registriert seit
    01.11.2007
    Beiträge
    33
    Danke
    0
    Thanked 0 Times in 0 Posts
    Ich habe eine andere Lösung für das Problem mit fremden WLAN Karten.

    Das Programm, welches ich angehängt habe modifiziert den Bios so, dass dieser keine Wlan Karten mehr blacklisted.
    Allerdings kann niemand dafür haften, hat bei mir allerdings immer reibungslos funktioniert.

    ---
    Ich hab es als source angehängt, damit nicht jemand es benutzt ohne zu wissen, was er tut.
    Angehängte Dateien Angehängte Dateien

  12. #12

    Registriert seit
    01.09.2007
    Beiträge
    284
    Danke
    0
    Thanked 0 Times in 0 Posts
    Ich muss mal den alten Thread hier rauskramen um zu fragen, ob vielleicht jemand eine compilierte Version des gepatchten Treibers hat, die unter einem aktuellen Live-System wie Ubuntu 8.40 oder Knoppix 6.0.1 funktioniert? Diese Treibermodule hier laufen nämlich nicht mehr unter den neuen Linux-Kerneln und selbst compilieren unter den beiden genannten Systemen hat bei mir nicht funktioniert, wahrscheinlich weils sie dafür nicht wirklich ausgelegt sind (entweder fehlt der compiler/make-Befehl oder es gibt zig Fehlermeldungen). Mangels externem CD-ROM für mein X31 stehen mir auch nur diese beiden Systeme zur Verfügung, da diese sich problemlos ohne große Frickelei auf einen bootbaren USB-Stick installieren lassen.
    Also, wer kann mir helfen oder zumindest sagen, wo ich mir noch die Uralt-Knoppix-Version 3.8.2 downloaden kann und die dann auf Stick bekomme?

    edit: hat sich bereits erledigt, habe mir die Arbeit gemacht, die Karte in mein R31 mit CD-ROM einzubauen und dort zu flashen. Noch ein Tipp zur Knoppix-Version: versucht erst gar nicht eine neuere als 3.8.x. Mit 4.0.2 hat es bereits nicht mehr funktioniert, weil der Kernel zu neu für die Module ist. Ich habe 3.8.1 erfolgreich verwendet.
    ThinkPad – was sonst?

  13. #13

    Registriert seit
    05.06.2009
    Beiträge
    2
    Danke
    0
    Thanked 0 Times in 0 Posts

    Hülfe

    Hallo Du Licht

    ich hab mir auch grad ein x31 zugelegt und würde gern meine alte 2200 zum laufen bekommen. Leider klappt das mit dem Flashen nicht. Also das Flashen des eeprom an sich schon, aber leider wird die Karte trotzdem nicht akzeptiert... Wie ist das bei Dir gelaufen? hast Du eventuell einen anderen Wert eingetragen?

    Danke Dir und Gruß.

  14. #14
    Avatar von darktrym
    Registriert seit
    28.10.2007
    Beiträge
    1.078
    Danke
    1
    Thanked 0 Times in 0 Posts
    Vielleicht brauchst du eine andere PCI ID.

  15. #15

    Registriert seit
    27.02.2007
    Beiträge
    3.201
    Danke
    0
    Thanked 0 Times in 0 Posts
    moin,

    wenn man diese prozedur mit einer karte macht, die trotz FRU einen 1802 produziert, könnte danach auch die LED funktionieren?

    gruß
    ....

  16. #16

    Registriert seit
    03.12.2006
    Ort
    Thinkpadhausen
    Beiträge
    3.101
    Danke
    0
    Thanked 0 Times in 0 Posts
    Moin kopernikus,

    das ist sehr wahrscheinlich... IBM hat doch tatsächlich das Layout angepasst.

    Da Pin 11 (LED1_GRNP )WiFi active LED + und 13 (LED1_GRNN ) WiFi active LED -, bei der FRU Karte, die im BIOS nicht in der Whitelist geführt ist, elektronisch funktioniert müsste das klappen.

    Versuch doch mal, kannst ja wieder zurückändern! Poste mal... :P

    Klaus
    „Ich bin wie ich bin. Die einen kennen mich, die anderen können mich.“

  17. #17

    Registriert seit
    05.06.2009
    Beiträge
    2
    Danke
    0
    Thanked 0 Times in 0 Posts
    Zitat Zitat von 'darktrym',index.php?page=Thread&postID=599899#pos t599899
    Vielleicht brauchst du eine andere PCI ID.
    ok, aber woher nehmen? Gibts dafür irgendwo eine Liste? Oder kann ich die richtige id irgendwie heraus bekommen?

    Ich hab eine intel 2200 bg und würde die gern in mein x31 bekommen... welche Karten sind denn hier eigentlich original mal drin gewesen?

  18. #18

    Registriert seit
    15.04.2009
    Beiträge
    16
    Danke
    0
    Thanked 0 Times in 0 Posts
    Hallo allerseits,

    ich wärme mal wieder das Thema für mein R52 auf. Folgendes Problem: die Intel 2200BG Wlan MiniPCI-karte läßt sich im R52 auch nach dem durchgeführten "no-1802"-Patch nicht betreiben. Nach dem Boot-Vorgang bleibt der Fehler erhalten und es bleibt nur das TP auszuschalten.

    Jetzt habe ich ein zweites R52 mit funktionierender WLan-Karte (von IBM ebenfalls 2200BG). Ich habe in dem Beitrag http://stachon.webpark.cz/ipw-eeprom.html gelesen, dass man den EEPROM der WLAN Karte beschreiben kann. Da man den EEPROM-Inhalt der Karte auch speichern kann, sollte es vielleicht auch möglich sein den Inhalt des IBM-EEPROMs auf den Intel-EEPROM zu übertragen. So könnte man dem BIOS vorgaukeln, dass eine IBM-Karte drin ist - abgesehen von der nicht funktionierenden LED.

    Hat von Euch schon einmal jemand darüber nachgedacht bzw. gibt es dazu bereits praktikable Lösungen. Mit Linux habe ich noch nicht so viel am Hut, so daß ich mich erst ins BS einarbeiten müßte. ?(

    Viele Grüße

    IBMmer

  19. #19

    Registriert seit
    24.01.2007
    Beiträge
    870
    Danke
    0
    Thanked 0 Times in 0 Posts
    Beim R52 muesstest du ein Zender-BIOS einspielen koennen, womit der Fehler dann weg sein sollte.

    Der Link zum BIOS lautet ... (so, welchem Mod ist jetzt der Blutdruck gestiegen?) ... siehe PM
    X201s 5413-A13 (i7-620LM 2GHz, 4GB RAM, 80GB Intel Postville SSD, Intel HD Graphics, Intel 6300 802.11agn WiFi, Bluetooth, Debian Sid)
    iBook G4 12" Mid 2005 (G4 1.33GHz, 1.5GB RAM, 160GB SAMSUNG HM160HC, ATI 9550, Broadcom WiFi, Debian Sid)
    Das beste Betriebssystem als ISO via BitTorrent gibts hier

  20. #20

    Registriert seit
    04.08.2008
    Beiträge
    477
    Danke
    0
    Thanked 0 Times in 0 Posts
    Zitat Zitat von Twisted Mind',index.php?page=Thread&postID=391435#post3914 35]

    Wichtig ist auch, dass der [url='http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-54956
    WLAN-Treiber[/url] von IBM/Lenovo benutzt wird, damit FN-F5 funktioniert! Mit dem Intel Treiber geht das nie.


    Klaus
    das stimmt nicht. nutze selber auch keinen ibm/lenovo wlan-treiber sonder den original intel. zu beachten ist nur, das man das große treiber paket nimmt mit dem connection utillity. mit den reinen treibern gehts leider wirklich nicht.
    http://www.vorratsdatenspeicherung.de/ www.gez-abschaffen.de
    Die drei größten Krisen im Leben eines Mannes: Frau weg - Job weg - Kratzer im Thinkpad

Ähnliche Themen

  1. Wlan Karte Intel 2100 o. 2200 o. 2915
    Von -=SeB=- im Forum Suche
    Antworten: 4
    Letzter Beitrag: 19.06.2010, 12:25
  2. 100310 - Warnung vor Treiberupdate Intel 2200 und 2915
    Von Mornsgrans im Forum Allgemeine ThinkPad-Diskussion
    Antworten: 4
    Letzter Beitrag: 08.04.2010, 08:17
  3. Antworten: 10
    Letzter Beitrag: 20.05.2009, 10:33
  4. intel 2200 wlan karte
    Von df6fn im Forum Suche
    Antworten: 0
    Letzter Beitrag: 27.05.2008, 13:44
  5. mini PCI Intel Wlan Karte 2915 a/b/g
    Von Phoeniman im Forum Biete ThinkPads und Zubehör
    Antworten: 5
    Letzter Beitrag: 04.01.2008, 22:28

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
CeCon ok1.de ipWeb Campus Shop Buchtmonitor gbyte - Drupal Webentwicklung