JMS Hardware&Software luxnote servion thinkspot
Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 20 von 53

Thema: Beta-Tester gesucht: TLP 0.3.4 / Oneiric / _Intel_ Grafik

  1. #1
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    10.958
    Danke
    8
    Thanked 94 Times in 75 Posts

    Beta-Tester gesucht: TLP 0.3.4 / Oneiric / _Intel_ Grafik

    +++
    27.10.2011: der Betatest ist beendet. Es hat sich im Testverlauf herausgestellt, daß der Weg, die Optionen zur Laufzeit per Sysfs zu setzen, leider nicht funktioniert. Daher werden in der nächsten TLP-Version diese Optionen aus der Konfiguration entfernt. Das verlinkte Paket habe ich gelöscht.

    Bis auf weiteres sind die Stromspartechniken für Intel-GPUs für Kernel 3.0 nur über Bootoptionen zugänglich. Ich habe eine Beschreibung in die TLP-Doku aufgenommen.

    Allen Testern vielen Dank für die Mühe!
    +++


    Hi,

    mit Kernel 3.0 wurde wieder einmal ein Stabilitätsproblem im Kernel durch Abschalten des betreffenden Stromspar-Features "gelöst". Diesmal erwischt es die Intel Grakas und zwar die RC6-Stromspartechnik und die Frame Buffer Compression (vgl. c't 2011/20 S. 152 und Ungenutztes Stromsparpotential).

    Aus diesen Grund habe ich in TLP 0.3.4 eine Möglichkeit eingebaut, die beiden Features zur Laufzeit ohne Kerneloption zu aktivieren:
    Code:
    # Intel graphics power management (Kernel >= 3.0)
    # 0=disable/1=enable rc6 power save
    I915_ENABLE_RC6_ON_AC=0
    I915_ENABLE_RC6_ON_BAT=1
    # 0=disable/1=enable frame buffer compression
    I915_ENABLE_FBC_ON_AC=0
    I915_ENABLE_FBC_ON_BAT=1
    TLP 0.3.4 aktiviert beides standardmäßig im Akkubetrieb und deaktiviert es am Netzteil; und zwar auch ohne die oben gezeigten Configzeilen.

    Bevor ich nun die neue Version mit dieser Einstellung per TLP-PPA auf alle User loslasse, möchte ich Euch bitten das Paket von Hand herunterzuladen, zu installieren und ein wenig zu testen. Die Randbedingungen stehen im Titel.
    Bitte schreibt Eure Erfahrungen mit genauer Angabe des eingesetzten Modells und der Ausgabe von (im Akkubetrieb)
    Code:
    sudo tlp-stat
    Mich interessiert insbesondere, ob das Einschalten der beiden Optionen zu Problemen mit der Systemstabilität oder der Grafikausgabe führt. Vom Ergebnis mache ich abhängig, was davon per Default in TLP aktiv bleibt.

    Wer möchte kann den Stromverbrauch mit und ohne die neues Features vergleichen. Im Akkubetrieb deaktivieren:
    Code:
    I915_ENABLE_RC6_ON_BAT=0
    I915_ENABLE_FBC_ON_BAT=0
    Ich freue mich auf Eure Erfahrungen und bedanke mich im voraus für die Unterstützung!

    EDITH: das Paket ist auch unter Debian Wheezy (Testing) verwendbar.
    Geändert von linrunner (28.10.2011 um 19:07 Uhr) Grund: Ende Betatest
    Gruß, linrunner

    X220, X200 - Ubuntu 14.04 64-bit - TLP - Ubuntu Schnelleinstieg - ThinkPad Extras PPA

  2. #2
    Gewinnspielabräumer
    Registriert seit
    01.07.2008
    Ort
    BW
    Beiträge
    5.610
    Danke
    2
    Thanked 0 Times in 0 Posts
    Sind dir generelle Erfahrungen zu RC6 und FBC auch recht?

    Archlinux, Kernel 3.0, FBC/RC6/pcie_aspm=force geht problemlos beim Intel R400.
    Markplatz: ---

  3. #3
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    10.958
    Danke
    8
    Thanked 94 Times in 75 Posts
    Themenstarter
    Selbstverständlich. Danke .
    Gruß, linrunner

    X220, X200 - Ubuntu 14.04 64-bit - TLP - Ubuntu Schnelleinstieg - ThinkPad Extras PPA

  4. #4

    Registriert seit
    11.12.2005
    Beiträge
    201
    Danke
    0
    Thanked 0 Times in 0 Posts
    Also ich habe das Paket noch nicht getestet, aber ich nutze seit einigen Wochen die Boot Option für "i915.i915_enable_rc6" in Grub. Die andere Option für FBC habe ich sofort rausschmeissen müssen, weil es enorme Stabilitätsprobleme gab. Ich nutze einen X201 mit aktuellen 3.0.0.-12er-Kernel mit Inteltreibern von Xorg-Edgers. Da seit dem Versuch doch wieder einige Updates reingekommen sind, könnte es allerdings auch wieder funktionieren.

  5. #5

    Registriert seit
    05.10.2010
    Beiträge
    176
    Danke
    9
    Thanked 1 Time in 1 Post
    also ich habs jetzt auch bisschen getestet unter Kubuntu 11.10 mit nem T410 (Core i5 2,53 Ghz, Intel only)...Stabilitätsprobleme konnte ich keine feststellen, allerdings auch keinen spürbar besseren Stromverbrauch
    mfG Avathar
    T410: Core i5 2x2,53 | 8GB Ram | 120GB Crucial M4 & 500GB HDD | Nvidia Optimus | 14,1" WXGA+ | Kubuntu 15.04

  6. #6

    Registriert seit
    24.03.2011
    Beiträge
    168
    Danke
    0
    Thanked 0 Times in 0 Posts
    Zu den Kerneloptionen (atm noch manuell und ohne TLP) aber seit einigen Wochen im Einsatz.

    T420s Debian Testing Kernel 3.0:
    i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 bringt bei mir 6.5 Watt weniger Verbrauch.

    Generell läuft das stabil, allerdings wenn ich im laufenden Betrieb den internen Monitor per xrandr ausschalte und dann exklusiv auf den externen wechsle, schmiert in ca. 50% der Fälle der X-Server ab. Ich glaube - bin aber nicht sicher - das liegt an FBC.

  7. #7
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    10.958
    Danke
    8
    Thanked 94 Times in 75 Posts
    Themenstarter
    @ccyx: wäre sehr hilfreich wenn Du das noch eingrenzen könntest. Das Oneiric-Paket von TLP müßte auf Wheezy funktionieren.
    Gruß, linrunner

    X220, X200 - Ubuntu 14.04 64-bit - TLP - Ubuntu Schnelleinstieg - ThinkPad Extras PPA

  8. #8

    Registriert seit
    24.03.2011
    Beiträge
    168
    Danke
    0
    Thanked 0 Times in 0 Posts
    ich hab grad nochmal getestet und mal das TLP 0.3.4 installiert.
    die fehler / x-server abstürze scheinen nicht wirklich mit den stromspareinstellungen zusammenzuhängen. da scheint der treiber für die sandy-bridge chips allgmeien noch ein paar patzer zu haben. also meine abstürze bzw. seltsames verhalten, dass z.b. ein monitor ausgang bis zum neustart nicht mehr geht treten sowohl mit als auch ohne die stromspareinstellungen auf.

  9. #9
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    10.958
    Danke
    8
    Thanked 94 Times in 75 Posts
    Themenstarter
    @ccyx: Danke für die Rückmeldung. Den blockierenden Monitorausgang – Displayport am Dock – kenne ich auch vom X200 manchmal nach dem Andocken. X mit mehreren Schirmen hat so seine Tücken ... :-/
    Gruß, linrunner

    X220, X200 - Ubuntu 14.04 64-bit - TLP - Ubuntu Schnelleinstieg - ThinkPad Extras PPA

  10. #10
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    10.958
    Danke
    8
    Thanked 94 Times in 75 Posts
    Themenstarter
    Kleiner Push zum Sonntag: ich brauche noch einige Rückmeldungen um zu entscheiden ob RC6 und/oder FBC per Default eingeschaltet bleiben können.
    Gruß, linrunner

    X220, X200 - Ubuntu 14.04 64-bit - TLP - Ubuntu Schnelleinstieg - ThinkPad Extras PPA

  11. #11
    Avatar von Frieder108
    Registriert seit
    15.01.2010
    Beiträge
    1.363
    Danke
    0
    Thanked 12 Times in 11 Posts
    Hei linrunner, geb mir noch n bischen Zeit, hab gerade im T410 mit Intel HD 3000 ne neue (größere) FP eingebaut. Wird n Multiboot mit Win7, Lucid und Kubuntu 11.10.

    Sobald ich TLP auf 11.10 drauf habe, pack ich dir die Ausgabe von "powertop" hier rein. Wird irgendwann im Laufe des Nachmittag/früher Abend sein.

    Grüßle

    Frieder

  12. #12
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    10.958
    Danke
    8
    Thanked 94 Times in 75 Posts
    Themenstarter
    Keine Hektik . Mich interessiert weniger Powertop, sondern in erster Linie die Frage ob es stabil läuft.
    Gruß, linrunner

    X220, X200 - Ubuntu 14.04 64-bit - TLP - Ubuntu Schnelleinstieg - ThinkPad Extras PPA

  13. #13
    Avatar von Frieder108
    Registriert seit
    15.01.2010
    Beiträge
    1.363
    Danke
    0
    Thanked 12 Times in 11 Posts
    Hei, also

    tlp 0.3.3 ~11,5 W im Idle > lan an, FF und Dolphin offen

    tlp 0.3.4 ~8,8 W im Idle > lan an, FF und Dolphin offen

    beide Werte gelten für Akkubetrieb, Kubuntu ist frisch aufgesetz, aktualisiert und teilweise eingerichtet.

    Grüßle

    Frieder

    edit//
    Was verstehst du unter "stabil laufen" ?

    Es scheint wohl zu funktionieren, aber davon bin ich ausgegangen.
    Geändert von Frieder108 (09.10.2011 um 18:03 Uhr)

  14. #14

    Registriert seit
    24.11.2009
    Ort
    Dresden
    Beiträge
    45
    Danke
    0
    Thanked 0 Times in 0 Posts
    Hey linrunner,
    leider ergibt sich kein geringerer Stromverbrauch bei mir mit aktiviertem igpm.
    Gemessen habe ich idle mit höchster Helligkeit, wlan ein, ...

    hab ein x61 7674X05
    Graka:
    Code:
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c)
    	Subsystem: Lenovo T61 [17aa:20b5]
    	Kernel driver in use: i915
    tlp-ausgaben: http://paste.ubuntuusers.de/403377/
    Angehängte Grafiken Angehängte Grafiken

  15. #15
    Gewinnspielabräumer
    Registriert seit
    01.07.2008
    Ort
    BW
    Beiträge
    5.610
    Danke
    2
    Thanked 0 Times in 0 Posts
    Linrunner will wissen ob die FBC und RC6 aktiviert stabil laufen und nicht ob der Stromverbrauch sinkt - das ist nämlich nur bei manchen Laptops der Fall.
    Markplatz: ---

  16. #16

    Registriert seit
    24.11.2009
    Ort
    Dresden
    Beiträge
    45
    Danke
    0
    Thanked 0 Times in 0 Posts
    @ Evilandi666: ist mir schon klar, ob's stabil läuft konnte ich gestern noch nicht sagen. Jetzt kann ich sagen, dass es bei mir stabil läuft.

  17. #17

    Registriert seit
    05.10.2010
    Beiträge
    176
    Danke
    9
    Thanked 1 Time in 1 Post
    habs jetzt seit ca 5 Tagen und noch keine Abstürze, etc feststellen können
    mfG Avathar
    T410: Core i5 2x2,53 | 8GB Ram | 120GB Crucial M4 & 500GB HDD | Nvidia Optimus | 14,1" WXGA+ | Kubuntu 15.04

  18. #18
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    10.958
    Danke
    8
    Thanked 94 Times in 75 Posts
    Themenstarter
    Vielen Dank für alle bisherigen Rückmeldungen!
    Gruß, linrunner

    X220, X200 - Ubuntu 14.04 64-bit - TLP - Ubuntu Schnelleinstieg - ThinkPad Extras PPA

  19. #19

    Registriert seit
    17.06.2007
    Ort
    Berlin
    Beiträge
    1.709
    Danke
    0
    Thanked 0 Times in 0 Posts
    So, nun nach den genannten Einstellungen meine stats:

    --- tlp 0.3.4 --------------------------------------------
    System = LENOVO ThinkPad T420s 4173W15
    BIOS = 8CET48WW (1.28 )
    Release = Ubuntu 11.10
    Kernel = 3.0.0-11-generic x86_64

    tlp power save = enabled
    power source = battery

    /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor = performance
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor = performance
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor = performance
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor = performance

    /sys/devices/system/cpu/sched_mc_power_savings = 1
    /sys/devices/system/cpu/sched_smt_power_savings = 0
    /proc/sys/kernel/nmi_watchdog = (not available)

    /sys/devices/system/cpu/cpu?/cpufreq/phc_controls = (phc kernel not available)

    /proc/acpi/ibm/thermal = (thinkpad_acpi not available)

    /proc/sys/vm/laptop_mode = 2
    /proc/sys/vm/dirty_writeback_centisecs = 6000
    /proc/sys/vm/dirty_expire_centisecs = 6000
    /proc/sys/vm/dirty_ratio = 60
    /proc/sys/vm/dirty_background_ratio = 1
    /proc/sys/fs/xfs/age_buffer_centisecs = (not available)
    /proc/sys/fs/xfs/xfssyncd_centisecs = (not available)
    /proc/sys/fs/xfs/xfsbufd_centisecs = (not available)

    /dev/sda:
    Model = INTEL SSDSA2M160G2GC
    Firmware = 2CV102HD
    APM Level = none/disabled
    scheduler = deadline

    SMART info:
    4 Start_Stop_Count = 0
    5 Reallocated_Sector_Ct = 3
    9 Power_On_Hours = 675 [h]
    225 Host_Writes_32MiB = 2.334 [TB]
    232 Available_Reservd_Space = 99 [%]
    233 Media_Wearout_Indicator = 99 [%]

    /sys/class/scsi_host/host0/link_power_management_policy = min_power
    /sys/class/scsi_host/host1/link_power_management_policy = min_power
    /sys/class/scsi_host/host2/link_power_management_policy = min_power
    /sys/class/scsi_host/host3/link_power_management_policy = min_power
    /sys/class/scsi_host/host4/link_power_management_policy = min_power
    /sys/class/scsi_host/host5/link_power_management_policy = min_power

    /sys/module/pcie_aspm/parameters/policy = powersave

    /sys/module/i915/parameters/i915_enable_rc6 = 1
    /sys/module/i915/parameters/i915_enable_fbc = 1

    bluetooth = on
    wifi = on
    wwan = none (no device)

    wlan0(iwlagn): power management = on

    /sys/module/snd_hda_intel/parameters/power_save = 1
    /sys/module/snd_hda_intel/parameters/power_save_controller = Y

    /sys/devices/platform/smapi/BAT0/manufacturer = SANYO
    /sys/devices/platform/smapi/BAT0/manufacture_date = 2011-05-27
    /sys/devices/platform/smapi/BAT0/first_use_date = 2011-07-09
    /sys/devices/platform/smapi/BAT0/cycle_count = 9
    /sys/devices/platform/smapi/BAT0/design_capacity = 44000 [mWh]
    /sys/devices/platform/smapi/BAT0/last_full_capacity = 40590 [mWh]
    /sys/devices/platform/smapi/BAT0/remaining_capacity = 17400 [mWh]
    /sys/devices/platform/smapi/BAT0/remaining_percent = 43 [%]
    /sys/devices/platform/smapi/BAT0/remaining_running_time_now = 46 [min]
    /sys/devices/platform/smapi/BAT0/remaining_charging_time = not_charging [min]

    cat: /sys/devices/platform/smapi/BAT0/start_charge_thresh: Kein passendes Gerät bzw. keine passende Adresse gefunden
    /sys/devices/platform/smapi/BAT0/start_charge_thresh = [%]
    /sys/devices/platform/smapi/BAT0/stop_charge_thresh = 100 [%]

    tlp usb autosuspend = enabled
    tlp usb blacklist = (not configured)

    /sys/bus/usb/devices/1-1/power/autosuspend_delay_ms = 2000, control = auto -- 8087:0024 unknown device (hub)
    /sys/bus/usb/devices/1-1.3/power/autosuspend_delay_ms = 2000, control = auto -- 147e:2016 Biometric Coprocessor (no driver)
    /sys/bus/usb/devices/1-1.4/power/autosuspend_delay_ms = 2000, control = auto -- 0a5c:217f Broadcom Bluetooth Device (btusb)
    /sys/bus/usb/devices/1-1.6/power/autosuspend_delay_ms = 2000, control = auto -- 04f2:b221 Integrated Camera (uvcvideo)
    /sys/bus/usb/devices/2-1/power/autosuspend_delay_ms = 2000, control = auto -- 8087:0024 unknown device (hub)
    /sys/bus/usb/devices/2-1.5/power/autosuspend_delay_ms = 2000, control = auto -- 17ef:1003 Integrated Smart Card Reader (no driver)
    /sys/bus/usb/devices/usb1/power/autosuspend_delay_ms = 2000, control = auto -- 1d6b:0002 EHCI Host Controller (hub)
    /sys/bus/usb/devices/usb2/power/autosuspend_delay_ms = 2000, control = auto -- 1d6b:0002 EHCI Host Controller (hub)
    /sys/bus/usb/devices/usb3/power/autosuspend_delay_ms = 2000, control = auto -- 1d6b:0002 xHCI Host Controller (hub)
    /sys/bus/usb/devices/usb4/power/autosuspend_delay_ms = 2000, control = auto -- 1d6b:0003 xHCI Host Controller (hub)
    T420s Arbeitstier run by Ubuntu 12.04 LTS @core i5, 8GB RAM, 160GB SSD
    Samsung Galaxy Nexus run by Blackbean (JB) @
    Cortex A9 dual, 1GB RAM, 16GB SSD
    Samsung Galaxy Tab 7.7 run by Google Android 4.0.4 @Dual Core, 1GB RAM, 32GB SSD

  20. #20
    Ubuntuversteher Avatar von linrunner
    Registriert seit
    22.06.2007
    Beiträge
    10.958
    Danke
    8
    Thanked 94 Times in 75 Posts
    Themenstarter
    @Esc: sieht gut aus – die SSD hab ich auch .

    Schau mal in http://thinkpad-wiki.org/Messung_der...me_unter_Linux und Updates ziehen nicht vergessen (Kernel ist alt).
    Gruß, linrunner

    X220, X200 - Ubuntu 14.04 64-bit - TLP - Ubuntu Schnelleinstieg - ThinkPad Extras PPA

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
CeCon ok1.de ipWeb Campus Shop Buchtmonitor gbyte - Drupal Webentwicklung